Bug 71647 - RFE: redhat-config-* apps should log commands/things they do
RFE: redhat-config-* apps should log commands/things they do
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: redhat-config-network (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
: FutureFeature
Depends On:
Blocks: 81720
  Show dependency treegraph
 
Reported: 2002-08-15 22:28 EDT by Dax Kelson
Modified: 2007-11-30 17:10 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-07 05:14:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/explanations from Mandrake 9.0 beta 3 (5.52 KB, application/octet-stream)
2002-08-18 02:27 EDT, Warren Togami
no flags Details

  None (edit)
Description Dax Kelson 2002-08-15 22:28:56 EDT
It appears that the redhat-config-* apps will be the moral equiv of AIX's
SMIT/SMITTY, HP-UX's SAM, and Solaris's SMC.

One VERY nice feature of AIX's SMIT/SMITTY is that you can elect to see EXACTLY
what commands and changes are being made "behind the scenes".

Please consider adding such functionality to the redhat-config-* apps. Maybe a
"show work console window" button or logging all everything to a file in /var/log/.

Digging through the source and/or running strace/ltrace on the apps to
figure out exactly what they are doing is not fun.

Another benefit is that the legions of former Windows sys admins who will be
using the redhat-config-* tools will have an easier time becoming 'command line
jockeys'.

A major problem with all the Windows admin tools is that they 'hide' what's
going on. The whole "hood welded shut" phenomenon. 

Please keep the redhat-config-* tools from having their hoods welded shut.
Comment 1 R P Herrold 2002-08-17 01:29:07 EDT
Thanks for adding the RFE -- The development language aspect to some degree is
driving how much this can be done -- within python, one may either open a file
handle for logging to, or perhaps a preferred method would be to describe a
'sufficient' summary of the net config file changes with the syslog.

By using a scheme like:
  echo "echo "rh-c-n eth1 static 192.168.1.2 255.255.255.0." | \
         /usr/bin/logger -p local0.info
once gets a truly portable way to record the information.

It may be beter to use a series of logging entries:
   echo "echo "rh-c-n device=eth1 " | \
     /usr/bin/logger -p auth.warning
   echo "echo "rh-c-n proto=static " | \
     /usr/bin/logger -p auth.warning
and so forth ... the transaction series will automatically get the process ID
added by the syslog, so we can differientiate transaction groups.

What a concept -- using small *nix tools to build better tools.
Comment 2 R P Herrold 2002-08-17 01:33:44 EDT
The question of what, and how to log at initial install/upgrade Anaconda time
remains -- currently we append into the file down in /tmp -- having a syslog
thread running early is possible, but it is not possible to start it _too_ early
in an install or upgrade, because there may be no partition yet to hold the
destination syslog logging file.

A couple of approaches appear -- hold a temp file until the destination is
present, or just stay with the logging file, and maybe write a late process step
to dump, line by line, the conents of that file to a 'logger' once it _is_
possible to start a syslogd up ...
Comment 3 Warren Togami 2002-08-18 02:27:51 EDT
Created attachment 71325 [details]
/var/log/explanations from Mandrake 9.0 beta 3
Comment 4 Warren Togami 2002-08-18 02:28:51 EDT
alexl@redhat.com asked for example Mandrake DrakConf /var/log/explanations.  The
above attached is from my friend's computer.

It would be really nice if Red Hat's tools did something similar, perhaps to the
same log filename.
Comment 5 Dax Kelson 2002-08-18 16:44:59 EDT
To me, the install/upgrade case is handled by anaconda and uses the 
files /root/install.log and /root/upgrade.log. Are the redhat-config-* apps 
even used during install/upgrade?

The use of the redhat-config-* apps post install are, to me, the important 
case.

Comment 6 R P Herrold 2002-08-18 20:04:10 EDT
Thanks, Warren -- the content attached looks just like what my suggestion would 
have produced with logger, and an entry in the /etc/syslogd.conf file:

local0.*	/var/log/explanations

Comment 7 Trond Eivind Glomsrxd 2002-08-27 23:41:58 EDT
Later, perhaps.
Comment 8 R P Herrold 2002-09-30 21:54:18 EDT
Reopen as an RFE for post RHL 8.0 consideration in planning items for next release
Comment 11 Harald Hoyer 2003-05-27 05:44:41 EDT
http://people.redhat.com/harald/redhat-config-network
with -vvvvvv you'll see most writing/modifying actions
Comment 12 Dax Kelson 2003-05-27 10:36:45 EDT
As a matter of course (ie, automatically and always), all the redhat-config-*
apps should log what they do. To the file /var/log/redhat-config or something.

This RFE doesn't apply just to redhat-config-network, but to all the
redhat-config apps.
Comment 13 Warren Togami 2003-07-19 07:10:38 EDT
Any progress on this?
Comment 14 Harald Hoyer 2004-04-07 05:14:31 EDT
redhat/system-config-network  writes its changes to
/var/log/{redhat,system}-config-network

Note You need to log in before you can comment on or make changes to this bug.