Bug 716476 (CVE-2011-2502) - CVE-2011-2502 systemtap: insufficient security check when loading uprobes kernel module
Summary: CVE-2011-2502 systemtap: insufficient security check when loading uprobes ker...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2011-2502
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 717594 717596 725578
Blocks: 716497
TreeView+ depends on / blocked
 
Reported: 2011-06-24 15:26 UTC by Jan Lieskovsky
Modified: 2019-09-29 12:45 UTC (History)
7 users (show)

Fixed In Version: systemtap 1.6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-03 20:44:45 UTC


Attachments (Terms of Use)
Don't allow path-based auth for uprobes (2.35 KB, patch)
2011-06-25 05:23 UTC, Josh Stone
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2011:1088 normal SHIPPED_LIVE Moderate: systemtap security update 2011-07-25 21:46:31 UTC

Description Jan Lieskovsky 2011-06-24 15:26:45 UTC
It was found that systemtap runtime tool (staprun) did not properly enforce
the module's path sanity check, when the ad-hoc module instrumentation via
user-space probing with user-specified module path was requested. A local
user, member of the 'stapusr' group could use this flaw to escalate their
privileges.

Comment 1 Jan Lieskovsky 2011-06-24 15:32:22 UTC
This issue did NOT affect the versions of the systemtap package, as shipped
with Red Hat Enterprise Linux 4 and 5 as they do not provide support for
loading of user-space probing modules from user-specified locations yet.

--

This issue affects the version of the systemtap package, as shipped with
Red Hat Enterprise Linux 6.

--

This issue affects the versions of the systemtap package, as shipped with
Fedora release of 14 and 15.

Comment 3 Josh Stone 2011-06-25 05:23:40 UTC
Created attachment 509874 [details]
Don't allow path-based auth for uprobes

Comment 8 Vincent Danen 2011-07-25 21:44:40 UTC
Created systemtap tracking bugs for this issue

Affects: fedora-all [bug 725578]

Comment 9 errata-xmlrpc 2011-07-25 21:46:37 UTC
This issue has been addressed in following products:

  Red Hat Enterprise Linux 6

Via RHSA-2011:1088 https://rhn.redhat.com/errata/RHSA-2011-1088.html


Note You need to log in before you can comment on or make changes to this bug.