Bug 71655 - LogLevel setting causes pre-mature connection close with PHP
LogLevel setting causes pre-mature connection close with PHP
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-16 05:21 EDT by Jakob Xstergaard
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 06:48:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jakob Xstergaard 2002-08-16 05:21:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0; Linux)

Description of problem:
If the LogLevel in the apache configuration file is changed from the default "warn" to "notice", the server will start dropping connections. It will simply close the connection after having received the "GET /test.php HTTP/1.0" request, for roughly 1/3 of the requests. The other 2/3 of the requests will go thru just fine.

If the loglevel is changed to "info", no PHP requests will be served at all.

If however I fetch a static page, every single request will work just fine.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Set loglevel to "info"
2. Put a PHP-4 page on your server (using the standard redhat php modules)
3. Re-load the page, re-load, re-load, re-load

 

Actual Results:  Konqueror says "Connection broken". Wget says "Connection closed while parsing headers". An echo+telnet confirms that *nothing* is sent from the server after the GET request is accepted.


Expected Results:  It should have served the page.

Oh, and this is *NOT* a bug in the PHP page - we created a test page with a single "echo" statement in it, and it failed as well.


Additional info:

It's a RedHat 7.3 machine with all updates as of August 16th.

The server runs SSL, but these errors happen on non-SSL enabled sites. Haven't tested with SSL.

The server runs five virtual domains.  It doesn't see a lot of load, so it's not a performance related problem.
Comment 1 Joe Orton 2004-09-21 06:48:16 EDT
Thanks for the report.  This is a mass bug update; since this release
of Red Hat Linux is no longer supported, please either:

a) try and reproduce the bug with a supported version of Red Hat
Enterprise Linux or Fedora Core, and re-open this bug as appropriate
after changing the Product field, or,

b) if relevant, try and reproduce this bug using the current version
of the upstream package, and report the bug upstream.

Note You need to log in before you can comment on or make changes to this bug.