Bug 71656 - Segmentation fault occur for large (generated) C programs
Summary: Segmentation fault occur for large (generated) C programs
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-16 10:10 UTC by Need Real Name
Modified: 2007-04-18 16:45 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-01 15:57:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-08-16 10:10:15 UTC
Description of Problem:

Code that can be compiled without optimisation causes a segmentation fault
to occur with optimisation.

The same kind of code, only longer, will eventually also generate a
segmentation fault even without optimisation


Version-Release number of selected component (if applicable):

gcc 2.96

How Reproducible:

With the prompt set to `types XXX>' the following illustrates the problem

types 113> gcc -O -c glue.c
glue.c: In function `__PROC__':
glue.c:1700: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
types 114> gcc -c glue.c
types 115> 

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

The code can be found at

   http://www.imm.dtu.dk/~jsm/bugdata/glue.c

and a bigger version of it in bigglue.c, which causes an ordinary 
compilation to fail.

The symptoms seem to indicate a problem associated with table sizes.

Since the code is generated by a program, it is not attractive to 
break it up in smaller parts.

Comment 1 Alan Cox 2002-12-15 22:39:13 UTC
You dont include the header it references


Comment 2 Vladimir Makarov 2004-10-01 15:57:38 UTC
Unfortunately, we did not get header files to reporduce the bug.  Gcc
2.96 is too old now.  Its release cycle was finished long ago. 
Therefore I am closing the bug.  If it is still important the customer
could reopen it.


Note You need to log in before you can comment on or make changes to this bug.