This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 716591 - NetworkManager crashes when connecting to wireless network via kde-plasma-networkmanagement using NM 0.8 API
NetworkManager crashes when connecting to wireless network via kde-plasma-net...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
15
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 717043 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-25 04:01 EDT by Tomas Toth
Modified: 2011-07-18 23:18 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-18 23:18:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/messages (53.14 KB, text/plain)
2011-06-25 04:06 EDT, Tomas Toth
no flags Details
dmesg (4.40 KB, text/plain)
2011-06-25 04:07 EDT, Tomas Toth
no flags Details
/var/log/messages (30.68 KB, text/plain)
2011-06-25 04:43 EDT, Tomas Toth
no flags Details
dmesg (4.55 KB, text/plain)
2011-06-25 04:43 EDT, Tomas Toth
no flags Details

  None (edit)
Description Tomas Toth 2011-06-25 04:01:54 EDT
Description of problem:
Cannot connect to wireless network after NM update. I use the KDE's NM applet (or what is it?). The connection hangs at Setting Network Address phase. NM crashes.

Version-Release number of selected component (if applicable):
NetworkManager.x86_64               1:0.8.9997-4.git20110620.fc15
NetworkManager-glib.x86_64          1:0.8.9997-4.git20110620.fc15


How reproducible:
Always.


Steps to Reproduce:
1. "Enable Wireless" networking in the applet.
2. NM auto-detects the home Wifi network and tries to connect to it.
3. Wait.
 
Actual results:
The connection hangs and fails at Setting Network Address phase - user visible.
NM crashed, caught signal 11 - from logs.

Expected results:
Connection succeeds.
Comment 1 Tomas Toth 2011-06-25 04:06:08 EDT
Created attachment 509880 [details]
/var/log/messages

The relevant part of /var/log/messages which includes also the NM crash logs.
Comment 2 Tomas Toth 2011-06-25 04:07:12 EDT
Created attachment 509881 [details]
dmesg

Applicable part of dmesg.
Comment 3 Tomas Toth 2011-06-25 04:42:40 EDT
Since this issue is present there is also another one, attempts to edit wireless connections, disable them crashes plasma-desktop. It is not possible to report the issue by ABRT as it says: Reporting disabled because the backtrace is unusable.

I am attaching the /var/log/messages and dmesg.

Test: 
  Enable Wireless  @ 10:19:31
      NM crash     @ 10:19:54
  Disable Wireless @ 10:20:55
      KDE plasma-desktop crash  @ 10:20:56
Comment 4 Tomas Toth 2011-06-25 04:43:11 EDT
Created attachment 509883 [details]
/var/log/messages
Comment 5 Tomas Toth 2011-06-25 04:43:55 EDT
Created attachment 509884 [details]
dmesg
Comment 6 Jirka Klimes 2011-06-27 12:01:19 EDT
Fixed upstream in f15 branch: bd625c03159b3a858137ab08845855dcf2aad848

Please try scratch build with the fix:
http://koji.fedoraproject.org/koji/taskinfo?taskID=3163954
Comment 7 Tomas Toth 2011-06-27 13:04:52 EDT
The issue is (both issues are) fixed by the above scratch build.

Thanks!
Comment 8 Jirka Klimes 2011-06-28 02:58:10 EDT
*** Bug 717043 has been marked as a duplicate of this bug. ***
Comment 9 Germano Massullo 2011-06-28 10:20:30 EDT
Directly from https://bugs.kde.org/show_bug.cgi?id=276694 submitted with automatic crash report wizard...

Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.3 (4.6.3)
Qt Version: 4.7.2
Operating System: Linux 2.6.38.8-32.fc15.i686 i686
Distribution: "Fedora release 15 (Lovelock)"

-- Information about the crash:
I was trying to connect to wifi lan but it does not work and plasma crashes
immediately when I select one of avaible connections

The crash can be reproduced every time.

-- Backtrace:
Application: Shell del desktop di Plasma (plasma-desktop), signal: Segmentation
fault
[KCrash Handler]
#7  0x00000011 in ?? ()
#8  0x00746727 in NMPopup::updateHasWireless (this=0x85cced0) at
/usr/src/debug/networkmanagement-0.9/applet/nmpopup.cpp:536
#9  0x00747a42 in NMPopup::addInterfaceInternal (this=0x85cced0,
iface=0x8953df8) at /usr/src/debug/networkmanagement-0.9/applet/nmpopup.cpp:407
#10 0x00747ecc in NMPopup::interfaceAdded (this=0x85cced0, uni=...) at
/usr/src/debug/networkmanagement-0.9/applet/nmpopup.cpp:309
#11 0x0073f21b in NMPopup::qt_metacall (this=0x85cced0,
_c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe3f388) at
/usr/src/debug/networkmanagement-0.9/i686-redhat-linux-gnu/applet/moc_nmpopup.cpp:102
#12 0x42306ece in metacall (argv=0xbfe3f388, idx=21,
cl=QMetaObject::InvokeMetaMethod, object=0x85cced0) at
kernel/qmetaobject.cpp:237
#13 QMetaObject::metacall (object=0x85cced0, cl=QMetaObject::InvokeMetaMethod,
idx=21, argv=0xbfe3f388) at kernel/qmetaobject.cpp:232
#14 0x42314d9a in QMetaObject::activate (sender=0x8604db8, m=0x81c5f8,
local_signal_index=1, argv=0xbfe3f388) at kernel/qobject.cpp:3278
#15 0x007fc746 in
Solid::Control::NetworkManager::Notifier::networkInterfaceAdded
(this=0x8604db8, _t1=...) at
/usr/src/debug/kdebase-workspace-4.6.3/i686-redhat-linux-gnu/libs/solid/control/networkmanager.moc:110
#16 0x007fce1e in
Solid::Control::NetworkManagerPrivate::_k_networkInterfaceAdded
(this=0x8604db8, uni=...) at
/usr/src/debug/kdebase-workspace-4.6.3/libs/solid/control/networkmanager.cpp:199
#17 0x007fceae in Solid::Control::NetworkManagerPrivate::qt_metacall
(this=0x8604db8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>,
_a=0xbfe3f4e8) at
/usr/src/debug/kdebase-workspace-4.6.3/i686-redhat-linux-gnu/libs/solid/control/networkmanager_p.moc:81
#18 0x42306ece in metacall (argv=0xbfe3f4e8, idx=11,
cl=QMetaObject::InvokeMetaMethod, object=0x8604db8) at
kernel/qmetaobject.cpp:237
#19 QMetaObject::metacall (object=0x8604db8, cl=QMetaObject::InvokeMetaMethod,
idx=11, argv=0xbfe3f4e8) at kernel/qmetaobject.cpp:232
#20 0x42314d9a in QMetaObject::activate (sender=0x86c3570, m=0x7d0be8,
local_signal_index=1, argv=0xbfe3f4e8) at kernel/qobject.cpp:3278
#21 0x007ccd86 in Solid::Control::Ifaces::NetworkManager::networkInterfaceAdded
(this=0x86c3570, _t1=...) at
/usr/src/debug/kdebase-workspace-4.6.3/i686-redhat-linux-gnu/libs/solid/control/ifaces/networkmanager.moc:118
#22 0x008669eb in NMNetworkManager::deviceAdded (this=0x86c3570, objpath=...)
at
/usr/src/debug/kdebase-workspace-4.6.3/solid/networkmanager-0.7/manager.cpp:213
#23 0x0086a35b in NMNetworkManager::qt_metacall (this=0x86c3570,
_c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe3f668) at
/usr/src/debug/kdebase-workspace-4.6.3/i686-redhat-linux-gnu/solid/networkmanager-0.7/manager.moc:95
#24 0x42306ece in metacall (argv=0xbfe3f668, idx=16,
cl=QMetaObject::InvokeMetaMethod, object=0x86c3570) at
kernel/qmetaobject.cpp:237
#25 QMetaObject::metacall (object=0x86c3570, cl=QMetaObject::InvokeMetaMethod,
idx=16, argv=0xbfe3f668) at kernel/qmetaobject.cpp:232
#26 0x42314d9a in QMetaObject::activate (sender=0x85d0c80, m=0x8835f8,
local_signal_index=0, argv=0xbfe3f668) at kernel/qobject.cpp:3278
#27 0x00875036 in OrgFreedesktopNetworkManagerInterface::DeviceAdded
(this=0x85d0c80, _t1=...) at
/usr/src/debug/kdebase-workspace-4.6.3/i686-redhat-linux-gnu/solid/networkmanager-0.7/nm-manager-clientinterface.moc:161
#28 0x00875577 in OrgFreedesktopNetworkManagerInterface::qt_metacall
(this=0x85d0c80, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfe3f89c) at
/usr/src/debug/kdebase-workspace-4.6.3/i686-redhat-linux-gnu/solid/networkmanager-0.7/nm-manager-clientinterface.moc:105
#29 0x42748838 in QDBusConnectionPrivate::deliverCall (this=0x81efbc0,
object=0x85d0c80, msg=..., metaTypes=..., slotIdx=140541968) at
qdbusintegrator.cpp:941
#30 0x42752dd7 in QDBusCallDeliveryEvent::placeMetaCall (this=0x8bee098,
object=0x85d0c80) at qdbusintegrator_p.h:103
#31 0x42318bef in QObject::event (this=0x85d0c80, e=0x8bee098) at
kernel/qobject.cpp:1217
#32 0x42a32784 in notify_helper (e=0x8bee098, receiver=0x85d0c80,
this=0x8169e90) at kernel/qapplication.cpp:4462
#33 QApplicationPrivate::notify_helper (this=0x8169e90, receiver=0x85d0c80,
e=0x8bee098) at kernel/qapplication.cpp:4434
#34 0x42a37bc3 in QApplication::notify (this=0x8bee098, receiver=0x85d0c80,
e=0x8bee098) at kernel/qapplication.cpp:4209
#35 0x438b0002 in KApplication::notify (this=0x815ab70, receiver=0x85d0c80,
event=0x8bee098) at
/usr/src/debug/kdelibs-4.6.3/kdeui/kernel/kapplication.cpp:311
#36 0x423006ee in QCoreApplication::notifyInternal (this=0x815ab70,
receiver=0x85d0c80, event=0x8bee098) at kernel/qcoreapplication.cpp:731
#37 0x42304178 in sendEvent (event=<optimized out>, receiver=<optimized out>)
at kernel/qcoreapplication.h:215
#38 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0,
data=0x811bc00) at kernel/qcoreapplication.cpp:1372
#39 0x4230433d in QCoreApplication::sendPostedEvents (receiver=0x0,
event_type=0) at kernel/qcoreapplication.cpp:1265
#40 0x4232e925 in sendPostedEvents () at kernel/qcoreapplication.h:220
#41 postEventSourceDispatch (s=0x816c7b8) at
kernel/qeventdispatcher_glib.cpp:277
#42 0x418bf5bf in g_main_dispatch (context=0x816b6f0) at gmain.c:2441
#43 g_main_context_dispatch (context=0x816b6f0) at gmain.c:3014
#44 0x418bfd30 in g_main_context_iterate (context=0x816b6f0, block=1099754112,
dispatch=1, self=0x8170070) at gmain.c:3092
#45 0x418c006f in g_main_context_iteration (context=0x816b6f0, may_block=1) at
gmain.c:3155
#46 0x4232ed68 in QEventDispatcherGlib::processEvents (this=0x811cb20,
flags=...) at kernel/qeventdispatcher_glib.cpp:422
#47 0x42ae6fab in QGuiEventDispatcherGlib::processEvents (this=0x811cb20,
flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#48 0x422ffa2e in QEventLoop::processEvents (this=0xbfe40054, flags=...) at
kernel/qeventloop.cpp:149
#49 0x422ffc81 in QEventLoop::exec (this=0xbfe40054, flags=...) at
kernel/qeventloop.cpp:201
#50 0x423043eb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#51 0x42a30565 in QApplication::exec () at kernel/qapplication.cpp:3736
#52 0x443b2ec6 in kdemain (argc=1, argv=0xbfe40254) at
/usr/src/debug/kdebase-workspace-4.6.3/plasma/desktop/shell/main.cpp:120
#53 0x0804876c in main (argc=1, argv=0xbfe40254) at
/usr/src/debug/kdebase-workspace-4.6.3/i686-redhat-linux-gnu/plasma/desktop/shell/plasma-desktop_dummy.cpp:3

Reported using DrKonqi
Comment 10 Tomas Toth 2011-07-07 15:11:17 EDT
Also works fine with the latest updates:
NetworkManager.x86_64                     1:0.8.9997-5.git20110702.fc15
NetworkManager-glib.x86_64                1:0.8.9997-5.git20110702.fc15
kde-plasma-networkmanagement.x86_64       1:0.9-0.53.20110616git.nm09.fc15
kde-plasma-networkmanagement-libs.x86_64  1:0.9-0.53.20110616git.nm09.fc15
Comment 11 Dan Williams 2011-07-18 23:18:50 EDT
Latest NM actually has disabled the NM 0.8 compat API since kde-plasma-networkmanagement now supports the NM 0.9 API.

Note You need to log in before you can comment on or make changes to this bug.