Bug 7166 - Niggles in top.
Niggles in top.
Status: CLOSED DUPLICATE of bug 7165
Product: Red Hat Linux
Classification: Retired
Component: procps (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Depends On:
  Show dependency treegraph
Reported: 1999-11-19 20:18 EST by dwmalone
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 1999-11-22 10:57:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description dwmalone 1999-11-19 20:18:04 EST
Top seems to have behavior unlike any other version of top I've
used. I've one bug and one feature request.

1) Running top through rsh bogusly reports that TERM is set to
VT100 - I note that strings shows that VT100 is a string in top.
Other versions of top seem to show 24 lines of output in the
situation where they are not connected to a tty. (Note, $TERM
definitely doesn't contain VT100):
1:21:walton 71% rsh graves top
top: Unknown terminal "VT100" in $TERM
1:21:walton 72% rsh graves echo $TERM

2) When sending a signal top only allows you to give the number
of one process, it would be nice to be able to give a list. Also
it would be nice if you could give the signal number on the PID
line, so you can do something like "k -9 3927 7320 9327".

Comment 1 Bill Nottingham 1999-11-22 10:57:59 EST
*** This bug has been marked as a duplicate of 7165 ***

Note You need to log in before you can comment on or make changes to this bug.