Bug 71662 - dhcpd creates illegal leases after dhcprequest
Summary: dhcpd creates illegal leases after dhcprequest
Status: CLOSED DUPLICATE of bug 62948
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dhcp (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-16 13:14 UTC by Tuomas Toropainen
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-17 20:59:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dhcp lease, logs and tcpdump output of problem (9.13 KB, text/plain)
2002-08-16 13:17 UTC, Tuomas Toropainen
no flags Details

Description Tuomas Toropainen 2002-08-16 13:14:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20020128

Description of problem:
When dhcp client requests address with DHCPREQUEST, dhcp server creates lease
with start time later than end time. And then it gives out duplicate ip
addresses. This happens only with linux dhcp clients, not windows. I'm not sure
what triggered this in the beginning, as this has not always been the case.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. obtain dhcp address for client with dhcpdiscover
2. try to obtain same address again, with dhcprequest
3. look at dhcp server lease file and there it is.

Actual Results:  dhcp server creates lease with start time one second after end
time:

lease 193.166.2.72 {
        starts 3 2002/07/17 14:12:46;
        ends 3 2002/07/17 14:12:45;
        hardware ethernet 00:50:04:8e:8d:30;
        uid 01:00:50:04:8e:8d:30;
        client-hostname "jullikka";
}


Expected Results:  Lease should have reasonable start and end times.

Additional info:

look at attachment for detail tcpdump and log information.

Comment 1 Tuomas Toropainen 2002-08-16 13:17:47 UTC
Created attachment 71084 [details]
dhcp lease, logs and tcpdump output of problem

Comment 2 Olivier Baudron 2002-08-16 15:37:51 UTC
This is dupplicate of bug 62948. Fixed in rawhide.

Comment 3 Pekka Savola 2002-08-17 21:00:25 UTC

*** This bug has been marked as a duplicate of 62948 ***


Note You need to log in before you can comment on or make changes to this bug.