Bug 7167 - Installer couldn't see CD in ATAPI CD-ROM drive
Installer couldn't see CD in ATAPI CD-ROM drive
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jay Turner
http://www.aq.org/~js/RH6.1-problems....
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-19 23:40 EST by Jay Sekora
Modified: 2015-01-07 18:39 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-29 12:15:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Sekora 1999-11-19 23:40:10 EST
When I booted from floppy (from the boot-RHEA-1999:044.img disk), the
installer couldn't see my CD in the ATAPI CD-ROM. After I was asked
where the installation media was and said `Local CDROM', the screen
cleared to blue and there was a very very long pause (several minutes)
during which my IDE CD-ROM spun up and down a couple times and its
light came on. Then the installation program said `I could not find a
RedHat CD in any of your CD-ROM drives'. (Yes, there was one in the
drive. :-)

Although an ATAPI CD-ROM is pretty vanilla hardware, I guessed that
maybe some prior hardware probe might have been causing it to
misbehave somehow, so I tried an expert-mode installation. That did
not give me an option to read from an ordinary ATAPI CD-ROM drive.
However, fortunately I happen to have a SCSI CD-R, which expert mode
was able to see. I put the RedHat CD in the SCSI CD-R, and the
installer found it and I was able to do the upgrade.

After the installation, the CD-ROM was seen normally; dmesg includes:
  hdb: BCD-16X 1997-03-25, ATAPI CDROM drive
  hdb: ATAPI 10X CD-ROM drive, 128kB Cache

By the way, the pause after `running /sbin/loader' is extremely long;
it might be useful to change that message to `running /sbin/loader;
please wait' or precede it with `It is normal for the following step
to take a long time' or something like that.

(Since I've already accomplished the install, this is a matter of
curiosity for me and a bug report, rather than something I personally
need a fix for.)
Comment 1 Jay Sekora 1999-11-20 20:37:59 EST
Fascinating.  I've since discovered that the problem occurs after installation
too - but *just* with the RedHat 6.1 installation CD.  I can mount it in my
SCSI CD-RW drive, and I can mount other CDs in my ATAPI drive, but I can't
mount the RH6.1 install CD in my ATAPI drive.  Maybe it's a problem with the
media (but a problem that my SCSI drive manages to overcome).  Anyway, I suspect
this is not a kernel or boot disk bug at this point.
Comment 2 Jay Sekora 1999-11-20 20:42:59 EST
I can't mount the RedHat SRPMs CD from my box set either.  (Sometimes I
eventually get "no medium found", sometimes the mount attempt just hangs
until I ^C it.)  I *can* mount the Linux Application Library and PowerTools
CDs that came with my (deluxe) boxed set, and other important CDs like my
Quake CD.
Comment 3 Jay Turner 1999-11-29 12:15:59 EST
I am closing out this bug as it appears to have nothing to do with the installer
and more to do with recognizing ATAPI cdroms.
Comment 4 John Waalkes 1999-11-30 14:23:59 EST
I'm (possibly) adding a simular bug regarding this too. But what I found was
that if you ejected the CD, and retried the install, it would take off fine.

Note You need to log in before you can comment on or make changes to this bug.