Bug 716708 - Could not read temperature from your system
Summary: Could not read temperature from your system
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell-extension-cpu-temperature
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fabian Affolter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-06-26 15:07 UTC by Eric Tanguy
Modified: 2011-11-17 23:43 UTC (History)
5 users (show)

Fixed In Version: gnome-shell-extension-cpu-temperature-0-0.3.git1f471c7.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-17 23:43:12 UTC
Type: ---


Attachments (Terms of Use)

Description Eric Tanguy 2011-06-26 15:07:37 UTC
Description of problem:

The applet says "could not read temperature from your system. please report"
I don't know wht you need as information
cat /proc/cpuinfo

processor	: 0
vendor_id	: AuthenticAMD
cpu family	: 15
model		: 47
model name	: AMD Athlon(tm) 64 Processor 3000+
stepping	: 2
cpu MHz		: 1000.000
cache size	: 512 KB
fpu		: yes
fpu_exception	: yes
cpuid level	: 1
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext fxsr_opt lm 3dnowext 3dnow up rep_good nopl extd_apicid pni lahf_lm
bogomips	: 2009.00
TLB size	: 1024 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 2 Fedora Update System 2011-07-15 12:56:09 UTC
gnome-shell-extension-cpu-temperature-0-0.2.gitcdc83b0.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gnome-shell-extension-cpu-temperature-0-0.2.gitcdc83b0.fc15

Comment 3 Fedora Update System 2011-07-16 07:27:11 UTC
Package gnome-shell-extension-cpu-temperature-0-0.2.gitcdc83b0.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-shell-extension-cpu-temperature-0-0.2.gitcdc83b0.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/gnome-shell-extension-cpu-temperature-0-0.2.gitcdc83b0.fc15
then log in and leave karma (feedback).

Comment 4 Eric Tanguy 2011-07-16 14:42:25 UTC
With this update the new temperature is : NaN°C ...

Comment 5 Christian Jose 2011-07-18 20:25:14 UTC
Fixed for me by installing:
lm_sensors-3.3.0-2.fc15.x86_64
gnome-shell-extension-cpu-temperature-0-0.2.gitcdc83b0.fc15.noarch

(The previous version, gnome-shell-extension-cpu-temperature-0-0.1.git712153f.fc15.noarch, was trying to read /sys/bus/acpi/devices/LNXTHERM\:00/thermal_zone/temp as far as I can tell, which didn't exist on my system.)

Comment 6 Fedora Update System 2011-07-18 22:28:49 UTC
gnome-shell-extension-cpu-temperature-0-0.2.gitcdc83b0.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Eric Tanguy 2011-07-19 05:16:21 UTC
Reopen the bug because now the temperature is : NaN°C

Comment 8 mgrider 2011-09-25 20:53:31 UTC
AMD Phenom II 1090T CPU temp appears to be here on my system: /sys/devices/platform/it87.552/temp3_input
When I swapped it into the Java Script, in place of one of the existing 5 items in the array, it worked for me.

Comment 9 brandongeise 2011-09-28 03:18:17 UTC
AMD Athlon 64 X2 4600+ temp is here on my system:

/sys/devices/platform/w83627ehf.656/temp3_input

I did the same as mgrider and replaced one of the items in the array restarted gnome-shell and everything works.

Comment 10 Fedora Update System 2011-11-14 19:10:28 UTC
gnome-shell-extension-cpu-temperature-0-0.3.git1f471c7.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gnome-shell-extension-cpu-temperature-0-0.3.git1f471c7.fc16

Comment 11 Fedora Update System 2011-11-16 00:29:42 UTC
Package gnome-shell-extension-cpu-temperature-0-0.3.git1f471c7.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-shell-extension-cpu-temperature-0-0.3.git1f471c7.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15958
then log in and leave karma (feedback).

Comment 12 Fedora Update System 2011-11-17 23:43:12 UTC
gnome-shell-extension-cpu-temperature-0-0.3.git1f471c7.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.