Bug 71675 - RFE: dosutils should include BootIt, a shareware NTFS resizer
RFE: dosutils should include BootIt, a shareware NTFS resizer
Status: CLOSED WONTFIX
Product: Red Hat Public Beta
Classification: Retired
Component: distribution (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-16 11:51 EDT by Mike MacCana
Modified: 2007-04-18 12:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-19 20:24:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike MacCana 2002-08-16 11:51:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux)

Description of problem:
This is not a parted bug, but I couldn't identify the correct component for FIPS or the contents of the dosutils directory on the CD.

Versions of Windows since Windows NT4, including all current cnsumer and release versions of Windows, use NTFS as their default filesystem. Neither parted nor FIPS can resize NTFS partitions on Windows NT4, 2000, or XP. As tiem goes on, this will become a bigger problem, but its already a major hassle for people dual booting.

Ideally, GNU Parted should be able to do this, but it currently cannot and stable support for NTFS in its various incarantions will take a long time.
 
There is a small shareware application balled BootItNG that can resize NTFS and FAT partitions non-destructively. Although it is not Open Source, Red Hat have a policy of including / using non-Open Source applications if there are not suitable Open Source alternatives for the job. This is one of those cases. 

By providing BootIt in the dosutils folder, Red Hat will allow people running NT4, 2000 and Windows XP to easily resize their partitions and dual boot with Linux. The BootItNG authors in turn will get their shareware exposed to potential customers. No, I don't work for the authors, I just want Red Hat to be able to dual boot easily with modern Windows OSs as older ones.

http://www.terabyteunlimited.com/bootitng.html



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Find a PC with Windows XP, 2000 or NT4 installed.
2.Attempt to make room for a dual boot with Red Hat Linux, and find a utility to resize the partitions, which will by default be in NTFS
	

Actual Results:  There are no utilities on the Red Hat CD to dual boot with current Windows distributions

Expected Results:  Red Hat should provide a utility (BootITNG) to resize modern (NTFS) Windows partitions just as they currently do with older Windows (FAT, FAT32) partitions (FIPS).

Additional info:
Comment 1 Mike MacCana 2002-08-19 20:24:34 EDT
Changed component appropriately.
Comment 2 Bill Nottingham 2002-08-20 00:09:04 EDT
I don't think we'd be including shareware on the CD; among othe reasons, we sell
the CDs.

Note You need to log in before you can comment on or make changes to this bug.