Bug 716799 - Fedora 15 install cd failed to boot: no root device
Fedora 15 install cd failed to boot: no root device
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
16
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-27 02:39 EDT by gostrc
Modified: 2013-02-01 10:13 EST (History)
11 users (show)

See Also:
Fixed In Version: dracut-013-19.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-23 18:29:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg output for no quiet rhgb kernel options (57.20 KB, application/octet-stream)
2011-10-04 19:50 EDT, gostrc
no flags Details
dmesg output for no quiet rhgb kernel options with added rdshell rdinitdebug kernel options (118.27 KB, application/octet-stream)
2011-10-04 19:51 EDT, gostrc
no flags Details
working archlinux boot log (54.77 KB, text/x-log)
2011-11-02 19:50 EDT, gostrc
no flags Details
archlinux boot log with loglevel=8 (53.94 KB, text/x-log)
2011-11-03 15:47 EDT, gostrc
no flags Details
lspci -v from archlinux (10.07 KB, text/x-log)
2011-11-03 17:51 EDT, gostrc
no flags Details
lsusb -v from archlinux (33.36 KB, text/x-log)
2011-11-03 17:51 EDT, gostrc
no flags Details
fedora boot log with loglevel=8 (56.32 KB, text/x-log)
2011-11-04 10:56 EDT, gostrc
no flags Details
lspci -v from fedora (11.69 KB, text/x-log)
2011-11-04 10:56 EDT, gostrc
no flags Details
lsusb -v from fedora (40.78 KB, text/x-log)
2011-11-04 10:57 EDT, gostrc
no flags Details
working dmesg log for fedora 16 RC4 (57.10 KB, text/x-log)
2011-11-04 12:53 EDT, gostrc
no flags Details
lspci from fedora 16 rescue DVD install disc (7.74 KB, text/plain)
2011-11-12 20:14 EST, Mariusz
no flags Details
lsusb from fedora 16 rescue DVD install disc (35.18 KB, text/plain)
2011-11-12 20:17 EST, Mariusz
no flags Details
dmesg from fedora 16 rescue DVD install disc (83.73 KB, text/plain)
2011-11-12 20:18 EST, Mariusz
no flags Details
results Boot Info Script 0.60 from fedora 16 rescue DVD install disc (5.59 KB, text/plain)
2011-11-12 20:21 EST, Mariusz
no flags Details
grub2.cfg from fedora 16 rescue DVD install disc (2.82 KB, application/octet-stream)
2011-11-12 20:22 EST, Mariusz
no flags Details
/etc/defaults/grub from fedora 16 rescue DVD install disc (184 bytes, application/octet-stream)
2011-11-12 20:23 EST, Mariusz
no flags Details
ls -l /boot from fedora 16 rescue DVD install disc (580 bytes, text/plain)
2011-11-12 20:24 EST, Mariusz
no flags Details

  None (edit)
Description gostrc 2011-06-27 02:39:08 EDT
Description of problem:
I have downloaded the fedora 15 i686 live desktop iso and verified the checksum.
I have also verified the burned cd.

When I reboot my computer, it gets to the fedora boot splash screen, loads about half way, and goes to the following message (after disabling the splash screen):

Warning no root device live: "/dev/disk/by-label/Fedora-15-i686-Live-Desktop.iso" found
Dropping to debug shell
sh: can't access tty; job control turned off
dracut:/#

I have checked, and there is no "by-label" folder under /dev/disk

The laptop I'm trying to boot off of is a sony vgn-bx760.
Under the bios, the cd drive is seen as a usb swappable drive.

I am unable to boot Fedora 15 and Scientific Linux 6.0 because of this error.
All other OSes I have tried, have had their install cds booted successfully. (winxp, win7, ubuntu, archlinux)

If there is any more info I can provide, please let me know.
I really want to see this bug fixed in future versions of Fedora.

Version-Release number of selected component (if applicable):
Fedora 15 i686 Live Desktop cd

How reproducible:
Every time.

Steps to Reproduce:
1. Boot livecd and pick any option in grub that boots from the cd.
  
Actual results:
Fails to boot into live cd.

Expected results:
Succeeds in booting.

Additional info:
http://forums.fedoraforum.org/showthread.php?p=1489179
Comment 1 gostrc 2011-06-27 11:30:17 EDT
Some additional info:
dmsetup ls --tree returns "No Devices Found"

When it dropped me to the dracut shell, I don't have /dev/cdrom and I don't have /dev/sr0
Comment 2 Harald Hoyer 2011-06-30 09:32:57 EDT
(In reply to comment #1)
> Some additional info:
> dmsetup ls --tree returns "No Devices Found"
> 
> When it dropped me to the dracut shell, I don't have /dev/cdrom and I don't
> have /dev/sr0

Oh.. wow.. no /dev/sr0 !!
Comment 3 gostrc 2011-06-30 10:22:07 EDT
I still experience this problem, but I managed to create a live USB using Fedora's live usb creator.
I then booted and it dropped me to dracut shell once again.
But this time I saw that /dev/sdb was there!
I changed the grub boot line from some UUID that was in there to /dev/sdb and it booted and I managed to install Fedora :)
Comment 4 gostrc 2011-10-04 17:36:59 EDT
Well since this bug has been closed as "worksforme", I would like to take the time to explain that this probably isn't a bug that everyone will experience because it depends on specific hardware.

Unless you have a spare sony vgn-bx760 laptop hanging around, I believe this is a legitimate bug report. 

Lo and behold, I just tried fedora 16 beta and I get this same bug.
I bet this bug has been there for a while now since I even experience it with centos 5/6 and scientific linux 5/6 also.

This is why I'm going to reopen this bug report and hopefully I can work with you guys somehow and try to get to the bottom of this. Closing this bug as "worksforme" without any further explanation really hurts me because I have taken the time to file it instead of ignoring it and going with another distribution (non-redhat).
Comment 5 Josh Boyer 2011-10-04 17:53:06 EDT
My mistake.  Thank you for trying the f16 beta.  Could you post the full boot output of that boot?
Comment 6 gostrc 2011-10-04 19:50:56 EDT
Created attachment 526348 [details]
dmesg output for no quiet rhgb kernel options
Comment 7 gostrc 2011-10-04 19:51:32 EDT
Created attachment 526349 [details]
dmesg output for no quiet rhgb kernel options with added rdshell rdinitdebug kernel options
Comment 8 gostrc 2011-10-04 19:54:08 EDT
Thanks for letting me reopen this and for everyone's time.

I have attached boot messages for both a clean (no rhgb quiet) option and one with additional kernel options (rdshell rdinitdebug).

Let me know what else I could provide for this bug.
Comment 9 Tony Browning 2011-10-12 23:28:45 EDT
This same bug during boot has happened to me also yesterday once but it never followed the no rhgb quiet command. It also displayed sh and displayed something like "your job control has stopped" or something of the sort and it does this mostly everytime>>>>.....
I'm expericing the same problem after boot-up without disk, (error message) (no root device found, boot failed, sleeping forever) and I am now using the same Toshiba Model100 laptop giving me this problem to write this now. But to be able to use this laptop I have to use a Fedora 15 live boot disk and I would like to save the Fedora 15 to my empty 100 GB partitioned and titled /media/vg-toshiba100 ext4 hard disk if possible. My problem began when I format (cleaned) the just mentioned hard disk of Fedora 14 so I could update to Fedora 15. In hard drive 4 devices are there:
Device 1. /dev/sr0, Mount Point: /run/initramfs/live, FilesystemType: iso9660, Total Size: 643.6MB, Availible: 0bytes.
Device 2. /dev/sr0, Mount Point: /mnt/live, FilesystemType: iso9660, Total Size: 643.6MB, Availible: 0bytes.
Device 3. /dev/mapper/live-rw/, Mount Point: is just forward slash, / , FilesystemType: ext 4, TotalSize: 3.9GB, Availible: 2.0GB
Device 4. /dev/sda2, Mount Point: /media/vg-toshiba100, FilesystemType: ext 4, TotalSize: 91.2GB, Availible: 91.2GB
In the disk analyzer tree and/or pie it shows that all of Fedora 15 files of drivers and libraries are there along with linux kernel 2.6.38.2-9.fc15.i686. I ran all the test and it reads that my disk is healthy! Any help would be most appreciative.
Comment 10 Josh Boyer 2011-11-02 13:47:43 EDT
(In reply to comment #8)
> Thanks for letting me reopen this and for everyone's time.
> 
> I have attached boot messages for both a clean (no rhgb quiet) option and one
> with additional kernel options (rdshell rdinitdebug).
> 
> Let me know what else I could provide for this bug.

Hm.  So the /dev/sdb showing up after you get to the prompt seems to be your iPod being detected as a mass-storage device.  I think that is unrelated to not finding the "rootfs" on the live image.

Could you possibly attach the boot logs from a working Linux install?  Either Ubuntu or Arch is fine (or both), as long as I can see the device detection portions.
Comment 11 gostrc 2011-11-02 19:50:46 EDT
Created attachment 531463 [details]
working archlinux boot log
Comment 12 gostrc 2011-11-02 19:51:57 EDT
I have attached the boot log for my working archlinux installation.
Comment 13 Josh Boyer 2011-11-02 20:44:44 EDT
Hm.  When you boot the live images (that latest RC4 image would be good to test), and you get dropped to a prompt, can you do:

cat /sys/devices/platform/sony-laptop/cdpower

If that file doesn't exist, can you do:

modprobe sony-laptop

and check again?  If the value is 0, try:

echo "1" > /sys/devices/platform/sony-laptop/cdpower

and see if the sr0 device shows up in dmesg.
Comment 14 gostrc 2011-11-03 01:23:22 EDT
I tried cat /sys/devices/platform/sony-laptop/cdpower and it said the file didn't exist.

So I tried modprobe sony-laptop (with a dash) and it said module sony_laptop (with an underscore) not found.
Comment 15 Josh Boyer 2011-11-03 08:50:31 EDT
(In reply to comment #14)
> I tried cat /sys/devices/platform/sony-laptop/cdpower and it said the file
> didn't exist.
> 
> So I tried modprobe sony-laptop (with a dash) and it said module sony_laptop
> (with an underscore) not found.

Well... that might be the actual problem then.  Which image did you use exactly so I can go poke around in the contents?

Harald, do you know if the live images have a restricted module set that would exclude some of the x86 platform drivers?
Comment 17 Josh Boyer 2011-11-03 14:58:08 EDT
Would you be willing to boot the ARCH install with loglevel=8 or debug set on the kernel command line?  I'd like to see the full device detection of the ARCH kernel.  It would be nice to compare two 3.1 kernels as well, but it seems even the latest arch snapshot is still based on 3.0.
Comment 18 gostrc 2011-11-03 15:47:49 EDT
Created attachment 531647 [details]
archlinux boot log with loglevel=8
Comment 19 gostrc 2011-11-03 15:55:33 EDT
Attched the dmesg output while booting linux 3.0.7 with loglevel=8.

The 3.1 kernel is in the testing repos and there have been some bugs which have been discovered which were worthy of keeping it in testing for now.
Comment 20 Josh Boyer 2011-11-03 16:09:27 EDT
Just to make sure I didn't missing something, you did have an iPod plugged into the machine when you booted what is attached in comment #6, right?
Comment 21 Josh Boyer 2011-11-03 16:15:20 EDT
And can we get a dump of lsusb -v and lspci -v from the arch install?
Comment 22 gostrc 2011-11-03 17:50:22 EDT
(In reply to comment #20)
> Just to make sure I didn't missing something, you did have an iPod plugged into
> the machine when you booted what is attached in comment #6, right?

I plugged in the ipod after getting dropped to the dracut shell.
Comment 23 gostrc 2011-11-03 17:51:31 EDT
Created attachment 531664 [details]
lspci -v from archlinux
Comment 24 gostrc 2011-11-03 17:51:52 EDT
Created attachment 531665 [details]
lsusb -v from archlinux
Comment 25 gostrc 2011-11-03 17:53:35 EDT
(In reply to comment #21)
> And can we get a dump of lsusb -v and lspci -v from the arch install?

Certainly, attached both files.
Comment 26 Josh Boyer 2011-11-03 21:35:48 EDT
(In reply to comment #25)
> (In reply to comment #21)
> > And can we get a dump of lsusb -v and lspci -v from the arch install?
> 
> Certainly, attached both files.

And possibly the same from the Fedora live image?

I really appreciate your willingness to help.  The theory about the sony-laptop driver is probably incorrect since the power to the cdrom driver would have to be on for the live image to boot anyway.  So we're still trying to figure out what the difference between the ARCH kernel and the Fedora kernel is.  I looked at the source, but there are no patches that seem related at all so it's likely a config setting.
Comment 27 gostrc 2011-11-03 23:19:18 EDT
(In reply to comment #26)
> (In reply to comment #25)
> > (In reply to comment #21)
> > > And can we get a dump of lsusb -v and lspci -v from the arch install?
> > 
> > Certainly, attached both files.
> 
> And possibly the same from the Fedora live image?
> 

I couldn't run lsusb/lspci because it said those commands were not found.

> I really appreciate your willingness to help.  The theory about the sony-laptop
> driver is probably incorrect since the power to the cdrom driver would have to
> be on for the live image to boot anyway.  So we're still trying to figure out
> what the difference between the ARCH kernel and the Fedora kernel is.  I looked
> at the source, but there are no patches that seem related at all so it's likely
> a config setting.

And I the same with your willingness to help me :)
Comment 28 Josh Boyer 2011-11-04 09:39:59 EDT
(In reply to comment #27)
> > And possibly the same from the Fedora live image?
> > 
> 
> I couldn't run lsusb/lspci because it said those commands were not found.

Ugh, right.  The live image is space limited and your machine isn't finding the contents anyway because of the missing drive.  Hm.  That probably means you'll have similar problems booting from the DVD iso into a rescue mode so that won't help.

Would it be possible to install the Fedora kernel RPM in the ARCH installation and boot ARCH with that kernel?

I've been looking at the differences in the kernel configs and the biggest things that stick out are CONFIG_IDE not being set in the Fedora kernel, and ums-cypress not getting loaded (or present in) the initrd.
Comment 29 Harald Hoyer 2011-11-04 10:26:53 EDT
(In reply to comment #15)
> (In reply to comment #14)
> > I tried cat /sys/devices/platform/sony-laptop/cdpower and it said the file
> > didn't exist.
> > 
> > So I tried modprobe sony-laptop (with a dash) and it said module sony_laptop
> > (with an underscore) not found.
> 
> Well... that might be the actual problem then.  Which image did you use exactly
> so I can go poke around in the contents?
> 
> Harald, do you know if the live images have a restricted module set that would
> exclude some of the x86 platform drivers?

yes... sony_laptop might not be included in the dracut initramfs, which is used for the livecd.

I can hardcode it though.
Comment 30 gostrc 2011-11-04 10:56:10 EDT
Created attachment 531784 [details]
fedora boot log with loglevel=8
Comment 31 gostrc 2011-11-04 10:56:43 EDT
Created attachment 531786 [details]
lspci -v from fedora
Comment 32 gostrc 2011-11-04 10:57:07 EDT
Created attachment 531788 [details]
lsusb -v from fedora
Comment 33 gostrc 2011-11-04 11:00:49 EDT
(In reply to comment #28)
> (In reply to comment #27)
> > > And possibly the same from the Fedora live image?
> > > 
> > 
> > I couldn't run lsusb/lspci because it said those commands were not found.
> 
> Ugh, right.  The live image is space limited and your machine isn't finding the
> contents anyway because of the missing drive.  Hm.  That probably means you'll
> have similar problems booting from the DVD iso into a rescue mode so that won't
> help.
> 

I managed to hunt down all packages required to run lsusb and lspci and extracted them manually and copied them over to the dracut environment.
I have attached output from lspci -v, lsusb -v, and dmesg with loglevel=8 for fedora 16 RC4.
Hope this helps.
Again, the ipod message in dmesg was plugged in after getting dropped to the shell.

> Would it be possible to install the Fedora kernel RPM in the ARCH installation
> and boot ARCH with that kernel?
> 

Do you still want me to look into this after I have attached the above files?

> I've been looking at the differences in the kernel configs and the biggest
> things that stick out are CONFIG_IDE not being set in the Fedora kernel, and
> ums-cypress not getting loaded (or present in) the initrd.
Comment 34 Josh Boyer 2011-11-04 11:28:53 EDT
(In reply to comment #33)
> (In reply to comment #28)
> > (In reply to comment #27)
> > > > And possibly the same from the Fedora live image?
> > > > 
> > > 
> > > I couldn't run lsusb/lspci because it said those commands were not found.
> > 
> > Ugh, right.  The live image is space limited and your machine isn't finding the
> > contents anyway because of the missing drive.  Hm.  That probably means you'll
> > have similar problems booting from the DVD iso into a rescue mode so that won't
> > help.
> > 
> 
> I managed to hunt down all packages required to run lsusb and lspci and
> extracted them manually and copied them over to the dracut environment.
> I have attached output from lspci -v, lsusb -v, and dmesg with loglevel=8 for
> fedora 16 RC4.
> Hope this helps.
> Again, the ipod message in dmesg was plugged in after getting dropped to the
> shell.

OK, excellent.  Thank you.

> > Would it be possible to install the Fedora kernel RPM in the ARCH installation
> > and boot ARCH with that kernel?
> > 
> 
> Do you still want me to look into this after I have attached the above files?

Hm.  No.  The drivers in use for the IDE controllers are the same between ARCH and fedora.  Let's do something else instead.

Using the same trick you did above, can you get the modules in the following directory onto the machine and insmod them?

http://jwboyer.fedorapeople.org/pub/bug716799/

That should at least bring the fedora kernel to equivalent levels of drivers loaded (minus the IDE stuff).  You might also try loading scsi_wait_scan.
Comment 35 Josh Boyer 2011-11-04 11:35:53 EDT
If those don't work either, we have some other cmdline arguments to try I guess:

pci=nocrs

pcie_aspm=off (though I don't think this will do anything since ASPM already seems disabled)

rdblacklist=ahci
Comment 36 gostrc 2011-11-04 12:53:17 EDT
(In reply to comment #34)
> (In reply to comment #33)
> > (In reply to comment #28)
> > > (In reply to comment #27)
> > > > > And possibly the same from the Fedora live image?
> > > > > 
> > > > 
> > > > I couldn't run lsusb/lspci because it said those commands were not found.
> > > 
> > > Ugh, right.  The live image is space limited and your machine isn't finding the
> > > contents anyway because of the missing drive.  Hm.  That probably means you'll
> > > have similar problems booting from the DVD iso into a rescue mode so that won't
> > > help.
> > > 
> > 
> > I managed to hunt down all packages required to run lsusb and lspci and
> > extracted them manually and copied them over to the dracut environment.
> > I have attached output from lspci -v, lsusb -v, and dmesg with loglevel=8 for
> > fedora 16 RC4.
> > Hope this helps.
> > Again, the ipod message in dmesg was plugged in after getting dropped to the
> > shell.
> 
> OK, excellent.  Thank you.
> 
> > > Would it be possible to install the Fedora kernel RPM in the ARCH installation
> > > and boot ARCH with that kernel?
> > > 
> > 
> > Do you still want me to look into this after I have attached the above files?
> 
> Hm.  No.  The drivers in use for the IDE controllers are the same between ARCH
> and fedora.  Let's do something else instead.
> 
> Using the same trick you did above, can you get the modules in the following
> directory onto the machine and insmod them?
> 
> http://jwboyer.fedorapeople.org/pub/bug716799/
> 
> That should at least bring the fedora kernel to equivalent levels of drivers
> loaded (minus the IDE stuff).  You might also try loading scsi_wait_scan.

also had to hunt down insmod,
I loaded rfkill.ko, nothing, next
I loaded sony-laptop.ko, some brightness control thing popped up but nothing related to the cdrom, next
I loaded ums-cypress.ko, and it created a /dev/sr0 file :)

I will attach the dmesg from that.
Comment 37 gostrc 2011-11-04 12:53:52 EDT
Created attachment 531808 [details]
working dmesg log for fedora 16 RC4
Comment 38 Josh Boyer 2011-11-06 10:31:32 EST
(In reply to comment #36)
> > Using the same trick you did above, can you get the modules in the following
> > directory onto the machine and insmod them?
> > 
> > http://jwboyer.fedorapeople.org/pub/bug716799/
> > 
> > That should at least bring the fedora kernel to equivalent levels of drivers
> > loaded (minus the IDE stuff).  You might also try loading scsi_wait_scan.
> 
> also had to hunt down insmod,
> I loaded rfkill.ko, nothing, next
> I loaded sony-laptop.ko, some brightness control thing popped up but nothing
> related to the cdrom, next
> I loaded ums-cypress.ko, and it created a /dev/sr0 file :)

Well, that is indeed good news.

The unfortunate part is that we won't be able to get a change into the final release of the F16 live images.  The module _should_ be present in the actual DVD install isos, so an F16 install will work there.

Harald, I'm going to assign this back to dracut since the only kernel related thing is a missing module in the initramfs.  Do you think you could include the ums-cypress module for live images in the future?
Comment 39 Harald Hoyer 2011-11-07 03:38:58 EST
yes
Comment 40 Mariusz 2011-11-12 20:14:28 EST
Created attachment 533312 [details]
lspci from fedora 16 rescue DVD install disc
Comment 41 Mariusz 2011-11-12 20:16:29 EST
I have this problem, too. I'm upgraded from DVD install disc my fedora 64 bit system from 15 to 16. I do grub2-mkconfig -o /boot/grub2/grub.cfg nad grub2-install /dev/sda. After boot:

dracut Warning: No root device "block:/dev/by-uuid/c411e4ca-acc4-48f4-8b56-7d65e728bd68" found
Dropping to debug shell.
sh: cant access tty; job control turned off
dracut:/#

My motherboard: Asus M2N4-SLI. 6GB RAM.
Comment 42 Mariusz 2011-11-12 20:17:35 EST
Created attachment 533313 [details]
lsusb from fedora 16 rescue DVD install disc
Comment 43 Mariusz 2011-11-12 20:18:36 EST
Created attachment 533314 [details]
dmesg from fedora 16 rescue DVD install disc
Comment 44 Mariusz 2011-11-12 20:21:17 EST
Created attachment 533315 [details]
results Boot Info Script 0.60 from fedora 16 rescue DVD install disc
Comment 45 Mariusz 2011-11-12 20:22:46 EST
Created attachment 533316 [details]
grub2.cfg from fedora 16 rescue DVD install disc
Comment 46 Mariusz 2011-11-12 20:23:41 EST
Created attachment 533317 [details]
/etc/defaults/grub from fedora 16 rescue DVD install disc
Comment 47 Mariusz 2011-11-12 20:24:27 EST
Created attachment 533318 [details]
ls -l /boot from fedora 16 rescue DVD install disc
Comment 48 Mariusz 2011-11-12 20:28:16 EST
All files I'm created after boot my computer from Fedora 16 DVD install disc. From chroot upgraded system.
Comment 49 Mariusz 2011-11-15 17:24:20 EST
I'm created a small /boot partition first in disk. This resolve my problem.
Comment 50 alfha_6 2011-11-15 21:42:31 EST
Same issue here 
laoding intial ramdisk ...

dracut warning: no root device "block:/dev/mapper/vg_(computer name)-lv_root" found
dracut warning: LVM vg_(computer name)/lv_root not found
dracut warning: LVM vg_(computer name)/lv_swap not found

I just made intallation made a few commands to update rebooted and then this.
Comment 51 Fedora Update System 2011-11-17 05:36:25 EST
dracut-013-19.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/dracut-013-19.fc16
Comment 52 Fedora Update System 2011-11-19 01:00:31 EST
Package dracut-013-19.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dracut-013-19.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-16098/dracut-013-19.fc16
then log in and leave karma (feedback).
Comment 53 Fedora Update System 2011-11-23 18:29:01 EST
dracut-013-19.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.