Bug 71684 - locale problem in virtual console?
locale problem in virtual console?
Status: CLOSED DUPLICATE of bug 74925
Product: Red Hat Raw Hide
Classification: Retired
Component: bash (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-16 13:14 EDT by Michael Schwendt
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-07 07:55:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2002-08-16 13:14:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020804

Description of problem:
[ This is another one from the set of locale-problems with non-ASCII characters.]

With "bash" on virtual console (CTRL+)ALT+F1, for each non-ASCII special
character (e.g. Euro-symbol, cent-symbol, characters from west european
languages) I type in, backspace can delete _two_ characters.

$ cat /etc/sysconfig/i18n 
LANG="en_GB.UTF-8"
SUPPORTED="en_GB.UTF-8:en_GB:en:en_US.UTF-8:en_US:en:de_DE.UTF-8:de_DE:de"
SYSFONT="LatArCyrHeb-16"

$ export | grep LAN
declare -x LANG="en_GB.UTF-8"


Version-Release number of selected component (if applicable):
bash-2.05b-3, glibc-2.2.90-23
(rest from upgraded Limbo beta2)

How reproducible:
Always

Steps to Reproduce:
1. (CTRL)+ALT+F1
2. log in
3. AltGr+E AltGr+E AltGr+E AltGr+E AltGr+E AltGr+E AltGr+E
[or enter other non-ASCII characters here]
4. Backspace Backspace Backspace  Backspace  Backspace  Backspace


Actual Results:  Backspace key deletes two characters each time it is pressed
and even deletes past the shell-prompt.

Expected Results:  Backspace key should delete only one character each time it
is pressed.
Comment 1 Tim Waugh 2002-10-11 07:15:26 EDT

*** This bug has been marked as a duplicate of 74925 ***

Note You need to log in before you can comment on or make changes to this bug.