Bug 716840 - stop/cont cause guest timedrift
stop/cont cause guest timedrift
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.7
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Rik van Riel
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2011-06-27 04:52 EDT by Suqin Huang
Modified: 2011-08-08 11:27 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-08 11:13:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suqin Huang 2011-06-27 04:52:06 EDT
Description of problem:
stop guest 60s, and then cont, check guest time after 10mins, guest timedrift around 70s.

Version-Release number of selected component (if applicable):
kvm-83-238.el5

How reproducible:
100%

Steps to Reproduce:
1. cmd:
/usr/libexec/qemu-kvm -monitor stdio -drive file=/mnt/images/RHEL-Server-5.7-64-virtio.qcow2,index=0,if=virtio,media=disk,cache=none,boot=on,format=qcow2 -net nic,vlan=0,model=virtio,macaddr=9a:ad:0f:27:a6:6f -net tap,vlan=0,ifname=t0-134040-cIy0,script=/mnt/scripts/qemu-ifup-switch,downscript=no -m 2048 -smp 4,cores=1,threads=1,sockets=4 -cpu qemu64,+sse2 -soundhw ac97 -vnc :0 -M rhel5.6.0 -boot c -usbdevice tablet -no-kvm-pit-reinjection -rtc-td-hack

2. cmdline

ro root=/dev/VolGroup00/LogVol00 console=ttyS0,115200 console=tty0

3. 
1). run ntpdate before stop
ntpdate -d -q ns1.nay.redhat.com

offset: -27.253621

2). stop guest
(qemu)stop

3). sleep 60

4). cont guest

(qemu) c

5). wait for 10mins
6). check time
ntpdate -d -q ns1.nay.redhat.com

offset:42.348616

timedrift: 70s

  
Actual results:


Expected results:


Additional info:
1. host
processor	: 1
vendor_id	: AuthenticAMD
cpu family	: 15
model		: 107
model name	: AMD Athlon(tm) Dual Core Processor 5400B
stepping	: 2
cpu MHz		: 1000.000
cache size	: 512 KB
physical id	: 0

flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy misalignsse

2. guest 
rhel5.7-x86_64
Comment 1 Ronen Hod 2011-08-08 11:13:11 EDT
Suqin,
I am closing this bug since it is not severe enough for 5.8. However
1. I believe that you will be able to reproduce it on 6.2
2. I also believe that it is "as designed". Gleb, please comment.
Thanks, Ronen.
Comment 2 Gleb Natapov 2011-08-08 11:27:58 EDT
(In reply to comment #1)
> Suqin,
> I am closing this bug since it is not severe enough for 5.8. However
> 1. I believe that you will be able to reproduce it on 6.2
> 2. I also believe that it is "as designed". Gleb, please comment.
That's not the question I can answer. You should ask someone who knows kvmclock better then me.

Note You need to log in before you can comment on or make changes to this bug.