Bug 71693 - New bind-9.2.1 package breaks mail delivery
New bind-9.2.1 package breaks mail delivery
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-16 14:46 EDT by Michael St. Laurent
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-28 22:07:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael St. Laurent 2002-08-16 14:46:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
The new bind-9.2.1 package for 7.0 seems to break the resolver.  Sendmail just 
put stuff in the mail queue instead of sending it due to name server timeout.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.  I used up2date on our 7.0 firewall system to update our packages including 
the kernel.
2.  Updated the /etc/sysconfig/named file to point at the chroot environment.
3.  Disabled IP-v6 support (by putting "listen-ip-v6 { none; };" in the options 
section of the config file) when the resolver refused to work at all and got 
partial sucess.  The "host" command would work but email still wound up in the 
queue instead of being sent.

Additional info:

All packages were updated to the current errata releases as of 8/14/02.  The 
system in question is an SMP with 2 processors.  I've corrected the problem by 
reverting the bind* pacakges back to the 8.2.2_P5 releases.  Since this is a 
critical path system I can't have it down to continue the debug process.  Sorry.
Comment 1 Bernhard Rosenkraenzer 2002-08-30 07:55:58 EDT
Not reproducable on any of my test machines. 
Comment 2 Michael St. Laurent 2002-08-30 12:04:51 EDT
Hmmmm.  OK let's see if some additional info will help.  The system is a 
firewall that uses the split DNS setup whereby the firewall is running bind and 
supplies address resolution to the outside world while there is a seperate DNS 
server on the inside LAN that provides resolution for local addresses.  This 
inside DNS server is set to forward unresolvable address lookups to the 
firewall which then goes out on the internet to resolve them.  The firewall's 
resolv.conf points to the inside DNS server.  If the lookup is for an external 
address the request goes to the internal server then back to the firewall which 
performs the lookup.  Does this make sense to you?  In any case this works fine 
with bind-8.2.2_P5-25 but does not work at all with the bind-9.2.1 package.
Comment 3 Daniel Walsh 2004-04-28 22:07:34 EDT
Closing since this bug has not been reproduced in a couple of years.

Note You need to log in before you can comment on or make changes to this bug.