This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 716956 - MLS avc: denied { getattr } for ... comm="crond" path="/etc/krb5.conf" ... scontext=system_u:system_r:crond_t:s0-s15:c0.c1023 tcontext=system_u:object_r:krb5_conf_t:s0 tclass=file
MLS avc: denied { getattr } for ... comm="crond" path="/etc/krb5.conf" ... sc...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy (Show other bugs)
5.7
All Linux
medium Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-27 10:56 EDT by Milos Malik
Modified: 2012-10-15 11:18 EDT (History)
1 user (show)

See Also:
Fixed In Version: selinux-policy-2.4.6-317.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 00:47:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2011-06-27 10:56:12 EDT
Description of problem:


Version-Release number of selected component (if applicable):
selinux-policy-devel-2.4.6-316.el5
selinux-policy-strict-2.4.6-316.el5
selinux-policy-minimum-2.4.6-316.el5
selinux-policy-2.4.6-316.el5
selinux-policy-targeted-2.4.6-316.el5
selinux-policy-mls-2.4.6-316.el5

How reproducible:
generated automatically each hour

Steps to Reproduce:
1. get a freshly installed RHEL-5.7 machine with MLS policy in enforcing mode
2. log in as root via console
3. AVCs appear automatically each hour (07:01:01,08:01:01,09:01:01 etc.)
  
Actual results:
----
time->Mon Jun 27 08:01:01 2011
type=SYSCALL msg=audit(1309176061.148:95): arch=c0000032 syscall=1210 success=no exit=-13 a0=2000000800511b00 a1=60000fffffb94770 a2=130 a3=0 items=0 ppid=4029 pid=4997 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=3 comm="crond" exe="/usr/sbin/crond" subj=system_u:system_r:crond_t:s0-0-s15:c0.c1023 key=(null)
type=AVC msg=audit(1309176061.148:95): avc:  denied  { getattr } for  pid=4997 comm="crond" path="/etc/krb5.conf" dev=dm-0 ino=36503783 scontext=system_u:system_r:crond_t:s0-s15:c0.c1023 tcontext=system_u:object_r:krb5_conf_t:s0 tclass=fifile
----

Expected results:
* no AVCs
Comment 1 Miroslav Grepl 2011-06-27 12:32:02 EDT
We need to add 

auth_use_nsswitch(crond_t)
Comment 2 Miroslav Grepl 2011-09-29 07:31:44 EDT
Fixed in selinux-policy-2.4.6-317.el5
Comment 5 errata-xmlrpc 2012-02-21 00:47:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0158.html

Note You need to log in before you can comment on or make changes to this bug.