Bug 71698 - NFS client loses a lot of performance between RH 7.2 and 7.3
NFS client loses a lot of performance between RH 7.2 and 7.3
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2002-08-16 15:29 EDT by Tim Skirvin
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-08-16 15:29:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Tim Skirvin 2002-08-16 15:29:13 EDT
Description of Problem:

(from my post to comp.os.linux.redhat):

        The short version: why has NFS client support gotten so much worse

between RH 7.2 and 7.3, and what can we do about it?

        Alright, some background: we're a mixed-platform Unix shop, with

Solaris Sparc servers and a mix of primarily Linux and Solaris desktops

(with a few of just about everything else for good measure - IRIX, Tru64,

HP-UX, AIX, OS X, Win2k).  The network is NFS/NIS using the automounter,

and has worked quite well historically.

        While most of our Linux boxes are running RedHat 7.2, I've begun

installing a few limited RH 7.3 test boxes in the group for testing

purposes.  So far, it's going great except for one thing: the NFS

performance.  If the systems attempt to copy any large files or perform

any non-trivial NFS task, they get errors of the sort of:

        "nfs: task xxxx can't get a request slot"

        ...and the task doesn't really complete.  Even when it does work,

performance is terrible - copying a 256M file to local disk takes minutes

instead of seconds on similar machines (10:35.43 on a RH 7.3 box, compared

to 0:50.18 on 7.2).

        I have tried patching the 7.3 boxes to the most recent kernel

RPM (2.4.18-5), which hasn't changed anything significantly.  On searching

Usenet, I've found word that I should be lowering the default wsize and

rsize to 8k or 16k; I don't consider this an acceptable alternative, given

that we use the automounter and any changes I make there will affect all

other systems on our network.

        Otherwise, I'm stumped.  And I'm really tempted to give RH 7.3 a

miss, which seems a shame but apparently necessary.

Version-Release number of selected component (if applicable): 

7.3, kernels 2.4.18-3 and 2.4.18-5 (either)

How Reproducible:


Steps to Reproduce:

On two (similar but not identical) systems:

# mount reno:/export/reno/ext36 /mnt

# time cp /mnt/isoimages/valhalla-i386-disc1.iso /scratch

RH 7.2 (2.4.9-34) results:

0.060u 16.580s 2:15.84 12.2%    0+0k 0+0io 103pf+0w

RH 7.3 (2.4.18-5) results: 

0.070u 62.730s 5:47.73 18.0%    0+0k 0+0io 100pf+0w
Comment 1 Bob Matthews 2002-08-16 16:10:53 EDT
We believe this problem is fixed in the 7.3 errata kernel which should be coming
out within a week or so.

Note You need to log in before you can comment on or make changes to this bug.