Bug 716984 - Legacy SysV initscript file must go into an optional subpackage.
Legacy SysV initscript file must go into an optional subpackage.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gpm (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nikola Pajkovsky
Fedora Extras Quality Assurance
:
Depends On:
Blocks: SysVtoSystemd
  Show dependency treegraph
 
Reported: 2011-06-27 12:38 EDT by Jóhann B. Guðmundsson
Modified: 2014-02-02 17:15 EST (History)
3 users (show)

See Also:
Fixed In Version: gpm-1.20.6-18.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-23 16:28:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Spec file patch for gpm (2.21 KB, patch)
2011-07-26 18:35 EDT, Jóhann B. Guðmundsson
no flags Details | Diff

  None (edit)
Description Jóhann B. Guðmundsson 2011-06-27 12:38:05 EDT
Description of problem:

Currently your component is providing both native systemd service files and
legacy sysv init script in the same package which is in violation of the
packaging guidelines[1]. 

Once a native systemd service file is shipped and if the intention is to
continue to maintain and ship the old sysv initscript the old sysvinit  must go
into an optional subpackage.

"SysV Initscripts
Packages may also provide a SysV initscript file, but are not required to do
so. This format is considered legacy, but Fedora still contains init mechanisms
such as upstart which do not support the systemd unit file format. If present,
the SysV initscript(s) must go into an optional subpackage, so as not to
confuse sysadmins. The guidelines for SysV initscripts can be found here:
Packaging:SysVInitScript"

http://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd
http://fedoraproject.org/wiki/Packaging:Tmpfiles.d


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2011-07-15 11:01:22 EDT
What's the current status of you are one of few that is not package
native systemd unit in the Base group correctly?

If you dont have the time to fix this should I try to find a proven packager to
do the work for you? 

https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd
https://fedoraproject.org/wiki/Packaging:Tmpfiles.d
Comment 2 Jóhann B. Guðmundsson 2011-07-26 18:35:43 EDT
Created attachment 515381 [details]
Spec file patch for gpm

Note this has to be cleanup before thursday
Comment 3 Nikola Pajkovsky 2011-08-05 05:10:54 EDT
thanks for patch, I really appreciate it!

Honestly, your patch is not applicable, because
1)
--- file_not_specified_in_diff	
+++ file_not_specified_in_diff

I know that this is a diff between spec file, but '$ patch' does not

2)
you are in git man! '$ git commit -sm "message"' and '$ git format-patch -1' will do a great job for you ;)
Comment 4 Fedora Update System 2011-08-05 08:22:57 EDT
gpm-1.20.6-18.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gpm-1.20.6-18.fc16
Comment 5 Fedora Update System 2011-08-05 16:07:50 EDT
Package gpm-1.20.6-18.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gpm-1.20.6-18.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/gpm-1.20.6-18.fc16
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2011-08-23 16:28:45 EDT
gpm-1.20.6-18.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.