Bug 717052 - subscription-manager uninstall leaves yum in a bad state
subscription-manager uninstall leaves yum in a bad state
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bryan Kearney
J.C. Molet
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-06-27 16:02 EDT by J.C. Molet
Modified: 2011-12-06 12:15 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:15:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description J.C. Molet 2011-06-27 16:02:34 EDT
Description of problem:
When you uninstall subscription manager after using it, it leaves behind the redhat.repo file which is no longer being maintained by subscription manager.  This could cause yum to break by the fact it is still pointing to repos that may or may not work.

Version-Release number of selected component (if applicable):
subscription-manager-0.96.1-1.git.264.7cc914b.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. Install subscription manager.
2. Use it so that your /etc/yum.repos.d/redhat.repo file is populated with repos
3. rpm -e subscription-manager
4. Install something else with yum.
  
Actual results:
Yum cannot run because redhat.repo is pointing to repos that don't work anymore.

Expected results:
the redhat.repo file is cleaned during the uninstall of subscription-manager.

Additional info:
This repoduces well with the candlepin testing data.
Comment 4 J.C. Molet 2011-08-16 12:03:31 EDT
The fix for this is simple, during uninstall subscription-manager renames the redhat.repo file to redhat.repo-bak which disables the repo without loosing its contents.  This effectively gets rid of these yum errors.

subscription-manager-0.96.5-1.git.51.ac50478.el6.x86_64
subscription-manager-firstboot-0.96.5-1.git.51.ac50478.el6.x86_64
python-rhsm-0.96.8-1.git.5.d42033a.el6.noarch
subscription-manager-gnome-0.96.5-1.git.51.ac50478.el6.x86_64

Marking VERIFIED
Comment 5 errata-xmlrpc 2011-12-06 12:15:23 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.