Bug 71708 - Tab windows sometimes not accessible
Tab windows sometimes not accessible
Product: Red Hat Linux
Classification: Retired
Component: gnome-terminal (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Depends On:
  Show dependency treegraph
Reported: 2002-08-16 18:40 EDT by Jos Vos
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-02-24 00:07:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jos Vos 2002-08-16 18:40:46 EDT
Description of Problem:
When having multiple subwindows, making the gnome-terminal window active
sometimes   let not type you in the current subwindow (tab) and the cursor is
white i.s.o. black.  Switching to another tab window and back solves that
problem then.

Version-Release number of selected component (if applicable):

How Reproducible:
It happens often, but is not 100% reproducable.
Comment 1 Havoc Pennington 2002-08-19 19:00:22 EDT
Which window manager?

If metacity have you seen this with metacity and gnome-terminal 2.0.1?
Comment 2 Jos Vos 2002-08-20 02:13:53 EDT
The standard GNOME setup is used, so I think it is metacity, yes.

I'll try it with beta5 (containing the packages you mention) later.
Comment 3 Jos Vos 2002-08-20 15:58:43 EDT
The problem seems to be solved in null...  Will do some more tests and you may
close this if I don't add a new comment within a day ;-).
Comment 4 Jos Vos 2002-08-21 17:31:17 EDT
The problem still occurs... :-(.  I have the impression not as frequently as
before, but I'm not sure about that.
Comment 5 Nalin Dahyabhai 2002-08-21 23:11:17 EDT
Is the focus indicator on the tab itself when this happens?  I've occasionally
seen the tab get the focus instead of the terminal widget (when this happens,
pressing the down key moves the focus back into the widget).  If this is the
case, then it's not a metacity bug, but I don't know if it's in vte or
Comment 6 Havoc Pennington 2002-08-21 23:35:18 EDT
Note that if you click a tab that's already active, it is _supposed_ to get
focused. You'll then see the dotted line around the tab title. So if that's the
issue, it's not really a bug...
Comment 7 Jos Vos 2002-08-24 11:27:06 EDT
Yes, it seems to be the case that the tab has the focus and that that was the
problem.  Confufing...  The down key worked, but clicking in the window
sometimes does not seem to work, IIRC (if I now try it works :-( ).
Comment 8 Jos Vos 2002-08-24 16:10:38 EDT
I'm still fighting with this problem very often. The down key always works, yes,
but  when coming back to the window later the tab has the focus again.  I'm not
sure about the exact circumstances, I haven't found a reproducable sequence yet,
but I can't believe this is a feature i.s.o. a bug...
Comment 9 Havoc Pennington 2003-01-08 00:32:31 EST
I'm not sure I understand what remains here (I'm unclear on exactly what the
misbehavior is). There were various issues related to this fixed since 8.0
though, and I believe it works correctly now. Part of the fixes are in GTK, so
2.2.0 is needed.
Comment 10 Emmanuel Galanos 2003-02-23 23:21:45 EST
What is the point of this behaviour? A tab having focus seems to serve no
useful purpose. It is quite easy to get to this state by just clicking twice
on the tab. It is not fixed in the latest betas/rawhide. Very confusing for
an end user.
Comment 11 Havoc Pennington 2003-02-24 00:07:57 EST
Tabs being able to focus is necessary for keyboard navigation. The behavior 
is consistent for all notebook widgets.

It was worse in rawhide for a while because clicking the terminal area didn't
focus the terminal area again, but that's fixed.

In any case, this is a standard UI behavior, changing it would have to be 
discussed upstream in bugzilla.gnome.org/usability@gnome.org, it's not 
something we would change in Red Hat patches.

Note You need to log in before you can comment on or make changes to this bug.