Bug 717135 - guest can not format hard drive
guest can not format hard drive
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.7
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier3
  Show dependency treegraph
 
Reported: 2011-06-28 02:18 EDT by Xiaoqing Wei
Modified: 2011-08-11 09:28 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-11 09:28:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
time-out error (26.71 KB, image/png)
2011-06-28 02:18 EDT, Xiaoqing Wei
no flags Details
all ide (41.67 KB, image/png)
2011-07-10 22:37 EDT, Xiaoqing Wei
no flags Details

  None (edit)
Description Xiaoqing Wei 2011-06-28 02:18:44 EDT
Created attachment 510204 [details]
time-out error

Description of problem:
guest can not format hard drive

Version-Release number of selected component (if applicable):
kvm-83-238.el5
kvm-qemu-img-83-238.el5

How reproducible:
mostly

Steps to Reproduce:
1.create images : 
qemu-img create -f qcow2 storage1.qcow2 1G
qemu-img create -f qcow2 storage2.qcow2 1G

2.start guest with above extra images attached (one ide, one virtio) :

qemu-kvm .... -drive file=guest_os.qcow2,if=virtio,index=0..  -drive file=storage.qcow2,if=virtio,index=1..  -drive file=storage2.qcow2,if=ide,index=2..

3.open "disk management" and format disks,
  
Actual results:
wait a long time and guest return time-out error(please see snapshot).

Expected results:
guest format disks without any problem

Additional info:

1) after error occured,delete disk partition and retry format,sometimes disks can be formatted.
2) virtio seems easier to be formatted when retry. (ide 1/10, virtio 4/10)


full cmd :
qemu-kvm -name w03-64 -monitor stdio -serial unix:/tmp/serial-20110617-145355-bU4d,server,nowait \
\
-drive file=/win2003-64-virtio.qcow2,index=0,if=virtio,media=disk,cache=none,boot=on,format=qcow2 -drive file=/storage.qcow2,index=1,if=virtio,media=disk,cache=none,format=qcow2 \
-drive file=/storage2.qcow2,index=2,if=ide,media=disk,cache=none,format=qcow2 \
\
-net nic,vlan=0,model=virtio,macaddr=9a:d8:7f:12:35:8a \
-net tap,vlan=0,ifname=03-64,script=/usr/local/staf/test/RHEV/kvm-new/autotest/client/tests/kvm/scripts/qemu-ifup-switch,downscript=no -m 4096 -smp 2,cores=1,threads=1,sockets=2 -cpu qemu64,+sse2 -soundhw ac97 -spice port=8000,disable-ticketing -qxl 1 -rtc-td-hack -M rhel5.6.0 -boot c -usbdevice tablet



host info:
kernel-2.6.18-269.el5

CPU:
processor	: 1
vendor_id	: AuthenticAMD
cpu family	: 15
model		: 67
model name	: Dual-Core AMD Opteron(tm) Processor 1216

8G RAM
Comment 1 Xiaoqing Wei 2011-06-28 08:30:26 EDT
guest info:
Windows 2003 64bit

there's a work around (not knowing is it always work, I tried it 3 times and all works ) :

 hot plug a disk to guest will resolve this problem:

1) I hot-plugged a disk to guest,after guest search drivers,open "disk management",the hot-plugged disk can be initialized and formatted easily.

2)there are 2 disks I try to format it multiple time but didn't success,after hot-plugged a disk,they can be formatted easily as well.

hot-plug cmd:

(qemu) pci_add pci_addr=auto storage file=/hot1.qcow2,if=virtio
Comment 2 Vadim Rozenfeld 2011-07-10 04:52:29 EDT
I've been trying to reproduce this problem, but so far I've been unable to reproduce this issue. Hence, I have several questions to you:
- is the above command line correct? There is no CD-ROM, mentioned in the
command line, but it appears on the picture https://bugzilla.redhat.com/attachment.cgi?id=510204. How did you attached it?
- is the problem reproducible with two disks of the same type (two 
virtio disks or two IDE)?

Best regards,
Vadim.
Comment 3 Xiaoqing Wei 2011-07-10 22:37:09 EDT
Created attachment 512123 [details]
all ide

(In reply to comment #2)
Hi Vadim,
> I've been trying to reproduce this problem, but so far I've been unable to
> reproduce this issue. 
I cannot reproduce it 100% as well,

> - is the above command line correct? There is no CD-ROM, mentioned in the
> command line, but it appears on the picture
> https://bugzilla.redhat.com/attachment.cgi?id=510204. How did you attached it?
I tried with cdrom and without cdrom, both can trigger this issue. so I pasted the above cmd.

> - is the problem reproducible with two disks of the same type (two 
> virtio disks or two IDE)?
> 
retried 10 times :
all ide    (3 / 5)
all virtio (0 / 5)


Kind regards,
Xiaoqing.
Comment 4 Vadim Rozenfeld 2011-07-11 01:41:50 EDT
(In reply to comment #3)
> Created attachment 512123 [details]
> all ide
> 
> (In reply to comment #2)
> Hi Vadim,
> > I've been trying to reproduce this problem, but so far I've been unable to
> > reproduce this issue. 
> I cannot reproduce it 100% as well,
Hi Xiaoqing,
OK, I'll try harder. 
> 
> > - is the above command line correct? There is no CD-ROM, mentioned in the
> > command line, but it appears on the picture
> > https://bugzilla.redhat.com/attachment.cgi?id=510204. How did you attached it?
> I tried with cdrom and without cdrom, both can trigger this issue. so I pasted
> the above cmd.
I see.
> 
> > - is the problem reproducible with two disks of the same type (two 
> > virtio disks or two IDE)?
> > 
> retried 10 times :
> all ide    (3 / 5)
> all virtio (0 / 5)
OK, I will continue with two IDEs.
I have tested virtio RAID-5 configuration several times in the past,
but didn't any problem.
Best regards,
Vadim. 
> 
> 
> Kind regards,
> Xiaoqing.
Comment 5 Vadim Rozenfeld 2011-08-11 09:28:47 EDT
Hi Xiaoqing,

I tried to reproduce this problem a huge amount of times during 
the last several days. I have tried platforms and different storage
subsystem configuration. But I cannot reproduce this problem on my
system.

From my own experience I can say that we have seen similar problems
several time. None of them were related to virtio block or IDE drive,
but rather were a NFS or a host storage subsystem's problems.

There is nothing related to virtio-win drivers we can fix.
I'm going to close it as NOTABUG. But please feel free to reopen it in 6.3 if you don't agree with me.

Best regards,
Vadim.

Note You need to log in before you can comment on or make changes to this bug.