Bug 71716 - konqueror crashed when accessing a directory where a "dead.letter" file is located.
konqueror crashed when accessing a directory where a "dead.letter" file is lo...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks: FC3BugWeekTracker
  Show dependency treegraph
 
Reported: 2002-08-16 20:04 EDT by Jerome Asselin
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-26 18:55:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the "dead.letter" file that causes konqueror to crash. (894 bytes, text/plain)
2002-08-16 20:06 EDT, Jerome Asselin
no flags Details

  None (edit)
Description Jerome Asselin 2002-08-16 20:04:24 EDT
Description of Problem:

It looks like I can reproduce the bug only with the particular
"dead.letter" file I have. I have tried to reproduce the problem
with an empty "dead.letter" file, but then it worked just fine.

If I move the bad "dead.letter" file in another directory, then
konqueror crashes only if I try to access that directory.

When it crashes, I do not receive an error signal. The scroll
bar (on the right-hand side) starts flashing very fast and
konqueror does not respond to my mouse commands anymore.
I have to kill the konqueror window with "xkill".

I will attach my "dead.letter" file. Hopefully, it is reproducable.

Version-Release number of selected component (if applicable):
$ rpm -qif /usr/bin/konqueror
Name        : kdebase                      Relocations: /usr
Version     : 2.2.2                             Vendor: Red Hat, Inc.
Release     : 1                             Build Date: Wed 14 Nov 2001 09:03:34 AM PST
Install date: Thu 13 Jun 2002 01:43:26 PM PDT      Build Host: stripples.devel.redhat.com
Group       : User Interface/Desktops       Source RPM: kdebase-2.2.2-1.src.rpm
Size        : 35993236                         License: GPL


How Reproducible:
Every time.

 Steps to Reproduce:
1. Put the "dead.letter" file in your home directory.
2. Load your home directory with konqueror by clicking on the
   home icon or by typing the command "konqueror ~".
3. Try to see if the konqueror windows responds to your mouse
   commands. (This should fail.)

Actual Results:

The scroll bar flashes very quickly and continuously. I cannot use
this konqueror window for file management. I must kill it with
"xkill". 

Expected Results:

Konqueror should allow me to submit mouse commands.

Additional Information:
Comment 1 Jerome Asselin 2002-08-16 20:06:06 EDT
Created attachment 71285 [details]
This is the "dead.letter" file that causes konqueror to crash.
Comment 2 Rik van Riel 2004-09-26 18:55:15 EDT
Tested by morte in #fedora-bugweek, no longer reproduced on a current
release.

Note You need to log in before you can comment on or make changes to this bug.