Bug 717476 - bad python-boto version causes imgfac push to fail with SignatureDoesNotMatch AWS Secret Access Key and signing method
Summary: bad python-boto version causes imgfac push to fail with SignatureDoesNotMatch...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: imagefactory
Version: 1.0.0
Hardware: All
OS: Unspecified
unspecified
medium
Target Milestone: rc
Assignee: Ian McLeod
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-06-28 21:51 UTC by Simeon Pinder
Modified: 2012-05-15 20:06 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-15 20:06:17 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:0588 normal SHIPPED_LIVE new packages: imagefactory 2012-05-15 22:31:27 UTC

Description Simeon Pinder 2011-06-28 21:51:54 UTC
Description of problem:
When the wrong version of pyhon-boto is installed for aeolus and imagefactory, then correct credentials are erroneously flagged as incorrect and imagefactory pushes fail with error message below.  Upgrading to rpm to python-boto-1.9b-5.fc14.noarch. 

Suggest that this version becomes the minimum version dependent for aeolus-install or appropriate component.

Version-Release number of selected component (if applicable):

How reproducible:
Every time.

Steps to Reproduce:
1. Install aeolus-all and configure.
2. Install python-boto-1.9b-3.fc14.noarch.
3. Install correct amazon ec2 credentials. 
4. Attempt to push an image to your ec2 account.
  
Actual results:
[root@dogmatix aeolus]# imgfac.py --image 1ecc08d8-0fff-466b-88cb-17fd81a318ad --provider ec2-us-east-1 --credentials /home/spinder/installers/cloud/provider_accounts.xml
Pushing build b2875ea1-f69d-4478-994a-bf44d0e758f8 of image 1ecc08d8-0fff-466b-88cb-17fd81a318ad to provider ec2-us-east-1
2011-06-28 14:02:00,809 ERROR boto pid(27591) Message: 403 Forbidden
2011-06-28 14:02:00,810 ERROR boto pid(27591) Message: <?xml version="1.0" encoding="UTF-8"?>
<Response><Errors><Error><Code>SignatureDoesNotMatch</Code><Message>The request signature we calculated does not match the signature you provided. Check your AWS Secret Access Key and signing method. Consult the service documentation for details.</Message></Error></Errors><RequestID>fa0a19ae-60ef-4477-8d2f-e572c383c7e7</RequestID></Response>
[root@dogmatix aeolus]# imgfac.py --image 1ecc08d8-0fff-466b-88cb-17fd81a318ad --debug --provider ec2-us-east-1 --credentials /home/spinder/installers/cloud/provider_accounts.xml
2011-06-28 14:18:39,113 DEBUG imagefactory.ImageWarehouse.ImageWarehouse pid(27709) Message: Created Image Warehouse instance http://localhost:9090 - buckets(target_images, templates, icicles, provider_images)
2011-06-28 14:18:39,113 DEBUG imagefactory.ImageWarehouse.ImageWarehouse pid(27709) Message: Getting metadata (['latest_unpushed']) from http://localhost:9090/images/1ecc08d8-0fff-466b-88cb-17fd81a318ad
2011-06-28 14:18:39,118 DEBUG imagefactory.ImageWarehouse.ImageWarehouse pid(27709) Message: Querying (http://localhost:9090/target_images/_query) with expression ($build == "b2875ea1-f69d-4478-994a-bf44d0e758f8" && $target == "ec2")
2011-06-28 14:18:39,124 DEBUG imagefactory.ImageWarehouse.ImageWarehouse pid(27709) Message: Getting metadata (['template']) from http://localhost:9090/target_images/4b85e868-9633-4b30-af66-0937e2dac255
2011-06-28 14:18:39,126 DEBUG imagefactory.ImageWarehouse.ImageWarehouse pid(27709) Message: Created Image Warehouse instance http://localhost:9090 - buckets(target_images, templates, icicles, provider_images)
2011-06-28 14:18:39,132 DEBUG imagefactory.ImageWarehouse.ImageWarehouse pid(27709) Message: Created Image Warehouse instance http://localhost:9090 - buckets(target_images, templates, icicles, provider_images)
Pushing build b2875ea1-f69d-4478-994a-bf44d0e758f8 of image 1ecc08d8-0fff-466b-88cb-17fd81a318ad to provider ec2-us-east-1
2011-06-28 14:18:39,140 DEBUG oz.Guest.FedoraRemoteGuest pid(27709) Message: Name: f14-JON_AGENT-64bit, UUID: e2828cce-4d52-4807-9807-8fdeccc33db4
2011-06-28 14:18:39,140 DEBUG oz.Guest.FedoraRemoteGuest pid(27709) Message: MAC: 52:54:00:33:7b:dc, distro: Fedora
2011-06-28 14:18:39,140 DEBUG oz.Guest.FedoraRemoteGuest pid(27709) Message: update: 14, arch: x86_64, diskimage: /var/tmp/f14-JON_AGENT-64bit.dsk
2011-06-28 14:18:39,141 DEBUG oz.Guest.FedoraRemoteGuest pid(27709) Message: nicmodel: virtio, clockoffset: utc
2011-06-28 14:18:39,141 DEBUG oz.Guest.FedoraRemoteGuest pid(27709) Message: mousetype: ps2, disk_bus: virtio, disk_dev: vda
2011-06-28 14:18:39,141 DEBUG oz.Guest.FedoraRemoteGuest pid(27709) Message: icicletmp: /var/lib/oz/icicletmp/f14-JON_AGENT-64bit, listen_port: 2513
2011-06-28 14:18:39,141 DEBUG oz.Guest.FedoraRemoteGuest pid(27709) Message: Original ISO path: /var/lib/oz/isos/Fedora14x86_64-iso.iso
2011-06-28 14:18:39,141 DEBUG oz.Guest.FedoraRemoteGuest pid(27709) Message: Modified ISO cache: /var/lib/oz/isos/Fedora14x86_64-iso-oz.iso
2011-06-28 14:18:39,141 DEBUG oz.Guest.FedoraRemoteGuest pid(27709) Message: Output ISO path: /var/tmp/f14-JON_AGENT-64bit-iso-oz.iso
2011-06-28 14:18:39,141 DEBUG oz.Guest.FedoraRemoteGuest pid(27709) Message: ISO content path: /var/lib/oz/isocontent/f14-JON_AGENT-64bit-iso
2011-06-28 14:18:39,141 DEBUG imagefactory.builders.BaseBuilder.FedoraBuilder pid(27709) Message: Being asked to push for provider ec2-us-east-1
2011-06-28 14:18:39,142 DEBUG imagefactory.builders.BaseBuilder.FedoraBuilder pid(27709) Message: distro: Fedora - update: 14 - arch: x86_64
2011-06-28 14:18:39,144 DEBUG imagefactory.builders.BaseBuilder.FedoraBuilder pid(27709) Message: acting as EC2 user: 2850-8396-6651
2011-06-28 14:18:39,144 DEBUG imagefactory.builders.BaseBuilder.FedoraBuilder pid(27709) Message: Starting ami ami-d6b946bf with instance_type m1.large
2011-06-28 14:18:39,666 ERROR boto pid(27709) Message: 403 Forbidden
2011-06-28 14:18:39,666 ERROR boto pid(27709) Message: <?xml version="1.0" encoding="UTF-8"?>
<Response><Errors><Error><Code>SignatureDoesNotMatch</Code><Message>The request signature we calculated does not match the signature you provided. Check your AWS Secret Access Key and signing method. Consult the service documentation for details.</Message></Error></Errors><RequestID>cb4443a2-0f60-44a1-8815-4cc7a19442db</RequestID></Response>
2011-06-28 14:18:39,669 DEBUG imagefactory.builders.BaseBuilder.FedoraBuilder pid(27709) Message: Exception caught in ImageFactory
2011-06-28 14:18:39,672 DEBUG imagefactory.builders.BaseBuilder.FedoraBuilder pid(27709) Message: Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/imagefactory/builders/FedoraBuilder.py", line 485, in push_image
    self.push_image_snapshot(target_image_id, provider, credentials)
  File "/usr/lib/python2.7/site-packages/imagefactory/builders/FedoraBuilder.py", line 497, in push_image_snapshot
    self.push_image_snapshot_ec2(target_image_id, provider, credentials)
  File "/usr/lib/python2.7/site-packages/imagefactory/builders/FedoraBuilder.py", line 665, in push_image_snapshot_ec2
    ec2region = boto.ec2.get_region(build_region_conf['host'], aws_access_key_id=self.ec2_access_key, aws_secret_access_key=self.ec2_secret_key)
  File "/usr/lib/python2.7/site-packages/boto/ec2/__init__.py", line 48, in get_region
    for region in regions(**kw_params):
  File "/usr/lib/python2.7/site-packages/boto/ec2/__init__.py", line 39, in regions
    return c.get_all_regions()
  File "/usr/lib/python2.7/site-packages/boto/ec2/connection.py", line 1412, in get_all_regions
    return self.get_list('DescribeRegions', None, [('item', RegionInfo)])
  File "/usr/lib/python2.7/site-packages/boto/connection.py", line 615, in get_list
    raise self.ResponseError(response.status, response.reason, body)
EC2ResponseError: EC2ResponseError: 403 Forbidden
<?xml version="1.0" encoding="UTF-8"?>
<Response><Errors><Error><Code>SignatureDoesNotMatch</Code><Message>The request signature we calculated does not match the signature you provided. Check your AWS Secret Access Key and signing method. Consult the service documentation for details.</Message></Error></Errors><RequestID>cb4443a2-0f60-44a1-8815-4cc7a19442db</RequestID></Response>


Expected results:
Push succeeds.

Additional info:
Updating python-boto to python-boto-1.9b-5.fc14.noarch fixes the problem.

Comment 1 wes hayutin 2011-09-28 16:41:28 UTC
making sure all the bugs are at the right version for future queries

Comment 3 wes hayutin 2011-09-29 16:06:33 UTC
push to ec2 is working..

2011-09-28 10:16:30,974 INFO imgfac.ImageWarehouse.ImageWarehouse pid(16110) Message: Creating a bucket returned status 500.
2011-09-28 10:16:30,977 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(16110) Message: Setting metadata ({'target_image': '6f2553be-57de-4818-ad31-b2ac7da91e7e', 'uuid': 'c320c6d9-b11e-4728-a3f9-14b9e45436a7', 'icicle': '7c66d60c-84d0-48ea-b2a5-224eb1c42419', 'target_identifier': 'ami-0dc10c64', 'object_type': 'provider_image', 'provider': 'ec2-us-east-1'}) for http://localhost:9090/provider_images/c320c6d9-b11e-4728-a3f9-14b9e45436a7
2011-09-28 10:16:30,985 DEBUG imgfac.builders.BaseBuilder.RHEL6_ec2_Builder pid(16110) Message: Stopping EC2 instance and deleting temp security group
2011-09-28 10:16:32,351 DEBUG imgfac.builders.BaseBuilder.RHEL6_ec2_Builder pid(16110) Message: Instance status (shutting-down) - waiting for 'terminated'. [0 of 300 seconds elapsed]
2011-09-28 10:16:37,425 DEBUG imgfac.builders.BaseBuilder.RHEL6_ec2_Builder pid(16110) Message: Instance status (shutting-down) - waiting for 'terminated'. [5 of 300 seconds elapsed]
2011-09-28 10:16:42,491 DEBUG imgfac.builders.BaseBuilder.RHEL6_ec2_Builder pid(16110) Message: Instance status (shutting-down) - waiting for 'terminated'. [10 of 300 seconds elapsed]
2011-09-28 10:16:47,555 DEBUG imgfac.builders.BaseBuilder.RHEL6_ec2_Builder pid(16110) Message: Instance status (shutting-down) - waiting for 'terminated'. [15 of 300 seconds elapsed]
2011-09-28 10:16:52,654 DEBUG imgfac.builders.BaseBuilder.RHEL6_ec2_Builder pid(16110) Message: Instance status (shutting-down) - waiting for 'terminated'. [20 of 300 seconds elapsed]
2011-09-28 10:16:57,727 DEBUG imgfac.builders.BaseBuilder.RHEL6_ec2_Builder pid(16110) Message: Instance status (shutting-down) - waiting for 'terminated'. [25 of 300 seconds elapsed]
2011-09-28 10:17:02,790 DEBUG imgfac.builders.BaseBuilder.RHEL6_ec2_Builder pid(16110) Message: Instance status (shutting-down) - waiting for 'terminated'. [30 of 300 seconds elapsed]
2011-09-28 10:17:08,068 DEBUG imgfac.builders.BaseBuilder.RHEL6_ec2_Builder pid(16110) Message: Removed temporary security group (imagefactory-c320c6d9-b11e-4728-a3f9-14b9e45436a7)
2011-09-28 10:17:08,068 DEBUG imgfac.builders.BaseBuilder.RHEL6_ec2_Builder pid(16110) Message: Fedora_ec2_Builder instance 38812176 pushed image with uuid 6f2553be-57de-4818-ad31-b2ac7da91e7e to provider_image UUID (c320c6d9-b11e-4728-a3f9-14b9e45436a7) and set metadata: {'target_image': '6f2553be-57de-4818-ad31-b2ac7da91e7e', 'target_identifier': 'ami-0dc10c64', 'icicle': '7c66d60c-84d0-48ea-b2a5-224eb1c42419', 'provider': 'ec2-us-east-1'}
2011-09-28 10:17:08,068 DEBUG imgfac.BuildJob.BuildAdaptor pid(16110) Message: Raising event with agent handler (<ImageFactoryAgent(Thread-1, initial)>), changed percent complete from 0 to 100
2011-09-28 10:17:08,069 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(16110) Message: Setting metadata ({'latest_build': '004d342a-0d96-40e8-a34d-9eadaabf333b'}) for http://localhost:9090/images/b626a6b4-0c90-459a-b5c6-ddc4c9e00725
2011-09-28 10:17:08,072 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(16110) Message: Setting metadata ({'latest_unpushed': None}) for http://localhost:9090/images/b626a6b4-0c90-459a-b5c6-ddc4c9e00725
2011-09-28 10:17:08,074 DEBUG imgfac.BuildJob.BuildAdaptor pid(16110) Message: Raising event with agent handler (<ImageFactoryAgent(Thread-1, initial)>), changed status from PUSHING to COMPLETED
2011-09-29 11:03:36,806 WARNING root pid(16110) Message: caught signal SIGTERM, stopping...
2011-09-29 11:03:52,173 INFO root pid(19434) Message: Launched as daemon...
2011-09-29 11:03:52,278 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(19434) Message: Created Image Warehouse instance http://localhost:9090 - buckets(target_images, templates, icicles, provider_images)
2011-09-29 11:03:52,279 INFO imgfac.qmfagent.ImageFactoryAgent.ImageFactoryAgent pid(19434) Message: image_factory has qmf/qpid address: redhat.com:imagefactory:7d73a13c-17cc-4d4d-a4a2-4da5e76d9726:image_factory
2011-09-29 11:04:57,289 WARNING root pid(19434) Message: caught signal SIGTERM, stopping...
2011-09-29 11:05:13,283 INFO root pid(20021) Message: Launched as daemon...
2011-09-29 11:05:13,301 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(20021) Message: Created Image Warehouse instance http://localhost:9090 - buckets(target_images, templates, icicles, provider_images)
2011-09-29 11:05:13,301 INFO imgfac.qmfagent.ImageFactoryAgent.ImageFactoryAgent pid(20021) Message: image_factory has qmf/qpid address: redhat.com:imagefactory:919c0552-1125-46e9-ab91-c89ac3e7daac:image_factory
[root@unused bin]# 

[root@unused bin]# rpm -qa | grep aeolus
aeolus-conductor-doc-0.4.0-0.20110929145941git7594098.fc15.noarch
aeolus-conductor-0.4.0-0.20110929145941git7594098.fc15.noarch
aeolus-conductor-daemons-0.4.0-0.20110929145941git7594098.fc15.noarch
aeolus-conductor-devel-0.4.0-0.20110929145941git7594098.fc15.noarch
aeolus-all-0.4.0-0.20110929145941git7594098.fc15.noarch
rubygem-aeolus-image-0.1.0-3.20110919115936gitd1d24b4.fc15.noarch
aeolus-configure-2.0.2-4.20110926142838git5044e56.fc15.noarch

Comment 5 errata-xmlrpc 2012-05-15 20:06:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0588.html


Note You need to log in before you can comment on or make changes to this bug.