Bug 717501 - [abrt] kernel: kernel BUG at fs/bio.c:159!: TAINTED -------D
[abrt] kernel: kernel BUG at fs/bio.c:159!: TAINTED -------D
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:75eb716728d12859db79253e1e7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-28 22:40 EDT by Donald Edward Winslow
Modified: 2011-08-17 22:34 EDT (History)
6 users (show)

See Also:
Fixed In Version: kernel-2.6.40.3-0.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-01 21:59:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Donald Edward Winslow 2011-06-28 22:40:03 EDT
abrt version: 2.0.3
architecture:   x86_64
cmdline:        ro root=UUID=cb01bad5-d7d0-432d-a890-eba71dbbf5e5 rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rhgb quiet
component:      kernel
kernel:         2.6.38.8-32.fc15.x86_64
kernel_tainted: 128
kernel_tainted_long: Kernel has oopsed before.
os_release:     Fedora release 15 (Lovelock)
package:        kernel
reason:         kernel BUG at fs/bio.c:159!
time:           Tue Jun 28 21:26:42 2011

backtrace:
:kernel BUG at fs/bio.c:159!
:invalid opcode: 0000 [#1] SMP 
:last sysfs file: /sys/devices/pci0000:00/0000:00:1d.7/usb2/idVendor
:CPU 1 
:Modules linked in: vfat fat nls_utf8 udf ses enclosure fuse sunrpc cpufreq_ondemand acpi_cpufreq freq_table mperf ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ftp rfcomm sco bnep l2cap virtio_net kvm_intel kvm snd_hda_codec_si3054 snd_hda_codec_realtek snd_hda_intel snd_hda_codec arc4 snd_hwdep snd_seq snd_seq_device iwl3945 uvcvideo snd_pcm btusb bluetooth videodev v4l2_compat_ioctl32 r8169 iwlcore mac80211 r852 sm_common snd_timer microcode nand nand_ids nand_ecc mii mtd snd cfg80211 iTCO_wdt i2c_i801 joydev soundcore snd_page_alloc iTCO_vendor_support serio_raw tpm_infineon asus_laptop sparse_keymap rfkill ipv6 sdhci_pci sdhci mmc_core uas usb_storage firewire_ohci firewire_core crc_itu_t i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:Pid: 8607, comm: umount Not tainted 2.6.38.8-32.fc15.x86_64 #1 To Be Filled By O.E.M. S62E/S62E
:RIP: 0010:[<ffffffff81147f9c>]  [<ffffffff81147f9c>] bvec_free_bs+0x11/0x37
:RSP: 0018:ffff88001e1ffa58  EFLAGS: 00010206
:RAX: ffff880076d5bd98 RBX: ffff880076d5bd50 RCX: 000000000000cbd8
:RDX: 000000000000000f RSI: ffff880076d5bd98 RDI: ffff88007a7d6140
:RBP: ffff88001e1ffa58 R08: ffff88007f5172b8 R09: ffff88001965f420
:R10: ffffc90000307000 R11: 0000000000000000 R12: ffff88007a7d6140
:R13: 0000000002000000 R14: 0000000000000000 R15: 0000000000000001
:FS:  00007f0f31b13820(0000) GS:ffff88007f500000(0000) knlGS:0000000000000000
:CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
:CR2: 00007ff590006520 CR3: 000000003ed4a000 CR4: 00000000000006e0
:DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
:DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
:Process umount (pid: 8607, threadinfo ffff88001e1fe000, task ffff88003dcec590)
:Stack:
: ffff88001e1ffa78 ffffffff81147ff6 ffff880076d5bd50 ffff88003dc5d0e0
: ffff88001e1ffa88 ffffffff8114803b ffff88001e1ffa98 ffffffff81211445
: ffff88001e1ffaf8 ffffffff81215d27 008000001e1ffb18 0000000000000000
:Call Trace:
: [<ffffffff81147ff6>] bio_free+0x34/0x64
: [<ffffffff8114803b>] bio_fs_destructor+0x15/0x17
: [<ffffffff81211445>] elv_set_request+0x1b/0x2c
: [<ffffffff81215d27>] get_request+0x1b8/0x262
: [<ffffffff8121676a>] get_request_wait+0x35/0x193
: [<ffffffff810b07a4>] ? __call_rcu+0x123/0x12c
: [<ffffffff81216907>] blk_get_request+0x3f/0x6e
: [<ffffffff812fc861>] scsi_execute+0x41/0x146
: [<ffffffff812fca02>] scsi_execute_req+0x9c/0xce
: [<ffffffff812f8a9c>] ioctl_internal_command.constprop.1+0x6b/0x163
: [<ffffffff812f8bed>] scsi_set_medium_removal+0x59/0x94
: [<ffffffff8130b225>] sr_lock_door+0x20/0x22
: [<ffffffff8132c475>] cdrom_release+0x195/0x205
: [<ffffffff81080608>] ? smp_call_function_many+0xec/0x1dc
: [<ffffffff8104127e>] ? should_resched+0xe/0x2d
: [<ffffffff81474408>] ? _cond_resched+0xe/0x22
: [<ffffffff8130a1b9>] sr_block_release+0x30/0x4d
: [<ffffffff81149aa2>] __blkdev_put+0xc6/0x179
: [<ffffffff81149c59>] blkdev_put+0x104/0x10c
: [<ffffffff81122f69>] kill_block_super+0x65/0x6a
: [<ffffffff811231a5>] deactivate_locked_super+0x26/0x4b
: [<ffffffff81123d0e>] deactivate_super+0x37/0x3b
: [<ffffffff8113863c>] mntput_no_expire+0xcc/0xd1
: [<ffffffff81139073>] sys_umount+0x2ac/0x2da
: [<ffffffff81009bc2>] system_call_fastpath+0x16/0x1b
:Code: 5d c3 55 48 89 e5 0f 1f 44 00 00 5d 0f b7 ff 48 6b ff 18 8b 87 80 d8 b3 81 c3 55 48 89 e5 0f 1f 44 00 00 83 fa 05 48 89 f0 76 02 <0f> 0b 75 0e 48 8b 77 20 48 89 c7 e8 f4 20 f9 ff eb 12 89 d2 48 
:RIP  [<ffffffff81147f9c>] bvec_free_bs+0x11/0x37
: RSP <ffff88001e1ffa58>

comment:
:In Dolphin file manager, I right-clicked on the icon for a large (1 TB) USB drive and chose "safely remove drive". The drive had not been used for some hours, so should not have been active. 
:The icon changed to indicate the drive was disconnected, but the message indicating that it was safe to remove did not come up. I disconnected anyway. The screen went black with lots of white 
:error messages, and then the desktop came back with the kerneloops message. This happened two of the three times I disconnected the drive today.
Comment 1 Dave Jones 2011-07-29 11:54:46 EDT
This bug should be fixed with 2.6.40-3 and higher (available in updates-testing. Please try that kernel, and leave feedback.

Thanks.
Comment 2 Fedora Update System 2011-07-29 12:01:19 EDT
kernel-2.6.40-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.40-3.fc15
Comment 3 Fedora Update System 2011-07-29 16:40:23 EDT
kernel-2.6.40-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.40-4.fc15
Comment 4 Fedora Update System 2011-07-30 23:33:33 EDT
Package kernel-2.6.40-4.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-2.6.40-4.fc15'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/kernel-2.6.40-4.fc15
then log in and leave karma (feedback).
Comment 5 Donald Edward Winslow 2011-07-31 12:40:51 EDT
I booted kernel-2.6.40-3 and did not get this bug or have any other problems. I'll test kernel-2.6.40-3 as soon as I get a chance.
Comment 6 Donald Edward Winslow 2011-07-31 13:25:28 EDT
In that last comment I meant to say I'll test kernel-2.6.40-4 as soon as I can.
Comment 7 Donald Edward Winslow 2011-07-31 15:18:07 EDT
I booted kernel-2.6.40-4. It seems to work fine. I'm unable to mount the USB drive mentioned above (doesn't even show up in /dev/disk/by-label), but the drive seems to be defective now--I can't see it from any other device either.
Comment 8 Fedora Update System 2011-08-01 21:58:11 EDT
kernel-2.6.40-4.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2011-08-16 08:48:25 EDT
kernel-2.6.40.3-0.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.40.3-0.fc15
Comment 10 Fedora Update System 2011-08-17 22:31:14 EDT
kernel-2.6.40.3-0.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.