Bug 717507 - SELinux is preventing /bin/bash from 'read' accesses on the directory /var/spool/cron.
Summary: SELinux is preventing /bin/bash from 'read' accesses on the directory /var/sp...
Keywords:
Status: CLOSED DUPLICATE of bug 717505
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 15
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:a80bf7add6b...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-06-29 03:29 UTC by cyrushmh
Modified: 2011-07-04 06:55 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-29 08:09:40 UTC


Attachments (Terms of Use)

Description cyrushmh 2011-06-29 03:29:42 UTC
SELinux is preventing /bin/bash from 'read' accesses on the directory /var/spool/cron.

*****  Plugin catchall (50.5 confidence) suggests  ***************************

If you believe that bash should be allowed read access on the cron directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep prelink /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

*****  Plugin leaks (50.5 confidence) suggests  ******************************

If you want to ignore bash trying to read access the cron directory, because you believe it should not need this access.
Then you should report this as a bug.  
You can generate a local policy module to dontaudit this access.
Do
# grep /bin/bash /var/log/audit/audit.log | audit2allow -D -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:prelink_cron_system_t:s0-s0:c0.c
                              1023
Target Context                system_u:object_r:cron_spool_t:s0
Target Objects                /var/spool/cron [ dir ]
Source                        prelink
Source Path                   /bin/bash
Port                          <未知>
Host                          (removed)
Source RPM Packages           bash-4.2.10-4.fc15
Target RPM Packages           cronie-1.4.8-1.fc15
Policy RPM                    selinux-policy-3.9.16-30.fc15
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.38.8-32.fc15.x86_64 #1 SMP Mon Jun 13 19:49:05
                              UTC 2011 x86_64 x86_64
Alert Count                   1
First Seen                    2011年06月29日 星期三 11时28分14秒
Last Seen                     2011年06月29日 星期三 11时28分14秒
Local ID                      69fb6f61-3843-4703-a8b8-72feb0f36175

Raw Audit Messages
type=AVC msg=audit(1309318094.558:70): avc:  denied  { read } for  pid=16211 comm="prelink" path="/var/spool/cron" dev=sda6 ino=2492311 scontext=system_u:system_r:prelink_cron_system_t:s0-s0:c0.c1023 tcontext=system_u:object_r:cron_spool_t:s0 tclass=dir


type=AVC msg=audit(1309318094.558:70): avc:  denied  { read } for  pid=16211 comm="prelink" path="/etc/cron.d" dev=sda6 ino=3016152 scontext=system_u:system_r:prelink_cron_system_t:s0-s0:c0.c1023 tcontext=system_u:object_r:system_cron_spool_t:s0 tclass=dir


type=AVC msg=audit(1309318094.558:70): avc:  denied  { read } for  pid=16211 comm="prelink" path="/etc/crontab" dev=sda6 ino=3016242 scontext=system_u:system_r:prelink_cron_system_t:s0-s0:c0.c1023 tcontext=system_u:object_r:system_cron_spool_t:s0 tclass=file


type=SYSCALL msg=audit(1309318094.558:70): arch=x86_64 syscall=execve success=yes exit=0 a0=1c4fd00 a1=1c55600 a2=1c53f50 a3=7fff0ae58f40 items=0 ppid=13270 pid=16211 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=3 comm=prelink exe=/bin/bash subj=system_u:system_r:prelink_cron_system_t:s0-s0:c0.c1023 key=(null)

Hash: prelink,prelink_cron_system_t,cron_spool_t,dir,read

audit2allow

#============= prelink_cron_system_t ==============
allow prelink_cron_system_t cron_spool_t:dir read;
allow prelink_cron_system_t system_cron_spool_t:dir read;
allow prelink_cron_system_t system_cron_spool_t:file read;

audit2allow -R

#============= prelink_cron_system_t ==============
allow prelink_cron_system_t cron_spool_t:dir read;
allow prelink_cron_system_t system_cron_spool_t:dir read;
allow prelink_cron_system_t system_cron_spool_t:file read;

Comment 1 Miroslav Grepl 2011-06-29 08:09:40 UTC

*** This bug has been marked as a duplicate of bug 717505 ***


Note You need to log in before you can comment on or make changes to this bug.