Bug 71751 - SFTP connections fail using tcsh as shell
SFTP connections fail using tcsh as shell
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: tcsh (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-17 20:17 EDT by Robert Buffington
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-19 13:33:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Buffington 2002-08-17 20:17:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.0.3705)

Description of problem:
Using the SSH Secure File Transfer (SFTP) with SSH Secure Shell version 3.1.0 
for Windows, I receive a "connection was lost" message with my shell set 
to /bin/csh (/bin/tcsh). I get no such error when using /bin/bash. Connections 
do not fail with the SSH Secure Shell (SSH) using the same program.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. set an account's shell to /bin/tcsh
2. Try to establish a Secure File Transfer to that account with the Windows 
SSH SFTP client available from ssh.com.

	

Actual Results:  "Connection was lost."

Expected Results:  Expected results can be seen if the same account sets the 
default shell to /bin/bash.

Additional info:

No obvious error messages in the server logs to help in figuring this out. 
According to the logs, the connection is successful.
Comment 1 Miloslav Trmač 2004-08-19 11:55:04 EDT
I can't reproduce this, using openssh-3.6.1p2-34 both as a server and
a client.

Please provide strace logs of the failed session:
Create a wrapper script:

cat > wrapper << EOF
#! /bin/sh
strace -ff -o ~/log /bin/tcsh "$@"
EOF
chmod a+x wrapper

Set this wrapper script as user's shell instead of /bin/tcsh
(you will probably have to edit /etc/passwd by hand or at least
add path to the script to /etc/shells), attempt to connect using
sftp.
You should get a few files in ~/log*, please attach a tarball
of them.
Comment 2 Robert Buffington 2004-08-19 13:33:51 EDT
Please file this as "NOTABUG". The problem was with a custom startup 
script (in /etc/profile.d) that was producing output to STDOUT which 
was confusing the SFTP client.

Note You need to log in before you can comment on or make changes to this bug.