Bug 717525 - destroying PV guest too quickly leaves qemu-dm not killed
Summary: destroying PV guest too quickly leaves qemu-dm not killed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen
Version: 5.7
Hardware: All
OS: All
medium
high
Target Milestone: rc
: ---
Assignee: Paolo Bonzini
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-06-29 06:36 UTC by Jinxin Zheng
Modified: 2012-02-21 05:55 UTC (History)
6 users (show)

Fixed In Version: xen-3.0.3-133.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-21 05:55:28 UTC
Target Upstream Version:


Attachments (Terms of Use)
the domain config (395 bytes, text/plain)
2011-06-29 06:37 UTC, Jinxin Zheng
no flags Details
xend.log (26.21 KB, text/plain)
2011-06-29 06:37 UTC, Jinxin Zheng
no flags Details
qemu-dm.log (357 bytes, text/plain)
2011-06-29 06:38 UTC, Jinxin Zheng
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0160 normal SHIPPED_LIVE xen bug fix and enhancement update 2012-02-20 14:53:33 UTC

Description Jinxin Zheng 2011-06-29 06:36:51 UTC
Description of problem:
Create the guest, then destroy it immediately, qemu-dm is usually left not killed, causing later created guests fail to respond on vnc.

Version-Release number of selected component (if applicable):
xen-3.0.3-132.el5
kernel-xen-2.6.18-269.el5

How reproducible:
70%~80%

Steps to Reproduce:
1. xm create domU
2. after 'xm create' returns, xm destroy domU immediately.
3. ps -ef

Actual results:
qemu-dm is still there.

Expected results:
no qemu-dm running.

Additional info:
Host is AMD with 128G memory. It's more reproducible on a machine with large memory.

The bug 610208, which was closed 'insufficient data', seems relevant.

Comment 1 Jinxin Zheng 2011-06-29 06:37:26 UTC
Created attachment 510397 [details]
the domain config

Comment 2 Jinxin Zheng 2011-06-29 06:37:45 UTC
Created attachment 510398 [details]
xend.log

Comment 3 Jinxin Zheng 2011-06-29 06:38:15 UTC
Created attachment 510399 [details]
qemu-dm.log

Comment 4 Miroslav Rezanina 2011-06-29 09:25:41 UTC
Problem only for PV guest as qemu-dm is setuping xenpv machine and do not recieve kill signal.

Comment 8 Yuyu Zhou 2011-11-30 06:33:32 UTC
reproduce the bug in xen-3.0.3-132.el5 and verify the bug in xen-3.0.3-135.el5.

Steps of reproduce:
1. destroy a pv guest right after it is created
# xm cr pv.cfg; xm des RHEL5.8-64-PV
Using config file "./pv.cfg".
Using <class 'grub.GrubConf.GrubConfigFile'> to parse /grub/menu.lst
Started domain RHEL5.8-64-PV
2. check the xm list, there is no guest running.
# xm list
Name                                      ID Mem(MiB) VCPUs State   Time(s)
Domain-0                                   0     2880     2 r-----    942.9
3. Check the processes, and the qemu-dm is not killed
# ps aux | grep qemu
root     11627  0.1  0.1  90444  4824 ?        Sl   14:27   0:00 /usr/lib64/xen/bin/qemu-dm -M xenpv -d 5 -domain-name RHEL5.8-64-PV -vnc 0.0.0.0:0 -vncunused -k en-us
root     11892  0.0  0.0  61172   736 pts/0    S+   14:27   0:00 grep qemu

Verify the bug with same steps as reproduce, and repeat the test for 5 times, the qemu-dm is killed every time.

So change this bug into VERIFIED.

Comment 9 errata-xmlrpc 2012-02-21 05:55:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0160.html


Note You need to log in before you can comment on or make changes to this bug.