Bug 717557 - SELinux is preventing /bin/mailx from 'read' accesses on the directory /var/spool/cron.
Summary: SELinux is preventing /bin/mailx from 'read' accesses on the directory /var/s...
Keywords:
Status: CLOSED DUPLICATE of bug 717505
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 15
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:2fe58bc1414...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-06-29 08:42 UTC by edo
Modified: 2011-06-29 08:45 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-29 08:45:23 UTC


Attachments (Terms of Use)

Description edo 2011-06-29 08:42:36 UTC
SELinux is preventing /bin/mailx from 'read' accesses on the directory /var/spool/cron.

*****  Plugin leaks (50.5 confidence) suggests  ******************************

If you want to ignore mailx trying to read access the cron directory, because you believe it should not need this access.
Then you should report this as a bug.  
You can generate a local policy module to dontaudit this access.
Do
# grep /bin/mailx /var/log/audit/audit.log | audit2allow -D -M mypol
# semodule -i mypol.pp

*****  Plugin catchall (50.5 confidence) suggests  ***************************

If you believe that mailx should be allowed read access on the cron directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep mail /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:system_mail_t:s0-s0:c0.c1023
Target Context                system_u:object_r:cron_spool_t:s0
Target Objects                /var/spool/cron [ dir ]
Source                        mail
Source Path                   /bin/mailx
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           mailx-12.5-3.fc15
Target RPM Packages           cronie-1.4.8-1.fc15
Policy RPM                    selinux-policy-3.9.16-30.fc15
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.38.8-32.fc15.x86_64 #1 SMP Mon Jun 13 19:49:05
                              UTC 2011 x86_64 x86_64
Alert Count                   1
First Seen                    St 29. jún 2011, 10:32:32 CEST
Last Seen                     St 29. jún 2011, 10:32:32 CEST
Local ID                      dad6c2d2-6a83-4520-9097-2f30a5a35af0

Raw Audit Messages
type=AVC msg=audit(1309336352.385:115): avc:  denied  { read } for  pid=20855 comm="mail" path="/var/spool/cron" dev=dm-0 ino=656763 scontext=system_u:system_r:system_mail_t:s0-s0:c0.c1023 tcontext=system_u:object_r:cron_spool_t:s0 tclass=dir


type=AVC msg=audit(1309336352.385:115): avc:  denied  { read } for  pid=20855 comm="mail" path="/etc/cron.d" dev=dm-0 ino=1049911 scontext=system_u:system_r:system_mail_t:s0-s0:c0.c1023 tcontext=system_u:object_r:system_cron_spool_t:s0 tclass=dir


type=SYSCALL msg=audit(1309336352.385:115): arch=x86_64 syscall=execve success=yes exit=0 a0=925680 a1=928da0 a2=929840 a3=8 items=0 ppid=22146 pid=20855 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=5 comm=mail exe=/bin/mailx subj=system_u:system_r:system_mail_t:s0-s0:c0.c1023 key=(null)

Hash: mail,system_mail_t,cron_spool_t,dir,read

audit2allow

#============= system_mail_t ==============
allow system_mail_t cron_spool_t:dir read;
allow system_mail_t system_cron_spool_t:dir read;

audit2allow -R

#============= system_mail_t ==============
allow system_mail_t cron_spool_t:dir read;
allow system_mail_t system_cron_spool_t:dir read;

Comment 1 Miroslav Grepl 2011-06-29 08:45:23 UTC

*** This bug has been marked as a duplicate of bug 717505 ***


Note You need to log in before you can comment on or make changes to this bug.