This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 717564 - Provide native systemd unit file
Provide native systemd unit file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openct (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
: 820138 (view as bug list)
Depends On:
Blocks: SysVtoSystemd
  Show dependency treegraph
 
Reported: 2011-06-29 05:03 EDT by Jóhann B. Guðmundsson
Modified: 2012-07-27 16:19 EDT (History)
2 users (show)

See Also:
Fixed In Version: openct-0.6.20-5.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-27 16:19:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Native systemd service file for openct (378 bytes, text/plain)
2011-06-29 05:04 EDT, Jóhann B. Guðmundsson
no flags Details
Minor cleanup to the service (331 bytes, text/plain)
2011-06-30 06:22 EDT, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2011-06-29 05:03:52 EDT
Description of problem:
https://fedoraproject.org/wiki/Features/SysVtoSystemd


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2011-06-29 05:04:44 EDT
Created attachment 510416 [details]
Native systemd service file for openct
Comment 2 Tomas Mraz 2011-06-30 05:51:19 EDT
I am afraid that this will not be as trivial - note that the status does a different thing than usual - is it possible to achieve similar thing with systemd unit?
That is to execute arbitrary commands to get status of the service?
Comment 3 Jóhann B. Guðmundsson 2011-06-30 06:21:58 EDT
Nope not that I'm aware of ( it would have probably been ExecStatus=/$foo if it existed ).
Comment 4 Jóhann B. Guðmundsson 2011-06-30 06:22:58 EDT
Created attachment 510630 [details]
Minor cleanup to the service
Comment 5 Tomas Mraz 2012-07-27 10:15:31 EDT
*** Bug 820138 has been marked as a duplicate of this bug. ***
Comment 6 Tomas Mraz 2012-07-27 16:19:08 EDT
I finally gave up waiting for the ExecStatus to be implemented and just left the extra status unimplemented.

Thanks for the unit file.

Note You need to log in before you can comment on or make changes to this bug.