Bug 717616 - Rebase the setroubleshoot tool to match gui within Fedora 14 and later versions.
Rebase the setroubleshoot tool to match gui within Fedora 14 and later versions.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: setroubleshoot (Show other bugs)
6.1
All Linux
medium Severity medium
: rc
: ---
Assigned To: Daniel Walsh
Milos Malik
: Rebase
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-29 08:03 EDT by Daniel Walsh
Modified: 2011-12-06 04:49 EST (History)
2 users (show)

See Also:
Fixed In Version: setroubleshoot-3.0.37-1.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 04:49:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Walsh 2011-06-29 08:03:02 EDT
We were in the middle of a redesign of setroubleshoot that was not quite ready for prime time when RHEL6 froze.  We have now run this new version of setroubleshoot on three versions of Fedora and it has many improvements, that I would like to get in RHEL6.

1. Redesigned simpler to us GUI, that allows the user to select the correct SELinux solution rather then the tool attempting to select the correct solution.

2. The current tool selects the language at translation on the server side and stores the translations in the XML database.  This has caused certain lanquages like Japanese to break the system.  The new tool stores the data in English and then translates on the client.  This allows us to display multiple lanquages from the same database.

3.  GUI has also been redesigned to make "ignore" buttons work better and easier to turn off the tool altogether.
Comment 1 Daniel Walsh 2011-06-29 08:04:41 EDT
Fixed in setroubleshoot-3.0.37-1.el6
Comment 9 errata-xmlrpc 2011-12-06 04:49:21 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1509.html

Note You need to log in before you can comment on or make changes to this bug.