Bug 717654 - subscription-manager does not have it's own policy
subscription-manager does not have it's own policy
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
All Linux
medium Severity medium
: rc
: 6.2
Assigned To: Bryan Kearney
IDM QE LIST
:
Depends On: 694879
Blocks: rhsm-rhel62 748554
  Show dependency treegraph
 
Reported: 2011-06-29 09:46 EDT by Miroslav Grepl
Modified: 2013-01-10 05:53 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 694879
Environment:
Last Closed: 2011-12-06 12:19:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 1 Miroslav Grepl 2011-06-29 09:49:07 EDT
I created a new policy but we need to patch init script file.

 [ $RETVAL -eq 0 ] && touch $LOCK
+[ -x /sbin/restorecon ] && /sbin/restorecon $LOCK


with this patch the lock file will be created with the right label.
Comment 2 Miroslav Grepl 2011-10-05 01:13:59 EDT
Well not sure why this fix is not going to RHEL6.2. This relates with policy changes.
Comment 4 Alex Wood 2011-10-17 15:47:41 EDT
Committed be21aa786f3df02dda1257dd0b5ef575f119ad9d
Comment 14 J.C. Molet 2011-10-25 09:35:42 EDT
running rhel6.2 snapshot 3, which uses rhsm versions:

subscription-manager-0.96.16-1.el6.x86_64
subscription-manager-firstboot-0.96.16-1.el6.x86_64
subscription-manager-gnome-0.96.16-1.el6.x86_64

rhsmcertd appears to be confined at startup:

ps auxfwwwZ | grep /usr/bin/rhsmcertd | grep -v grep
system_u:system_r:rhsmcertd_t:s0 root     1989  0.0  0.0   4112   404 ?        Ss   Oct24   0:00 /usr/bin/rhsmcertd 240 1440
system_u:system_r:rhsmcertd_t:s0 root     1991  0.0  0.0   4112   404 ?        S    Oct24   0:00  \_ /usr/bin/rhsmcertd 240 1440


rhsmcertd has its own binary context:

[root@jmolet-rhel62s3 ~]# ls -laZ /usr/bin/rhsmcertd
-rwxr-xr-x. root root system_u:object_r:rhsmcertd_exec_t:s0 /usr/bin/rhsmcertd
Comment 15 errata-xmlrpc 2011-12-06 12:19:36 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.