Bug 717664 - RFE - usability request for feedback after call to subscription-manager subscribe
RFE - usability request for feedback after call to subscription-manager subsc...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Bryan Kearney
John Sefler
: FutureFeature
: 706223 (view as bug list)
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-06-29 10:22 EDT by John Sefler
Modified: 2012-02-22 14:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:21:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2011-06-29 10:22:12 EDT
Description of problem:
As an incremental step to improve the usability based on mmccune's subscription-manager experience (nicely documented here https://engineering.redhat.com/trac/kalpana/wiki/SubscriptionManagerReview), I am opening this bug to call out a need and generate ideas for more informative feedback after calling subscription-manager subscribe.

The current behavior is:
# subscription-manager subscribe --pool=8a99f981308acf420130991163ac0c56
# 

^^^ NO FEEDBACK, NOT EVEN A "You have successfully subscribed to blah"


Since the effect of a successful subscribe is access to additional yum repositories, here is a suggestion for subscribe feedback:
# subscription-manager subscribe --pool=8a99f981308acf420130991163ac0c56
You have successfully been granted entitlement abcd-1234 that includes the following repositories in /etc/yum.repos.d/redhat.repo :
repo id                                              repo name                                                                       status
-------                                              ---------                                                                       ------
rhel-6-server-beta-debug-rpms                        Red Hat Enterprise Linux 6 Server Beta (Debug RPMs)                             disabled
rhel-6-server-beta-rpms                              Red Hat Enterprise Linux 6 Server Beta (RPMs)                                   disabled
rhel-6-server-beta-source-rpms                       Red Hat Enterprise Linux 6 Server Beta (Source RPMs)                            disabled
rhel-6-server-debug-rpms                             Red Hat Enterprise Linux 6 Server (Debug RPMs)                                  disabled
rhel-6-server-optional-beta-debug-rpms               Red Hat Enterprise Linux 6 Server - Optional Beta (Debug RPMs)                  disabled
rhel-6-server-optional-beta-rpms                     Red Hat Enterprise Linux 6 Server - Optional Beta (RPMs)                        disabled
rhel-6-server-optional-beta-source-rpms              Red Hat Enterprise Linux 6 Server - Optional Beta (Source RPMs)                 disabled
rhel-6-server-optional-debug-rpms                    Red Hat Enterprise Linux 6 Server - Optional (Debug RPMs)                       disabled
rhel-6-server-optional-rpms                          Red Hat Enterprise Linux 6 Server - Optional (RPMs)                             disabled
rhel-6-server-optional-source-rpms                   Red Hat Enterprise Linux 6 Server - Optional (Source RPMs)                      disabled
rhel-6-server-rpms                                   Red Hat Enterprise Linux 6 Server (RPMs)                                        enabled: 5,078
rhel-6-server-source-rpms                            Red Hat Enterprise Linux 6 Server (Source RPMs)                                 disabled
rhel-6-server-supplementary                          Red Hat Enterprise Linux 6 Server - Supplementary (RPMs)                        disabled
rhel-6-server-supplementary-beta                     Red Hat Enterprise Linux 6 Server - Supplementary Beta (RPMs)                   disabled
rhel-6-server-supplementary-beta-debuginfo           Red Hat Enterprise Linux 6 Server - Supplementary Beta (Debug RPMs)             disabled
rhel-6-server-supplementary-beta-src                 Red Hat Enterprise Linux 6 Server - Supplementary Beta (Source RPMs)            disabled
rhel-6-server-supplementary-debuginfo                Red Hat Enterprise Linux 6 Server - Supplementary (Debug RPMs)                  disabled
rhel-6-server-supplementary-src                      Red Hat Enterprise Linux 6 Server - Supplementary (Source RPMs)                 disabled
rhel-source                                          Red Hat Enterprise Linux 6Server - x86_64 - Source                              disabled
rhel-source-beta                                     Red Hat Enterprise Linux 6Server Beta - x86_64 - Source                         disabled



In addition to the command line tool, feedback in the subscription-manager-gui would also be useful.  I believe Paul Lightfoot should be included in these design enhancements...
Suggestion 1: double clicking the subscription in the "My Subscriptions" tab opens a dialog that shows the entitled repos id, repo name, enabled status
Suggestion 2: include a table in the subscription details pane (scrolled out of view?) that contains the entitled repos id, repo name, enabled status
Comment 2 John Sefler 2011-06-29 10:30:23 EDT
Ooops, bugzilla's formatting of that suggested feedback did not work well, I'll try again...

# subscription-manager subscribe --pool=8a99f981308acf420130991163ac0c56
You have successfully been granted entitlement abcd-1234 that includes the
following repositories in /etc/yum.repos.d/redhat.repo :
repo id                repo name                      status
-------                ---------                      ------
rhel-6-server-rpms     Red Hat Enterprise Linux 6     enabled: 5,078
rhel-6-server-suppl    RHEL 6 Supplementary           disabled
rhel-6-server-debug    RHEL 6 Debug rpms              disabled
Comment 3 Bryan Kearney 2011-07-18 15:15:58 EDT
For the first part, you now get:

[root@bkearney src]# ./subscription-manager subscribe --pool ff808081313e7e6201313e7f42de0705
Successfully subscribed the system to Pool ff808081313e7e6201313e7f42de0705
[root@bkearney src]# 


Auto subscribe now looks like:

Installed Product Current Status:

ProductName:         	Awesome OS Server Bits   
Status:               	Subscribed        

Fixed in ba3a22a12121c33cc8b71e474cb56b658b63dd13 in master.
Comment 5 John Sefler 2011-07-26 17:33:39 EDT
Verifying Version...
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.4-1.git.64.b534693.el6.x86_64


[root@jsefler-onprem-62server ~]# subscription-manager subscribe --pool=8a90f8c631680f1401316810903a0685
Successfully subscribed the system to Pool 8a90f8c631680f1401316810903a0685

^^^ VERIFIED THAT WE NOW GET A SUCCESSFUL FEEDBACK MESSAGE UPON SUBSCRIBING

The request for a list of repos is not handled by the new subscription-manager repos module...

[root@jsefler-onprem-62server ~]# subscription-manager repos --list
+----------------------------------------------------------+
    Entitled Repositories in /etc/yum.repos.d/redhat.repo
+----------------------------------------------------------+

RepoName:            	never-enabled-content    
RepoId:              	never-enabled-content    
RepoUrl:             	https://mockamai.devlab.phx1.redhat.com/foo/path/never
Enabled:             	0                        


RepoName:            	always-enabled-content   
RepoId:              	always-enabled-content   
RepoUrl:             	https://mockamai.devlab.phx1.redhat.com/foo/path/always
Enabled:             	1                        


RepoName:            	content                  
RepoId:              	content-label            
RepoUrl:             	https://mockamai.devlab.phx1.redhat.com/foo/path
Enabled:             	1     



Also verifying feedback from autosubscribe...

[root@jsefler-onprem-62server ~]# subscription-manager subscribe --auto
Installed Product Current Status:

ProductName:         	Awesome OS Server Bits   
Status:               	Subscribed        


ProductName:         	Awesome OS Workstation Bits
Status:               	Subscribed               


ProductName:         	Multiplier Product Bits  
Status:               	Not Subscribed           


ProductName:         	Awesome OS for z80 Bits  
Status:               	Not Subscribed   




Moving to VERIFIED


Note: Still TODO for the sake of parity is implement a corresponding feature in the subscription-manager-gui that displays the entitled repos.
Comment 6 Paul Lightfoot 2011-07-27 11:09:03 EDT
(In reply to comment #5)
> Verifying Version...
> [root@jsefler-onprem-62server ~]# rpm -q subscription-manager
> subscription-manager-0.96.4-1.git.64.b534693.el6.x86_64
> 
> 
> [root@jsefler-onprem-62server ~]# subscription-manager subscribe
> --pool=8a90f8c631680f1401316810903a0685
> Successfully subscribed the system to Pool 8a90f8c631680f1401316810903a0685
> 
> ^^^ VERIFIED THAT WE NOW GET A SUCCESSFUL FEEDBACK MESSAGE UPON SUBSCRIBING
> 
> The request for a list of repos is not handled by the new subscription-manager
> repos module...
> 
> [root@jsefler-onprem-62server ~]# subscription-manager repos --list
> +----------------------------------------------------------+
>     Entitled Repositories in /etc/yum.repos.d/redhat.repo
> +----------------------------------------------------------+
> 
> RepoName:             never-enabled-content    
> RepoId:               never-enabled-content    
> RepoUrl:              https://mockamai.devlab.phx1.redhat.com/foo/path/never
> Enabled:              0                        
> 
> 
> RepoName:             always-enabled-content   
> RepoId:               always-enabled-content   
> RepoUrl:              https://mockamai.devlab.phx1.redhat.com/foo/path/always
> Enabled:              1                        
> 
> 
> RepoName:             content                  
> RepoId:               content-label            
> RepoUrl:              https://mockamai.devlab.phx1.redhat.com/foo/path
> Enabled:              1     
> 
> 
> 
> Also verifying feedback from autosubscribe...
> 
> [root@jsefler-onprem-62server ~]# subscription-manager subscribe --auto
> Installed Product Current Status:
> 
> ProductName:          Awesome OS Server Bits   
> Status:                Subscribed        
> 
> 
> ProductName:          Awesome OS Workstation Bits
> Status:                Subscribed               
> 
> 
> ProductName:          Multiplier Product Bits  
> Status:                Not Subscribed           
> 
> 
> ProductName:          Awesome OS for z80 Bits  
> Status:                Not Subscribed   
> 
> 
> 
> 
> Moving to VERIFIED
> 
> 
> Note: Still TODO for the sake of parity is implement a corresponding feature in
> the subscription-manager-gui that displays the entitled repos.

Regarding adding the repo info to the subscription-manager-gui, my thinking is that this is best done by adding a table in the Subscription Details pane—which I believe was John's suggestion #2.
Comment 7 John Sefler 2011-07-28 09:46:42 EDT
Paul,  I have a better suggestion for repos list in the subscription-manager-gui

Suggestion 3: Add another tab next to right of "My Subscription" called "My Repositories" that contains a table of all the repositories provided by my subscriptions.  There could also be a filter to show all/enabled/disabled repos.  And then looking forward when bkearney implements a cli function to "subscription-manager repos --enabledrepo=<repoid> --disablerepo=<repoid>", the same tabbed panel in the gui with the table of repos could include checkboxes and a submit buttons to enable/disable the repos.

bkearney throw that ^^^ on the backlog.
Comment 8 errata-xmlrpc 2011-12-06 12:21:39 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html
Comment 9 Bryan Kearney 2012-02-22 14:07:37 EST
*** Bug 706223 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.