Bug 71768 - APT would be better
APT would be better
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
http://apt4rpm.sourceforge.net/
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-18 11:11 EDT by ruysenaars
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-20 22:39:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ruysenaars 2002-08-18 11:11:05 EDT
I don't understand why package management is still a PITA in redhat, and that
you still aren't using apt4rpm. Using it would greatly improve ease of use. It
works great, Conectiva uses it already.

http://freshrpms.net/apt/
http://distro.conectiva.com.br/projetos/42
Comment 1 Tim Powers 2002-08-20 10:25:44 EDT
Reassigning to rpm component.
Comment 2 Jeff Johnson 2002-08-20 10:33:55 EDT
This is an up2date or anaconda RFE, as rpm is
an analogue of dpkg, not apt.
Comment 3 Mantas Kriaučiūnas 2003-01-16 04:20:45 EST
APT already runs on Red Hat, see:

http://apt4rpm.sourceforge.net/

Maybe Red Hat developers can collaborate with this project and integrate APT in
Red Hat ASAP ?

P.S. If there were voting system in RH bugzilla, this bug would have high rating :)
Comment 4 Adrian Likins 2003-01-20 22:39:32 EST
apt doesn't have many of the features RHN needs, so it's
not a replacement for up2date. 

If you want the package added, the place to file
a report is against "distribution"

Untill APT supports the features RHN needs, this
bug is closed.
Comment 5 Warren Togami 2003-01-20 23:10:34 EST
I'm currently working on package GPG checking for apt amongst other features. 
Could you please provide a list of features needed for RHN?
Comment 6 Mantas Kriaučiūnas 2003-01-23 04:04:00 EST
I reported a bug against "distribution" as you told - see bug# 82542
Comment 7 Mantas Kriaučiūnas 2003-01-24 09:46:20 EST
Reh Hat developers should talk more with each other:

from bug bug# 82542:
 Bill Nottingham on 2003-01-23 18:03 <notting@redhat.com> wrote:
>"APT is like up2data. (sic)"
>Exactly. If there are features missing from up2date that you'd like, please file
>them against enhancement requests against up2date or RHN.

Warren Togami <warren@togami.com> on 2003-01-20 23:10 wrote:
>I'm currently working on package GPG checking for apt amongst other features. 

There is a GPG checking posibility in Debian - see: 
http://packages.debian.org/unstable/non-us/debsig-verify.html

APT in Debian works correctly with debsig, and as I know rpm in Red Hat has
signature checking possibility. APT on RH uses rpm, then maybe there are no
necessity to change apt4rpm ?
Comment 8 Adrian Likins 2003-01-24 15:49:04 EST
>Exactly. If there are features missing from up2date that you'd like, please file
>them against enhancement requests against up2date or RHN.

I'll all about feature requests. Lets hear em (in seperate bug
reports please).

Basically, apt doesn't do a lot of the RHN related stuff
that up2date does. I have no plans to add them to APT. 
If someone else does, that might be cool. But until
that happens, APT isn't a drop-in replacement for
up2date (or vice versa). So since I can't replace
up2date with APT, this bug is closed.

As mentioned above, if there are useful apt
features missing from up2date, file a enhancement
bug report for them. They may get added ;->
Comment 9 Adrian Likins 2003-01-24 15:55:48 EST
> Could you please provide a list of features needed for RHN?

quick list:

rhnsd support
support for registering systems to RHN
support for uploading hardware info
"action" support
support for rhn channels
a simple gui
full dep resolution support (inc conflicts, file deps, obsoletes, etc)
 

Note You need to log in before you can comment on or make changes to this bug.