Bug 717694 - kdepim-mobile stuff should be packaged separately (or not at all)
kdepim-mobile stuff should be packaged separately (or not at all)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16Blocker/F16FinalBlocker F16Blockers390x F16Blockerppc
  Show dependency treegraph
 
Reported: 2011-06-29 11:27 EDT by Romain DEP.
Modified: 2012-03-14 09:10 EDT (History)
7 users (show)

See Also:
Fixed In Version: kdepim-4.6.0-2.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-29 19:31:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Romain DEP. 2011-06-29 11:27:27 EDT
Description of problem:
kdepim from kde-testing (at least) comes with -mobile apps (kmail-mobile, korganizer-mobile and so on)

Actual results:
those packages shouldn't be installed this way, along 'regular' non-mobile pim-apps, moreover as they crash at startup

Expected results:
These binaries should be packaged separately, or don't be packaged at all as they are that unstable.
Comment 1 Kevin Kofler 2011-06-29 18:23:00 EDT
Having stuff in the live image's menu which crashes as soon as it's started is a clear blocker as per
https://fedoraproject.org/wiki/Fedora_16_Final_Release_Criteria
paragraph 11 (menu sanity). (I assume that QA will agree.)

We really need to get this broken pre-alpha-quality software the heck out of the default installation. It shouldn't be too hard to subpackage it, or just kill it entirely.
Comment 2 Kevin Kofler 2011-06-29 18:34:18 EDT
So, as I don't think it makes sense to ship a subpackage which doesn't work, I just disabled KDEPIM_BUILD_MOBILE in kdepim-4.6.0-2.fc16.
Comment 3 Kevin Kofler 2011-06-29 19:31:36 EDT
3170845 build (dist-rawhide, /kdepim:f7bd2a19797b9e3eb11c73589f9efc0fe90674ac) completed successfully

Looks like this blocker isn't going to delay the release. ;-)

Closing.

Note You need to log in before you can comment on or make changes to this bug.