Bug 717788 - NPE on Inventory>Agent subtab for a platform that has UNKNOWN avail and has never been UP
NPE on Inventory>Agent subtab for a platform that has UNKNOWN avail and has n...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.1
Unspecified Unspecified
low Severity high (vote)
: ---
: ---
Assigned To: Jay Shaughnessy
Mike Foley
:
Depends On:
Blocks: jon3 rhq41-ui
  Show dependency treegraph
 
Reported: 2011-06-29 16:55 EDT by Ian Springer
Modified: 2013-08-05 20:39 EDT (History)
5 users (show)

See Also:
Fixed In Version: 4.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Springer 2011-06-29 16:55:34 EDT
From mazz: I would BZ that and indicate that its because there was no avail data
 - probably an easy NPE fix.

Here's the stack trace (unfortunately a js stack since it's from prod mode):

Message: Globally uncaught exception
Severity: Error
Time : Wednesday, June 29, 2011 4:42:39 PM Etc/GMT+4
Detail :	
com.google.gwt.core.client.JavaScriptException:(TypeError): Cannot read property 'java_lang_Long_value' of null arguments: java_lang_Long_value, type: non_object_property_load stack: TypeError: Cannot read property 'java_lang_Long_value' of null at org_rhq_enterprise_gui_coregui_client_inventory_resource_detail_inventory_ResourceResourceAgentView$1_$onSuccess__Lorg_rhq_enterprise_gui_coregui_client_inventory_resource_detail_inventory_ResourceResourceAgentView$1_2Lorg_rhq_core_domain_resource_Agent_2V (http://jon06.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/341D86321ECE4289E0459672BA4BDE1F.cache.html:136352:517) at Object.org_rhq_enterprise_gui_coregui_client_inventory_resource_detail_inventory_ResourceResourceAgentView$1_onSuccess__Ljava_lang_Object_2V [as onSuccess__Ljava_lang_Object_2V] (http://jon06.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/341D86321ECE4289E0459672BA4BDE1F.cache.html:136371:3) at com_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_$onResponseReceived__Lcom_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_2Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V (http://jon06.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/341D86321ECE4289E0459672BA4BDE1F.cache.html:9294:93) at Object.org_rhq_enterprise_gui_coregui_client_util_rpc_TrackingRequestCallback_onResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V [as onResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V] (http://jon06.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/341D86321ECE4289E0459672BA4BDE1F.cache.html:150928:5) at com_google_gwt_http_client_Request_$fireOnResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_RequestCallback_2V (http://jon06.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/341D86321ECE4289E0459672BA4BDE1F.cache.html:4378:14) at Object.com_google_gwt_http_client_RequestBuilder$1_onReadyStateChange__Lcom_google_gwt_xhr_client_XMLHttpRequest_2V [as onReadyStateChange__Lcom_google_gwt_xhr_client_XMLHttpRequest_2V] (http://jon06.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/341D86321ECE4289E0459672BA4BDE1F.cache.html:4604:5) at XMLHttpRequest. (http://jon06.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/341D86321ECE4289E0459672BA4BDE1F.cache.html:12598:13) at com_google_gwt_core_client_impl_Impl_entry0__Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2 (http://jon06.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/341D86321ECE4289E0459672BA4BDE1F.cache.html:2474:27) at XMLHttpRequest.onreadystatechange (http://jon06.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/341D86321ECE4289E0459672BA4BDE1F.cache.html:2463:12)
--- STACK TRACE FOLLOWS ---
(TypeError): Cannot read property 'java_lang_Long_value' of null arguments: java_lang_Long_value, type: non_object_property_load stack: TypeError: Cannot read property 'java_lang_Long_value' of null at org_rhq_enterprise_gui_coregui_client_inventory_resource_detail_inventory_ResourceResourceAgentView$1_$onSuccess__Lorg_rhq_enterprise_gui_coregui_client_inventory_resource_detail_inventory_ResourceResourceAgentView$1_2Lorg_rhq_core_domain_resource_Agent_2V (http://jon06.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/341D86321ECE4289E0459672BA4BDE1F.cache.html:136352:517) at Object.org_rhq_enterprise_gui_coregui_client_inventory_resource_detail_inventory_ResourceResourceAgentView$1_onSuccess__Ljava_lang_Object_2V [as onSuccess__Ljava_lang_Object_2V] (http://jon06.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/341D86321ECE4289E0459672BA4BDE1F.cache.html:136371:3) at com_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_$onResponseReceived__Lcom_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_2Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V (http://jon06.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/341D86321ECE4289E0459672BA4BDE1F.cache.html:9294:93) at Object.org_rhq_enterprise_gui_coregui_client_util_rpc_TrackingRequestCallback_onResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V [as onResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V] (http://jon06.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/341D86321ECE4289E0459672BA4BDE1F.cache.html:150928:5) at com_google_gwt_http_client_Request_$fireOnResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_RequestCallback_2V (http://jon06.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/341D86321ECE4289E0459672BA4BDE1F.cache.html:4378:14) at Object.com_google_gwt_http_client_RequestBuilder$1_onReadyStateChange__Lcom_google_gwt_xhr_client_XMLHttpRequest_2V [as onReadyStateChange__Lcom_google_gwt_xhr_client_XMLHttpRequest_2V] (http://jon06.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/341D86321ECE4289E0459672BA4BDE1F.cache.html:4604:5) at XMLHttpRequest. (http://jon06.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/341D86321ECE4289E0459672BA4BDE1F.cache.html:12598:13) at com_google_gwt_core_client_impl_Impl_entry0__Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2 (http://jon06.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/341D86321ECE4289E0459672BA4BDE1F.cache.html:2474:27) at XMLHttpRequest.onreadystatechange (http://jon06.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/341D86321ECE4289E0459672BA4BDE1F.cache.html:2463:12)
    at Unknown.anonymous(Unknown source:0)
    at Unknown.at org_rhq_enterprise_gui_coregui_client_inventory_resource_detail_inventory_ResourceResourceAgentView$1_$onSuccess__Lorg_rhq_enterprise_gui_coregui_client_inventory_resource_detail_inventory_ResourceResourceAgentView$1_2Lorg_rhq_core_domain_resource_Agent_2V(Unknown source:0)
    at Unknown.at Object.org_rhq_enterprise_gui_coregui_client_inventory_resource_detail_inventory_ResourceResourceAgentView$1_onSuccess__Ljava_lang_Object_2V [as onSuccess__Ljava_lang_Object_2V](Unknown source:0)
    at Unknown.at com_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_$onResponseReceived__Lcom_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_2Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V(Unknown source:0)
    at Unknown.at Object.org_rhq_enterprise_gui_coregui_client_util_rpc_TrackingRequestCallback_onResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V [as onResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V](Unknown source:0)
    at Unknown.at com_google_gwt_http_client_Request_$fireOnResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_RequestCallback_2V(Unknown source:0)
    at Unknown.at Object.com_google_gwt_http_client_RequestBuilder$1_onReadyStateChange__Lcom_google_gwt_xhr_client_XMLHttpRequest_2V [as onReadyStateChange__Lcom_google_gwt_xhr_client_XMLHttpRequest_2V](Unknown source:0)
    at Unknown.at XMLHttpRequest.(Unknown source:0)
    at Unknown.at com_google_gwt_core_client_impl_Impl_entry0__Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2(Unknown source:0)
    at Unknown.at XMLHttpRequest.onreadystatechange(Unknown source:0)
Comment 1 Ian Springer 2011-06-29 16:58:05 EDT
I think this can be reproduced as follows:

1) setup a new Agent on machine X and allow its platform to be discovered
2) stop the Agent
3) import the Agent's platform
4) the platform should have unknown avail since the Agent is down
5) go to the platform's Inventory>Agent subtab
Comment 2 Jay Shaughnessy 2011-08-21 11:26:17 EDT
master commit 29b542700591bb3b481479671341c70447d53874

Test Note: Use Ian's repro steps above
Comment 3 Sunil Kondkar 2011-08-24 05:06:57 EDT
Verified on build#334 Version: 4.1.0-SNAPSHOT Build Number: d686a21)

Followed the steps. NPE is not observed on the platform's Inventory>Agent subtab.

Marking as verified.
Comment 4 Mike Foley 2012-02-07 14:31:13 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE
Comment 5 Mike Foley 2012-02-07 14:31:15 EST
marking VERIFIED BZs to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.