Bug 717798 - unwanted HHHH string in stdout from subscription-manager unregister
unwanted HHHH string in stdout from subscription-manager unregister
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Bryan Kearney
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-06-29 17:57 EDT by John Sefler
Modified: 2011-12-06 12:21 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:21:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2011-06-29 17:57:58 EDT
Description of problem:
There appears to be a debugging println from dev left in the code during a call to subscription-manager unregister.  Please remove it.  This regression is blocking automated tests.


Version-Release number of selected component (if applicable):
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.2-1.git.6.a062826.el6.x86_64


Steps to Reproduce:
[root@jsefler-onprem-62server ~]# subscription-manager register --username=testuser1 --password=password --owner=admin
The system has been registered with id: be2c9605-5583-491b-83ec-20db057aeeed 
[root@jsefler-onprem-62server ~]# subscription-manager unregister
HHHH
System has been un-registered.


^^^^ The HHHH string in stdout is unexpected.
Comment 2 Bryan Kearney 2011-06-29 19:12:37 EDT
Fixed in 202166d0f5148efab8b7d1e14aeceabc73efae9f. Master branch.
Comment 4 spandey 2011-07-11 07:07:09 EDT
verified using following setup 


[root@dhcp201-165 ~]# rpm -qa | grep subscription
subscription-manager-gnome-0.96.3-1.git.0.723b652.el6.i386
subscription-manager-0.96.3-1.git.0.723b652.el6.i386
subscription-manager-firstboot-0.96.3-1.git.0.723b652.el6.i386
[root@dhcp201-165 ~]# subscription-manager unregister
System has been un-registered.
[root@dhcp201-165 ~]# 

Working fine Moving defect status from modified to Verified
Comment 5 errata-xmlrpc 2011-12-06 12:21:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.