Bug 71783 - X doesn't start giving because of mmap() error.
Summary: X doesn't start giving because of mmap() error.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 1.0
Hardware: alpha
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-19 04:34 UTC by Ray Strode
Modified: 2007-04-18 16:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-01 23:49:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch to fix the problem. (1.23 KB, patch)
2002-08-19 04:36 UTC, Ray Strode
no flags Details | Diff

Description Ray Strode 2002-08-19 04:34:47 UTC
XFree86 from RawHide doesn't start, failing with the 
error "xf86MapVidMemSparse: Could not (dense) mmap fb (No such file or 
directory)".  This is because mapVidMemSparse() in lnx_video.c incorrectly 
assumes that if mmap() returns an address that is different from the address 
requested then there is an error.

I will attach a patch that seems to fix the problem.

Comment 1 Ray Strode 2002-08-19 04:36:36 UTC
Created attachment 71391 [details]
A patch to fix the problem.

Comment 2 Mike A. Harris 2002-08-20 07:23:46 UTC
Thanks for the report, and the patch.  When I get a chance to hack
on Alpha stuff, I'll poke at this, and try to integrate changes needed
for Alpha and test, etc.

Thanks again.

Comment 3 Mike A. Harris 2002-11-03 13:19:09 UTC
Applied to my 4.2.1-9.1 build, and my latest CVS build as of today.
Patch seems to work fine.  Thanks.

Comment 4 Michael Fulbright 2002-12-20 17:38:25 UTC
Time tracking values updated


Note You need to log in before you can comment on or make changes to this bug.