Bug 71794 - import of gnome.ui in python2 fails
import of gnome.ui in python2 fails
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: orbit-python (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-19 09:19 EDT by Martin Norback
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-16 12:40:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Norback 2002-08-19 09:19:43 EDT
Description of Problem:
A file containg
import gnome.ui
fails with python2, giving the following trace

# /usr/lib/python2.2/site.pyc matches /usr/lib/python2.2/site.py
import site # precompiled from /usr/lib/python2.2/site.pyc
# /usr/lib/python2.2/os.pyc matches /usr/lib/python2.2/os.py
import os # precompiled from /usr/lib/python2.2/os.pyc
import posix # builtin
# /usr/lib/python2.2/posixpath.pyc matches /usr/lib/python2.2/posixpath.py
import posixpath # precompiled from /usr/lib/python2.2/posixpath.pyc
# /usr/lib/python2.2/stat.pyc matches /usr/lib/python2.2/stat.py
import stat # precompiled from /usr/lib/python2.2/stat.pyc
# /usr/lib/python2.2/UserDict.pyc matches /usr/lib/python2.2/UserDict.py
import UserDict # precompiled from /usr/lib/python2.2/UserDict.pyc
Python 2.2 (#1, Apr 12 2002, 15:29:57)
[GCC 2.96 20000731 (Red Hat Linux 7.2 2.96-109)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
import gnome # directory /usr/lib/python2.2/site-packages/gnome
# /usr/lib/python2.2/site-packages/gnome/__init__.pyc matches
/usr/lib/python2.2/site-packages/gnome/__init__.py
import gnome # precompiled from /usr/lib/python2.2/site-packages/gnome/__init__.pyc
dlopen("/usr/lib/python2.2/site-packages/gobjectmodule.so", 2);
import gobject # dynamically loaded from
/usr/lib/python2.2/site-packages/gobjectmodule.so
dlopen("/usr/lib/python2.2/site-packages/gnome/_gnomemodule.so", 2);
import gnome._gnome # dynamically loaded from
/usr/lib/python2.2/site-packages/gnome/_gnomemodule.so
dlopen("/usr/lib/python2.2/site-packages/gnome/uimodule.so", 2);
import bonobo # directory /usr/lib/python2.2/site-packages/bonobo
# /usr/lib/python2.2/site-packages/bonobo/__init__.pyc matches
/usr/lib/python2.2/site-packages/bonobo/__init__.py
import bonobo # precompiled from
/usr/lib/python2.2/site-packages/bonobo/__init__.pyc
dlopen("/usr/lib/python2.2/site-packages/bonobo/activationmodule.so", 2);
dlopen("/usr/lib/python2.2/site-packages/CORBAmodule.so", 2);
Fatal Python error: Could not import CORBA
Avbruten (SIGABRT)

Version-Release number of selected component (if applicable):
python2-2.2-16
pygtk2-1.99.12-1
gnome-python2-1.99.11-3
orbit-python-1.99.0-4

How Reproducible:
always

Steps to Reproduce:
prompt# python2
>>> import gnome.ui

Actual Results:
python2 exits

Expected Results:
module imported

Additional Information:
Comment 1 Matt Wilson 2003-10-16 12:40:12 EDT
this works for me,

Note You need to log in before you can comment on or make changes to this bug.