Bug 717961 - Render issues in text fields in Qt applications when using Gnome shell
Render issues in text fields in Qt applications when using Gnome shell
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
15
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-30 10:29 EDT by akiross
Modified: 2011-08-08 10:40 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-08 10:40:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of a couple of bugs (qt creator and another app) (87.69 KB, image/png)
2011-06-30 10:29 EDT, akiross
no flags Details

  None (edit)
Description akiross 2011-06-30 10:29:48 EDT
Created attachment 510689 [details]
Screenshot of a couple of bugs (qt creator and another app)

Description of problem:
When using gnome shell (and not when using other environments, as KDE or Ratpoison), I experience render bugs in text fields in qt applications (e.g. qt creator, psi-im). The buffer seems to be updated partially or not updated at all, especially when scrolling or moving through the lines.
Some of them are persistent, that is they are still until the affected area is refreshed, some others are visible for just a fraction of second, then vanish.

I can't remember if I ever experienced this bug in non-text-editing context (e.g. while drawing).

Version-Release number of selected component (if applicable):
I'm using
qt 4.7.2 8.fc15
gtk+ 1.2.10 71.fc15
gtk2 2.24.4 2.fc15
gtk3 3.0.11 1.fc15
gnome-shell 3.0.2 4.fc15

How reproducible:
The bugs are somewhat random, but using a Qt application with a text editor in it will eventually show this bug. I experienced it with Qt creator, Psi and custom Qt applications.

Attached two screenshots of the issue visible and then the same window after a refresh.
Comment 1 Rex Dieter 2011-06-30 10:49:46 EDT
Still smells a lot like a video driver (hw accel) bug.  What video hw/driver are you using?

Are you using desktop-effects/compositing in these other environments too?
Comment 2 akiross 2011-06-30 10:58:42 EDT
I'm using nvidia proprietary drivers:
xorg-x11-drv-nvidia 275.09.07 1.fc15

On KDE I'm pretty sure I was not using any desktop-effects/compositing, and I guess the same for Ratpoison.
But IIRC this bug didn't appeared when using "Classic GNOME with Compiz".

Anyway I can test of course; please, tell me if do you need any particular environment for testing.
Comment 3 Rex Dieter 2011-06-30 11:05:19 EDT
I think we can't conclude much else than "nvidia driver + (gnome3?) compositing + qt app" = text rendering bug".  Which still hints strongly at a driver issue.
Comment 4 akiross 2011-06-30 11:15:28 EDT
Ok. I would like to report also that this bug didn't seems present when I updated to F15 (a few days after it was released), but appeared later on when updating.
I'm sorry but I didn't keep track of when it happened.

I'll try with noveau drivers.
Comment 5 Rex Dieter 2011-06-30 11:18:08 EDT
fwiw, /var/log/yum.log should give you a history of what was updated and when.
Comment 6 akiross 2011-07-16 08:12:06 EDT
I'd like to report that refresh issues happened also with other applications recently: Eclipse, Nautilus and Chrome, which aren't qt applications. Sorry these seems to be rarer and I couldn't take screenshots.
Thanks Rex for your last tip.
Comment 7 Rex Dieter 2011-08-08 10:16:03 EDT
Based on this last comment, I think that rules at anything qt-only, and likely highlights a video driver issue.

If you're still using nvidia, we'll likely have to mark this CANTFIX, else, re-assign to nouveau
Comment 8 akiross 2011-08-08 10:32:16 EDT
Still using nvidia, unluckly I gave up trying with nouveau. I'll try to report this bug directly to nvidia.
Thanks for your help.
Comment 9 Rex Dieter 2011-08-08 10:40:15 EDT
ok.

Note You need to log in before you can comment on or make changes to this bug.