Bug 71798 - tulip wrong assignement of irqs to multiport nic
Summary: tulip wrong assignement of irqs to multiport nic
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 4
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-19 13:59 UTC by Christoph Dworzak
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-10 20:51:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixup irq on multiport-nics also on x86_64 (407 bytes, patch)
2005-02-17 15:32 UTC, Christoph Dworzak
no flags Details | Diff
assigned irq with and without patch (1.95 KB, text/plain)
2005-12-27 16:57 UTC, Christoph Dworzak
no flags Details

Description Christoph Dworzak 2002-08-19 13:59:44 UTC
Description of Problem:
the tulip networkcard driver does not correctly assign irqs to broken 
multiport network cards (Adaptec ANA6944TX here).
There's a workaround in the code, but not correctly implemented.

Version-Release number of selected component (if applicable):
2.4.18-5

How Reproducible:
Every time

Steps to Reproduce:
1. install multiport nic
2. boot system

Actual Results:
/var/log/messages reports correct irq
/proc/interrupts shows wrong irq
only first nic works correctly.
others timeout or hang

Expected Results:
all n ports working correctly :)

Additional Information:
the bug is in the files 
/usr/src/linux-2.4.18-5/drivers/net/tulip/tulip_core.c line 1619 and 
/usr/src/linux-2.4.18-5/drivers/net/tulip_old/tulip_core.c line 1325.

current:
 irq = last_irq;

correct:
 dev->irq = irq = last_irq;

i reported this bug on the kernel-mailing-list, but nobody picked it up.
it would be nice if i didn't have to compile my own kernels just because of 
this little change.

Comment 1 Jeff Garzik 2003-01-31 16:36:50 UTC
Should be fixed in latest Red Hat errata kernel, which includes an updated tulip
driver, which in turn includes this multiport irq fix.


Comment 2 Christoph Dworzak 2005-02-17 15:32:33 UTC
Created attachment 111161 [details]
fixup irq on multiport-nics also on x86_64

Comment 3 Christoph Dworzak 2005-02-17 15:35:10 UTC
Comment on attachment 111161 [details]
fixup irq on multiport-nics also on x86_64

this patch is not only needed on i386, but also on x86_64

Comment 4 Dave Jones 2005-09-30 07:02:36 UTC
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.


Comment 5 Dave Jones 2005-11-10 20:08:14 UTC
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.


Comment 6 John W. Linville 2005-12-14 15:19:55 UTC
Test kernels w/ the appropriate patch are available here: 
 
   http://people.redhat.com/linville/kernels/fc4/ 
 
Please give those a shot and confirm that things are working correctly w/ 
tulip on the x86_64 box in question...thanks! 

Comment 7 Christoph Dworzak 2005-12-27 16:53:46 UTC
(In reply to comment #6)
> Test kernels w/ the appropriate patch are available here: 
>    http://people.redhat.com/linville/kernels/fc4/ 

tested it and it's ok.

(see attachement. four ports should be on the same irq, as they are all wired to
the same pci_irq.)


Comment 8 Christoph Dworzak 2005-12-27 16:57:19 UTC
Created attachment 122600 [details]
assigned irq with and without patch

Comment 9 John W. Linville 2006-01-06 19:46:34 UTC
Patch posted upstream on 1/6/2006... 

Comment 10 John W. Linville 2006-01-10 20:51:11 UTC
Merged to netdev-2.6 on 1/9/2006... 

Comment 11 Christoph Dworzak 2006-02-10 20:39:09 UTC
(In reply to comment #10)
> Merged to netdev-2.6 on 1/9/2006... 

do you know when/if this will be included in the kernel?


Comment 12 John W. Linville 2006-02-10 20:50:39 UTC
Seems to be in the current FC4 kernel... 

Comment 13 Christoph Dworzak 2006-02-11 13:01:42 UTC
my question was not innocent, i asked, because the x86_64 version is not
included yet. i checked 2.6.14-1.1656_FC4, 2.6.15-1.1830_FC4 and 2.6.15-1.1831_FC4.


Comment 14 John W. Linville 2006-02-13 14:29:16 UTC
Hmmm...actually, you are right.  I'm not sure what I was looking at before.  I 
apologize. 
 
I really don't know when the patch will make it to FC4.  In the meantime, you 
can try the Fedora-netdev kernels: 
 
   http://people.redhat.com/linville/kernels/fedora-netdev/ 
 
Hth! 


Note You need to log in before you can comment on or make changes to this bug.