Bug 71804 - Updated kdebase-3.0.3 RPM depends on wrong kdelibs version
Updated kdebase-3.0.3 RPM depends on wrong kdelibs version
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-19 10:58 EDT by J. J. Ramsey
Modified: 2007-04-18 12:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-11 18:07:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J. J. Ramsey 2002-08-19 10:58:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020607

Description of problem:
The update RPM kdebase-3.0.3-0.7 depends on kdelibs-3.0.3-10, when it should
depend on kdelibs-3.0.3-0.7.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install kdelibs-3.0.3-0.7.i386.rpm and its dependencies.
2. Run "rpm -Uvh kdebase-3.0.3-0.7.i386.rpm".

Actual Results:  rpm complains kdelibs >= 3.0.3-10 is needed by kdebase-3.0.3-0.7

Expected Results:  kdebase should install.
Comment 1 Pavel Roskin 2002-08-19 11:21:25 EDT
Proposed patch for kdebase.spec

--- kdebase.spec
+++ kdebase.spec
@@ -16,7 +16,7 @@
 %define pamservice kde
 %define gdmsession KDE
 Name: kdebase
-Requires: kdelibs >= %{version}-10 libxml2 >= 2.4.12
+Requires: kdelibs == %{version}-%{rel} libxml2 >= 2.4.12
 Requires: /etc/X11/xdm/Xaccess /etc/X11/xdm/Xservers /etc/X11/xdm/Xwilling
 Requires: /etc/X11/xdm/Xsession /etc/X11/xdm/Xsetup_0
 Requires: cdparanoia-libs
Comment 2 Need Real Name 2002-09-21 17:58:39 EDT
On a similar note, I went to:
  http://kde.org/announcements/announce-3.0.3.html
clicked "Red Hat 7.3: Intel i386" which took me to:
  http://www.gtlib.cc.gatech.edu/pub/kde/stable/3.0.3/RedHat/7.3/i386/
downloaded everything and did (on my vanilla Red Hat 7.3 system):
  rpm --freshen *
and I got the errors:
error: failed dependencies:
  libartsflow-gcc2.96.so.1   is needed by arts-1.0.3-0.7
  libartsflow_idl-gcc2.96.so.1   is needed by arts-1.0.3-0.7
  libkmedia2_idl-gcc2.96.so.1   is needed by arts-1.0.3-0.7
  libmcop-gcc2.96.so.1   is needed by arts-1.0.3-0.7
  kdelibs >= 3.0.3-10 is needed by kdebase-3.0.3-0.7
  libartsflow-gcc2.96.so.1   is needed by kdemultimedia-arts-3.0.3-0.7
  libartsflow_idl-gcc2.96.so.1   is needed by kdemultimedia-arts-3.0.3-0.7
  libmcop-gcc2.96.so.1   is needed by kdemultimedia-arts-3.0.3-0.7
  libartsflow-gcc2.96.so.1   is needed by noatun-3.0.3-0.7
  libartsflow_idl-gcc2.96.so.1   is needed by noatun-3.0.3-0.7
  libkmedia2_idl-gcc2.96.so.1   is needed by noatun-3.0.3-0.7
  libmcop-gcc2.96.so.1   is needed by noatun-3.0.3-0.7
  libqtmcop-gcc2.96.so.1   is needed by noatun-3.0.3-0.7
  libsoundserver_idl-gcc2.96.so.1   is needed by noatun-3.0.3-0.7
which includes the kdebase-3.0.3-0.7 depends on delibs >= 3.0.3-10 error 
along with a whole lot of other junk.  KDE 3.0.0 is very buggy, so it would 
be really nice if it were easy to upgrade.
Comment 3 Doug 2002-09-29 04:11:36 EDT
I have the exact same experince as bdx678.  I downloaded all 96 KDE 3.0.3 rpm 
packages from the "offical" site.  The command I used is this:
   rpm -Fvh --test *.rpm

I get the EXACT same list of errors as bdx678.

It looks from the suggested spec patch above that the library version is simply 
a bad version, and that there really isn't a kdelibs-3.0.3-10 package.  This 
implies that without using the patch, kdebase-3.0.3-0.7 can just installed 
with --nodeps and perhaps --force.

The other funny errors are not so straight forward.  I've read a post on the 
net which indicates that all the missing libxxxx-gcc2.96.so.1 dependencies can 
be "worked around" by also forcing the install of all the complaining packages, 
then making symbolic links to the missing dependencies.

For example, libartsflow-gcc2.96.so.1 is missing, but libartsflow.so.1 is in 
one of the packages.  Therefore, the net post suggests doing this:
   ln -s libartsflow.so.1 libartsflow-gcc2.96.so.1
in the appropriate directory for EACH of the missing dependencies.

I haven't tried this, but it might work.  I do find it odd that a quasi-
official KDE 3.0.3 release from RH failed out-of-the-box, and that there's no 
real fix for it yet.

BB.
Comment 4 Ngo Than 2004-10-11 18:07:11 EDT
it's fixed in rhel3 and fc2 current release.

Note You need to log in before you can comment on or make changes to this bug.