Bug 718045 - Register dialog disappears when invalid credentials are given
Register dialog disappears when invalid credentials are given
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Michael Stead
J.C. Molet
:
Depends On:
Blocks: rhsm-rhel62 743047
  Show dependency treegraph
 
Reported: 2011-06-30 15:30 EDT by J.C. Molet
Modified: 2011-12-06 12:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:21:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J.C. Molet 2011-06-30 15:30:58 EDT
Description of problem:
When registering in subscription-manager-gui, the register dialog disappears when an error is encountered. This is in contrast to the old behavior where a error would pop up, you'd hit OK, and then it would return you to the registration screen to correct whatever caused the error.

Version-Release number of selected component (if applicable):
subscription-manager-gnome-0.96.2-1.git.13.b72becb.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. Start up subscription-manager-gui
2. Select to "register system"
3. Enter in bogus login credentials
4. Hit "register"
  
Actual results:
An error dialog pops up and the registration dialog is closed.

Expected results:
An error dialog pops up over the registration dialog.  Once you clear the error pop-up, you are returned to the registration screen where you can try again.

Additional info:
Comment 1 J.C. Molet 2011-07-05 16:23:07 EDT
This is only valid if you enter in both a user name and password... if you leave any of these fields blank you still get their correct behavior.
Comment 2 Michael Stead 2011-09-19 15:44:36 EDT
This is fixed in branches:

RHEL6.2 - 736faabce1d40cf91511b5dd98f0ae2807f42d3f

master - fde2cfcb8cd45bfb32c77c18410e27f9a2551498
Comment 4 J.C. Molet 2011-09-20 09:43:14 EDT
rhel6.2:

subscription-manager-gnome-0.96.9-1.git.26.e7a7723.el6.x86_64
subscription-manager-firstboot-0.96.9-1.git.26.e7a7723.el6.x86_64
subscription-manager-0.96.9-1.git.26.e7a7723.el6.x86_64
python-rhsm-0.96.12-1.git.0.4862863.el6.noarch


master:

subscription-manager-0.97.1-1.git.34.9643006.el6.x86_64
subscription-manager-firstboot-0.97.1-1.git.34.9643006.el6.x86_64
subscription-manager-gnome-0.97.1-1.git.34.9643006.el6.x86_64
python-rhsm-0.97.1-1.git.1.4e522a5.el6.noarch


This has been VERIFIED as working in the above versions ^^
Comment 5 errata-xmlrpc 2011-12-06 12:21:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.