Bug 718052 - use "org/organization" nomenclature instead of "owner"
use "org/organization" nomenclature instead of "owner"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Bryan Kearney
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-06-30 15:44 EDT by John Sefler
Modified: 2011-12-06 12:21 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:21:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
System Registration" dialog still shows "owners" (15.23 KB, image/png)
2011-06-30 18:32 EDT, John Sefler
no flags Details
Fetching list of possible organizations (16.90 KB, image/png)
2011-09-23 22:29 EDT, John Sefler
no flags Details
Organization: label in the facts dialog (33.58 KB, image/png)
2011-09-23 22:31 EDT, John Sefler
no flags Details

  None (edit)
Description John Sefler 2011-06-30 15:44:51 EDT
Description of problem:
To be consistent with katello/satellite nomenclature, subscription-manager should use the term "org"/"organization" everywhere we are currently using "owner".

Some places where "owner" is being used in subscription-manager include:
subscription-manager register --owner
  "Must specify owner for new consumer."
subscription-manager-gui register owner selection dialog
subscription-manager-gui facts window Owner: label
many candlepin api calls: https://fedorahosted.org/candlepin/wiki/API
subscription-manager identity
   owner name: admin 
   owner id: 8a90f8c630e1b7060130e1b74e920006

I'm sure there are more places than these.
Please append them in the comments...
Comment 2 Bryan Kearney 2011-06-30 16:33:17 EDT
Fixed in master 66df558b891a2cacbf2d642e043ecc409d4dd201.
Comment 4 John Sefler 2011-06-30 18:32:54 EDT
Created attachment 510770 [details]
System Registration" dialog still shows "owners"

In the "System Registration" dialog, it still shows:
  Fetching list of possible owners.....
Comment 5 John Sefler 2011-06-30 18:39:44 EDT
[root@jsefler-onprem-62server ~]# subscription-manager register --username=testuser1 --password=password --org=foo
Owner foo does not exist
^^^^^                   ^
Org                     .  < don't forget punctuation


[root@jsefler-onprem-62server ~]# subscription-manager register --username=testuser1 --password=password
Must specify owner for new consumer.
             ^^^^^
             org
Comment 6 John Sefler 2011-07-01 09:42:09 EDT
[root@jsefler-onprem-62server ~]# subscription-manager register --username=testuser3 --password=password
User testuser3 cannot access owner admin
                             ^^^^^      ^
                             org        .

Is this really the best message for a READ_ONLY user?  I don't yet know enough about READ_ONLY user to suggest a better message.
Comment 7 Bryan Kearney 2011-07-01 13:39:55 EDT
c4 is fixed in subscription manager
6a18499c43b4d2c767ff9921d567bab96f14be97

c5 and c6 will require a new build of candlepin. 6b245c82c2f0bf8cf156b7b5ec3873b2da2c025a
Comment 8 John Sefler 2011-07-05 12:14:57 EDT
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.2-1.git.19.47243e5.el6.x86_64

[root@jsefler-onprem-62server ~]# subscription-manager register --username=testuser1
Password: 
You must specify an organization/owner for new consumers.

                    ^^^^^^^^^^^^^^^^^^
                    Is this really what we want?
                    Can't we make up our mind?
                    How will this translate to other languages?
                    more org, less owner
Comment 9 Bryan Kearney 2011-09-22 08:55:38 EDT
fixed in candlepin in 5d02aa2a9c94ff3902e0e64d33c707343ae13576.
Comment 10 John Sefler 2011-09-23 22:21:10 EDT
Verifying Version....
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.11-1.git.7.15fc9d2.el6.x86_64

Verifying the use of Org/Organization in all of the following uses...

[root@jsefler-onprem-62server ~]# subscription-manager register --username=testuser1 --password=password
You must specify an organization for new consumers.


[root@jsefler-onprem-62server ~]# subscription-manager register --username=testuser1 --password=password --org=admin
The system has been registered with id: 0b4d28eb-95c4-4713-9c29-ad6d15bceca7 


[root@jsefler-onprem-62server ~]# subscription-manager register --username=testuser1 --password=password --org=foo --force
The system with UUID 0b4d28eb-95c4-4713-9c29-ad6d15bceca7 has been unregistered
Organization foo does not exist.


[root@jsefler-onprem-62server ~]# subscription-manager register --username=testuser3 --password=password
testuser3 cannot register to any organizations.


[root@jsefler-onprem-62server ~]# subscription-manager identity
Current identity is: 0b4d28eb-95c4-4713-9c29-ad6d15bceca7 
name: jsefler-onprem-62server.usersys.redhat.com 
org name: Admin Owner 
org id: 8a90f8c63296bc55013296bcd0890006


[root@jsefler-onprem-62server ~]# subscription-manager orgs --username=testuser1 --password=password
+-------------------------------------------+
          testuser1 Organizations
+-------------------------------------------+

OrgName: 	Snow White               
OrgKey: 	snowwhite                

OrgName: 	Admin Owner              
OrgKey: 	admin
Comment 11 John Sefler 2011-09-23 22:29:51 EDT
Created attachment 524703 [details]
Fetching list of possible organizations

Verifying Version...
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager-gnome
subscription-manager-gnome-0.96.11-1.git.7.15fc9d2.el6.x86_64
Comment 12 John Sefler 2011-09-23 22:31:57 EDT
Created attachment 524704 [details]
Organization: label in the facts dialog
Comment 13 John Sefler 2011-09-23 22:42:59 EDT
Moving to verified

NOTE... The use of owner still exists in the Candlepin API and JSON data.  This can be opened as a separate bug.

On candlepin server...
cd /root/candlepin/proxy
buildr candlepin:apicrawl
cat target/candlepin_methods.json | python -mjson.tool | grep owner
                "owner": {
                "owner": {
        "description": "Create a Consumer. NOTE: Opening this method up to everyone, as we have\n nothing we can reliably verify in the method signature. Instead we have\n to figure out what owner this consumer is destined for (due to backward\n compatability with existing clients which do not specify an owner during\n registration), and then check the access to the specified owner in the\n method itself.", 
                "name": "owner", 
        "url": "/consumers/{consumer_uuid}/owner", 
                "name": "owner", 
                "ownerId": {
                "name": "owner", 
        "description": "Allow the creation of an activation key from the owner resource", 
                "owner": {
        "url": "/owners/{owner_key}/activation_keys", 
            "owner_key"
        "url": "/owners", 
                "owner": {
        "url": "/owners/{owner_key}/subscriptions", 
            "owner_key"
        "url": "/owners/{owner_key}/uebercert", 
            "owner_key"
        "description": "Deletes an owner", 
        "url": "/owners/{owner_key}", 
        "url": "/owners/{owner_key}/consumers/{consumer_uuid}/atom", 
            "owner_key"
        "url": "/owners/{owner_key}/events", 
            "owner_key"
        "url": "/owners/{owner_key}/imports", 
            "owner_key"
        "description": "Return the owner identified by the given ID.", 
        "url": "/owners/{owner_key}", 
            "owner_key"
        "url": "/owners/{owner_key}/atom", 
            "owner_key"
        "description": "Return the owner's info identified by the given ID.", 
                        "ownerId": {
                            "ownerId": {
                            "ownerId": {
        "url": "/owners/{owner_key}/info", 
            "owner_key"
        "description": "Return the entitlement pools for the owner of the given id.", 
        "url": "/owners/{owner_key}/pools", 
            "owner_key"
        "url": "/owners/{owner_key}/statistics/{qtype}/{vtype}", 
            "owner_key"
        "url": "/owners/{owner_key}/subscriptions", 
            "owner_key"
        "url": "/owners/{owner_key}/uebercert", 
            "owner_key"
        "url": "/owners/{owner_key}/imports", 
            "owner_key"
        "url": "/owners", 
        "description": "Return the activation keys for the owner of the given id.", 
        "method": "org.fedoraproject.candlepin.resource.OwnerResource.ownerActivationKeys", 
        "url": "/owners/{owner_key}/activation_keys", 
            "owner_key"
        "description": "Return the consumers for the owner of the given id.", 
        "method": "org.fedoraproject.candlepin.resource.OwnerResource.ownerConsumers", 
        "url": "/owners/{owner_key}/consumers", 
            "owner_key"
        "description": "Return the entitlements for the owner of the given id.", 
        "method": "org.fedoraproject.candlepin.resource.OwnerResource.ownerEntitlements", 
        "url": "/owners/{owner_key}/entitlements", 
            "owner_key"
        "description": "'Tickle' an owner to have all of their entitlement pools synced with\n their subscriptions. This method (and the one below may not be entirely\n RESTful, as the updated data is not supplied as an argument.", 
                "name": "auto_create_owner", 
        "url": "/owners/{owner_key}/subscriptions", 
        "description": "expose updates for owners", 
        "url": "/owners/{owner_key}", 
            "owner_key"
        "url": "/owners/subscriptions", 
        "deprecated": "Use the method on /owners", 
                "description": "if both consumer and owner are given, or if a product id is specified without a consumer or owner", 
                "description": "if a specified consumer or owner is not found", 
                "name": "owner", 
                            "owner": {
                            "owner": {
                            "owner": {
                            "owner": {
                            "owner": {
                            "owner": {
                            "owner": {
                "owner": {
        "url": "/users/{username}/owners", 
[root@jsefler-onprem-62candlepin proxy]#
Comment 14 errata-xmlrpc 2011-12-06 12:21:47 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.