Bug 71814 - DHCP doesn't work with VLAN
DHCP doesn't work with VLAN
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: dhcp (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-19 13:20 EDT by Need Real Name
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-01 16:37:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-08-19 13:20:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
I've tried RH7.3 based on claims that it supports VLANs, but could not find 
any 'userspace' tool for configuring it. I found the tool (coming together with 
the patch that is now part of the kernel) by Ben Greear 
(http://www.candelatech.com/~greear/vlan.html version 1.6). The userspace 
tool 'vconfig' works, I am able to connect the port in trunk mode to Cisco 
switch, I can connect to the machine via various VLANs.

The problem is with DHCP daemon. From the documentation of vconfig I understand 
that this might present a problem unless packet reordering flag is set, so I 
have set it (vconfig set_flag ethX.Y 1 1). Even before the flag appeared to be 
set if I looked in /proc/net/vlan/ethX.Y. tcpdump, the other tool that uses 
SOCK_PACKET, which is also case with DHCP, works on the interfaces that have 
been virtualized in VLAN.

However, the same configuration of DHCP daemon that works with physical 
interface, doesn't work if the interface is a VLAN (and ofcourse I have changed 
the settings in /etc/sysconfig/dhcpd to reflect the new interface).

Furthermore dhcrelay (part of the same package) doesn't seem to work with 
either physical or VLAN interface as in:
dhcrelay -i ethX dhcp.example.net
or in:
dhcrelay -i ethX.Y dhcp.example.net

Version-Release number of selected component (if applicable):
dhcp-2.0pl5-8.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1. compile vconfig
2. vconfig add eth1 12
3. vconfig add eth1 13
4. ifconfig eth1.12 10.41.12.100 netmask 255.255.255.0 broadcast 10.41.12.255 up
5. ifconfig eth1.13 10.41.13.100 netmask 255.255.255.0 broadcast 10.41.13.255 up
6. configure DHCPDARGS=eth1.12 and in DHCPDARGS=eth1.13 /etc/sysconfig/dhcpd 
(two separate lines)
7. configure the scopes and pools in /etc/dhcpd.conf (two - one for 
10.41.12.0/24 and one for 10.41.13.0)
8. service dhcpd start
9. configure a computer on the VLAN 12 to get address via DHCP

or

1. compile vconfig
2. vconfig add eth1 12
3. vconfig add eth1 13
4. ifconfig eth1.12 10.41.12.100 netmask 255.255.255.0 broadcast 10.41.12.255 up
5. ifconfig eth1.13 10.41.13.100 netmask 255.255.255.0 broadcast 10.41.13.255 up
6. dhcrelay -i eth1.12 -i eth1.13 10.41.1.1 (the address of working DHCP server)
7. configure the scope and pool on DHCP server (scope 10.41.12.0...)
8. configure a computer on the VLAN 12 to get address via DHCP

or

1. ifconfig eth1 10.41.12.100 netmask 255.255.255.0 broadcast 10.41.12.255 up
2. dhcrelay -i eth1 10.41.1.1
3. configure the scope and pool on DHCP server (scope 10.41.12.0...)
4. configure a computer on the VLAN 12 to get address via DHCP

Actual Results:  The computer doesn't get address from DHCP (it uses default 
DHCP address of Windows 2000)

Expected Results:  Granted lease from the server.

Additional info:

The setup with VLAN and local DHCP works with just one interface to listen to.
If I do tcpdump while in relay mode, the request reaches the machine, but 
nothing exits on the interface leading to external DHCP server.

HW:
Compaq Proliant DL360 G2
ethernet card - built in interface based on Broadcom bcm5700 chipset
External DHCP server - Windows 2000
Comment 1 Elliot Lee 2002-08-26 07:32:19 EDT
erk...

1. I don't think VLAN is support-supported (which is why we don't include the userspace 
tool). The RHL 7.3 release notes should be read as indicating that the kernel has this 
feature compiled in (whether or not that's a reasonable way to read it :( )...

2. Rawhide has dhcp 3.0pl1 - bugs of this nature need to be tested against the latest 
version...

3. The problem might be in the kernel or in dhcpd - in either case, I'm not really able to 
focus on chasing this down, but hopefully someone else will come along and provide 
comments based on your more than adequate instructions, and I can always try to provide 
feedback on any patches or specific questions...
Comment 2 Need Real Name 2002-08-26 09:30:42 EDT
1. Release notes as on page http://www.redhat.com/docs/manuals/linux/RHL-7.3-
Manual/release-notes/x86/ seem more than a bit misleading. BTW, can you pass 
info to the documentation dept regarding this (also the fact that VLAN support 
is 802.1q not 802.11q - also misspelled in anaconda release notes)
2. The server in question is to be used in production as a firewall. I cannot 
use the bleeding edge version. The version of DHCP you are reffering to has not 
yet made it to the production version.
3. If you can't help me with the VLAN setup, can you give me a few pointers on 
my problems with straight dhcrelay setup that doesn't relay?
Comment 3 Elliot Lee 2002-08-26 10:41:03 EDT
I don't have many clues to lend on dhcrelay - it doesn't look like you're doing anything 
wrong. It will be a while before I get a chance to set up some machines to test the 7.3 
dhcrelay, so this may sit for a while.

Given that you've already experimented with the VLAN tools and various DHCP stuff on 
this server, I don't see any real obstacle to giving the rawhide dhcp-3.0pl1-8 package a try 
(unless testing the reproduction. You shouldn't need to update any other packages to 
install it, and the only change need to move to/from dhcp 3.0 is the addition/removal of 
'ddns-update-style none;' in /etc/dhcpd.conf.
Comment 4 Daniel Walsh 2003-08-01 16:37:48 EDT
Since this has been open for a year with no response I am closing it.

Note You need to log in before you can comment on or make changes to this bug.