This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 71819 - (IDE)The system hangs when trying to mount CD-ROM on Compaq Proliant DL360 G2
(IDE)The system hangs when trying to mount CD-ROM on Compaq Proliant DL360 G2
Status: CLOSED DUPLICATE of bug 71499
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-19 13:37 EDT by Need Real Name
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-08-19 13:37:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
The system hangs completely (even Alt-SysReq doesn't work) when trying to mount 
CD-ROM on Compaq Proliant DL360 G2

Version-Release number of selected component (if applicable):
kernel-2.4.18-3

How reproducible:
Always

Steps to Reproduce:
1. insert media in CD-ROM
2. mount /mnt/cdrom

Actual Results:  ide-floppy driver 0.99.newide
hda: ATAPI 24X CD-ROM drive, 128kB Cache, DMA
Serverworks OSB4 in impossible state.
Disable UDMA or if you are using Seagate then try switching disk types
on this controller. Please report this event to osb4-bug@ide.cabal.tm
OSB4: continuing might cause disk corruption
<hang>

Expected Results:  Mounted CD-ROM

Additional info:

The same hardware had some problems with RH7.2, when mounting the drive was 
slow in response to seek commands at first read (it took almost a minute to 
mount, and also to do a simple find /mnt/cdrom).
The model number as writen on the drive is CRN-8245B (E56A), and I think it is 
produced by Compaq.
Comment 1 Need Real Name 2002-08-20 06:22:09 EDT
Compaq suggested disabling the DMA by issuing:
/sbin/hdparm -d0 /dev/cdrom

This worked, but I think that system hanging should not happen anyway. 
Especially since the system worked with RH7.2.
Comment 2 Richard Black 2002-08-22 19:07:39 EDT
The fix has been found for the cdrom DMA issue which can affect certain systems 
with plain cdrom drives and certain particular ide chipsets.  The problem 
excludes DVD drives and CDRW drives.

The problem is that the following grep command requires the "-H" parameter for 
the awk command to function as expected.  So we change the following block of 
code in /etc/rc.sysinit:

# Turn off DMA on CD-ROMs. It more often than not causes problems.
if [ -x /sbin/hdparm -a -e /proc/ide ]; then
  for N in `grep -v ide-disk /proc/ide/*/*/driver 2>/dev/null | awk -F / '{ prin
t $5 }'`; do
   hdparm -q -d0 /dev/$N >/dev/null 2>&1
  done
fi


to the following:

# Turn off DMA on CD-ROMs. It more often than not causes problems.
if [ -x /sbin/hdparm -a -e /proc/ide ]; then
  for N in `grep -Hv ide-disk /proc/ide/*/*/driver 2>/dev/null | awk -F / '{ 
prin
t $5 }'`; do
   hdparm -q -d0 /dev/$N >/dev/null 2>&1
  done
fi

Sincerely,
Richard Black
Comment 3 Alan Cox 2003-06-09 10:17:43 EDT

*** This bug has been marked as a duplicate of 71499 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:49:25 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.