Bug 718205 - Gui : Fetching owner list process is not getting end for testuser3
Gui : Fetching owner list process is not getting end for testuser3
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bryan Kearney
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-07-01 07:47 EDT by spandey
Modified: 2015-04-23 19:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:21:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
User testuser3 is not able to register with any orgs. (12.39 KB, image/png)
2011-08-03 12:12 EDT, John Sefler
no flags Details

  None (edit)
Description spandey 2011-07-01 07:47:41 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
3/3

Prerequisites :
Candlepin : On-premise 
Client : Rhel6 With following subscription-manager 
subscription-manager-firstboot-0.96.2-1.el6.x86_64
subscription-manager-gnome-0.96.2-1.el6.x86_64
subscription-manager-0.96.2-1.el6.x86_64

Steps to Repro : 
Launch subscription-manager gui.
Register client using testuser3

Expected Result : 
Client should register to candlepin as Read_only admin owner 

Actual Result : 
Gui : Never ended owner fetch process is going on.





snip of rhsm.log 


[root@dhcp201-207 ~]# tail -f /var/log/rhsm/rhsm.log
2011-07-01 06:39:37,838 [INFO]  @connection.py:156 - loading ca certificate '/etc/rhsm/ca/candlepin-ca.pem'
2011-07-01 06:39:37,838 [INFO]  @connection.py:156 - loading ca certificate '/etc/rhsm/ca/candlepin-stage.pem'
2011-07-01 06:39:37,838 [INFO]  @connection.py:156 - loading ca certificate '/etc/rhsm/ca/fakamai-cp1.pem'
2011-07-01 06:39:37,838 [INFO]  @connection.py:156 - loading ca certificate '/etc/rhsm/ca/redhat-uep.pem'
2011-07-01 06:39:37,839 [INFO]  @connection.py:170 - work in insecure mode ?:False
2011-07-01 06:39:37,900 [INFO]  @connection.py:198 - status code: 200
2011-07-01 06:39:38,699 [DEBUG]  @certlib.py:679 - Sorting product and entitlement cert status for: 2011-07-01 06:39:38.699768
2011-07-01 06:39:38,701 [DEBUG]  @certlib.py:697 - Installed product IDs: ['69']
2011-07-01 06:39:38,701 [DEBUG]  @certlib.py:688 - valid entitled products: []
2011-07-01 06:39:38,701 [DEBUG]  @certlib.py:689 - expired entitled products: []
Comment 2 John Sefler 2011-07-01 13:07:29 EDT
Probably related, I am also seeing problems registering some users from the cli...

# subscription-manager register --username=testuser3 --password=password
User testuser3 cannot access owner admin

# subscription-manager register --username=happy --password=password
User happy cannot access owner snowwhite

# subscription-manager register --username=sleepy --password=password
User sleepy cannot access owner snowwhite

# subscription-manager register --username=bashful --password=password
User bashful cannot access owner snowwhite

# subscription-manager register --username=sneezy --password=password
User sneezy cannot access owner snowwhite

# subscription-manager register --username=dopey --password=password
User dopey cannot access owner snowwhite

# subscription-manager register --username=louie --password=password
User louie cannot access owner donaldduck
Comment 3 John Sefler 2011-07-08 11:05:29 EDT
I understand that the denied access for the users attempt to register in comment 2 is because they have READ_ONLY access to the owner.  What seems to be missing is a candlepin API call to determine the user's access role to the owners for which the user is a member.  Something like /users/<username>/owners/<owner>/roles might work.
Comment 4 Bryan Kearney 2011-08-02 14:22:58 EDT
fixed in master of subsription manager at a26379e73a383101162c0b8374d0b3d4aaad79a3
Comment 6 John Sefler 2011-08-03 12:12:58 EDT
Created attachment 516538 [details]
User testuser3 is not able to register with any orgs.

Verifying Version...
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.4-1.git.80.a26379e.el6.x86_64

[root@jsefler-onprem-62server ~]# subscription-manager register --username=testuser3 --password=password
testuser3 cannot register to any organizations.


Verified both CLI and GUI attempt to register using READ_ONLY credentials.

PS. Why is the error message different coming from the CLI vs. GUI?
Comment 7 errata-xmlrpc 2011-12-06 12:21:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.