Bug 718338 - Compress context menu in nautilus breaks on folders with spaces
Compress context menu in nautilus breaks on folders with spaces
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: file-roller (Show other bugs)
6.2
All Linux
high Severity medium
: rc
: ---
Assigned To: David King
Desktop QE
: EasyFix, Patch
Depends On:
Blocks: 670971 782183 835616 994246 1083163 840699
  Show dependency treegraph
 
Reported: 2011-07-01 16:55 EDT by Matthew Mosesohn
Modified: 2014-06-09 05:07 EDT (History)
6 users (show)

See Also:
Fixed In Version: file-roller-2.28.2-7.el6
Doc Type: Bug Fix
Doc Text:
Cause: file-roller was not properly dealing with filenames containing spaces. Consequence: File or directory names with spaces were not properly recognized by file-roller, e.g when called through the 'Compress' menuitem in nautilus. Fix: Make file-roller use the correct API to handled file names. Result: file-roller can properly handle filenames with spaces now.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-09 05:07:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthew Mosesohn 2011-07-01 16:55:09 EDT
Description of problem:
If you try to compress a folder with spaces, it presents an error:
----
An error occurred while adding files to the archive.

No such file or directory
----

Version-Release number of selected component (if applicable):
nautilus-2.28.4-15.el6.x86_64
file-roller-2.28.2-6.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Create a folder called "test folder" in Nautilus
2. Right click the folder and choose Compress
3. Click Create
  
Actual results:
An error occurred while adding files to the archive.

No such file or directory

Expected results:
archive should be created as expected

Additional info:
this issue is fixed in Fedora 15
Comment 2 RHEL Product and Program Management 2011-07-05 21:36:11 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 4 Grant Williamson 2012-06-07 06:31:57 EDT
The fix is easy, already present in another bugzilla.

https://bugzilla.redhat.com/show_bug.cgi?id=610338

Can this be added please.

http://git.gnome.org/browse/file-roller/commit/?id=23c4cf9e9e8103d2dc017a03545422119a346d31
Comment 18 errata-xmlrpc 2014-06-09 05:07:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0642.html

Note You need to log in before you can comment on or make changes to this bug.