Bug 71835 - kde-games and kde-i18n-Swedish selected though KDE is not
Summary: kde-games and kde-i18n-Swedish selected though KDE is not
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: null
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67218
TreeView+ depends on / blocked
 
Reported: 2002-08-19 19:28 UTC by Mikael Hallendal
Modified: 2007-04-18 16:45 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-21 08:05:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mikael Hallendal 2002-08-19 19:28:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/0

Description of problem:
Choosed a workstation with GNOME and no KDE. Then I opened the "Games and
Entertainment"-category in the "Choose packages" page. "kde-i18n-Swedish" and
"kdegames" where checked to be installed even though I didn't want any KDE stuff.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:

Comment 1 Jeremy Katz 2002-08-21 06:44:38 UTC
kdegames are just as good as gnome-games, so there's no real reason not to
install both by default.  kde-i18n-Swedish then gets pulled in due to kdelibs
being installed

Comment 2 Mikael Hallendal 2002-08-21 08:05:18 UTC
I see a very big reason not to install them by default. And that is the fact
that you get a bunch of extra packages that you don't want just because of
kdegames. If I choose I want a GNOME and choose I don't want KDE, then the
installer should not override my choses, especially not for something as dumb as
games.

This is the workstation installation, so I don't see why games should be
installed at all (GNOME or KDE).

Comment 3 Jeremy Katz 2002-08-21 14:02:55 UTC
No, thinking in terms of "this is a GNOME app" and "this is a KDE app" are just
*not* the right way to think.  The only people that care about that are people
caught up in the details of open source politics.  Users don't care.  See the
insanely long thread on limbo-list where Havoc has gone on about this at length.  

And games are installed because in most cases, people like having a game to play
every once in a while.  You're free to customize the selections and turn off the
games, but by default, we give you a little bit of fun.

Comment 4 Mikael Hallendal 2002-08-21 14:05:28 UTC
So, this is the reason that you need 3 full CD's to install a basic work station?
I'm not talking about this or that package is the better. I'm talking about
installing all of those extra libraries that are totally unneeded except for the
games.


Note You need to log in before you can comment on or make changes to this bug.