This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 718363 - parted gpt crash on /dev/vda
parted gpt crash on /dev/vda
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
15
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-01 19:47 EDT by Joshua Daniel Franklin
Modified: 2011-07-07 14:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-07 14:03:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
output of parted crash (1.45 KB, text/plain)
2011-07-01 19:47 EDT, Joshua Daniel Franklin
no flags Details

  None (edit)
Description Joshua Daniel Franklin 2011-07-01 19:47:54 EDT
Created attachment 510953 [details]
output of parted crash

Description of problem:
Attempting to create a gpt label on /dev/vda results core dump. Sounds like a big deal but in fact /dev/vda should not exist which may be a separate kernel bug. I discovered due to a errant "pre" section in my kickstart file referring to /dev/vda but in any case it's tickling some minor gpt bug in parted.


Version-Release number of selected component (if applicable):
parted 2.3 in Fedora 15 boot.iso (from e.g. http://ftp.osuosl.org/pub/fedora/linux/releases/15/Fedora/x86_64/os/images/ )

How reproducible:


Steps to Reproduce:
1. Boot Fedora 15 installer in a KVM virtual machine (I used virt-manager)
2. When installer starts, switch to shell (Ctrl-Alt-F2)
3. Run these commands:
dd if=/dev/urandom of=/dev/vda bs=512 count=64
parted -s /dev/vda mklabel gpt
parted -s /dev/vda unit mb print free

  
Actual results:
Core dump and errors including:
"Assertion (last_usable > first_usable) at gpt.c:713 in function _parse_header() failed.":


Expected results:
"No such file or directory" or anything other than a core dump.

Additional info:
Comment 1 Brian Lane 2011-07-07 14:03:11 EDT
writing random data to the device is guaranteed to cause problems. Use /dev/zero to initialize devices, not /dev/urandom

Note You need to log in before you can comment on or make changes to this bug.