Bug 718382 - f15 as x86_64 HVM xenDomU doesn't load virt.block devices
Summary: f15 as x86_64 HVM xenDomU doesn't load virt.block devices
Keywords:
Status: CLOSED DUPLICATE of bug 708267
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 15
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-07-02 07:03 UTC by corasian
Modified: 2011-07-06 17:50 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-07-06 17:50:04 UTC
Type: ---


Attachments (Terms of Use)
three scheenshots of the environment at the time anaconda tries to search for storage devices (27.39 KB, application/x-gzip)
2011-07-02 07:03 UTC, corasian
no flags Details

Description corasian 2011-07-02 07:03:33 UTC
Created attachment 510972 [details]
three scheenshots of the environment at the time anaconda tries to search for storage devices

Description of problem:
using a xen Dom0 (centos5.6), when a stock fc15 x86_64 image is used to install a HVM, the virtual block devices are not recognized by/available to the os for installation. I have attached screenshots of what the shell sees (lsmod;lspci;cat /proc/partitions) at the time it scans for storage devices. 

Version-Release number of selected component (if applicable):
not sure. current fedora 15 build available on the mirrors.

How reproducible:
install unmodified fedora 15 x86_64 to a xen HVM domU via pxe/cd/netboot

Steps to Reproduce:
1.establish functioning xen4.1.0(or earlier) dom0 x86_64 host
2.build a functional VM/domU, pointing to a x86_64 fc15 install target
3.boot up the VM and watch the install
  
Actual results:
no virtual block devices found by the anaconda; installation dies.

Expected results:
the guest os sees the virtual disks as an IDE disk drive.

Additional info:

http://lists.xensource.com/archives/html/xen-devel/2011-07/msg00062.html

I've been able to work around this bug by passing "xen_emul_unlug=never" to the kernel at boot time. However, including the xen-platform-pci.ko and xen-blkfront.ko modules in the initrd or toggling the appropriate kernel flags from =m to =y should fix it as well.

I don't see this bug in the 1386 image.

Comment 1 Peter Robinson 2011-07-06 08:03:06 UTC
Presumably this is meant to be assigned to anaconda

Comment 2 Chris Lumens 2011-07-06 17:50:04 UTC

*** This bug has been marked as a duplicate of bug 708267 ***


Note You need to log in before you can comment on or make changes to this bug.