Bug 71857 - Help is displayed in Mozilla
Summary: Help is displayed in Mozilla
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-network (Show other bugs)
(Show other bugs)
Version: null
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-19 21:00 UTC by Mikael Hallendal
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-22 19:56:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for yelp that fixes the problem when displaying HTML files (1.49 KB, patch)
2002-08-20 22:29 UTC, Mikael Hallendal
no flags Details | Diff

Description Mikael Hallendal 2002-08-19 21:00:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start redhat-config-network
2. Choose Help


Actual Results:  Mozilla is started to show the help

Expected Results:  It should be displayed in gnome-help (Yelp).

Additional info:

Comment 1 Leonid Mamtchenkov 2002-08-20 09:38:09 UTC
This seems to be the same problem as in #71859 and #71860.

Comment 2 Trond Eivind Glomsrxd 2002-08-20 15:58:41 UTC
Alex: Is there an easy way to replace the call to mozilla with a call to yelp?
If not, I'll just mark this as deferred...

Comment 3 Mikael Hallendal 2002-08-20 18:21:52 UTC
Am I correct to asume that you use gnome_url_show () to display the help?
Then the correct fix is to replace 

file:///path/to/file.html, with
ghelp:///path/to/file.html

I noticed however that Yelp seems to misunderstand that sometimes and give it to
gnome2-info2html (which results in gnome2-info2html hanging and Yelp hanging
waiting for it).

Since you won't be doing this change now (as I understood by the other modules I
reported this against) I won't look into it right away. If you _do_ want to make
the change I can try to look it ASAP and release a new Yelp (or give you a patch).

Comment 4 Mikael Hallendal 2002-08-20 22:29:19 UTC
Created attachment 71764 [details]
Patch for yelp that fixes the problem when displaying HTML files

Comment 5 Mikael Hallendal 2002-08-20 22:31:10 UTC
Added a patch for Yelp that is needed to be able to use it for displaying the
HTML documents correctly. I will release a new version of Yelp before Friday but
since you are in a pretty deep freeze you might want to just add a patch to the
current package instead.

Comment 6 Trond Eivind Glomsrxd 2002-08-22 19:56:23 UTC
Changed in CVS

Comment 7 Trond Eivind Glomsrxd 2002-08-28 16:39:03 UTC
1.1.17-1 has been built with this.


Note You need to log in before you can comment on or make changes to this bug.